]> gitweb @ CieloNegro.org - pkgsrc-firefox3.git/blobdiff - patches/patch-al
--enable-debug didn't work...
[pkgsrc-firefox3.git] / patches / patch-al
index a5e4a8e4cb68dc248c03cd5131f2783212d2219a..24e50db362715324edd6778e35758ad3dff150b3 100644 (file)
@@ -1,13 +1,26 @@
 $NetBSD$
 
---- nsprpub/pr/include/md/_darwin.h.orig       2009-02-03 23:16:39.000000000 +0900
-+++ nsprpub/pr/include/md/_darwin.h
-@@ -62,7 +62,7 @@
+--- modules/libpr0n/decoders/icon/Makefile.in.orig     2008-03-01 08:24:54.000000000 +0900
++++ modules/libpr0n/decoders/icon/Makefile.in
+@@ -67,7 +67,7 @@ ifeq ($(OS_ARCH),OS2)
+ PLATFORM = os2
+ endif
  
- #undef  HAVE_STACK_GROWING_UP
- #define HAVE_DLL
--#define USE_MACH_DYLD
-+#define USE_DLFCN
- #define _PR_HAVE_SOCKADDR_LEN  
- #define _PR_STAT_HAS_ST_ATIMESPEC
- #define _PR_HAVE_LARGE_OFF_T
+-ifeq ($(OS_ARCH),Darwin)
++ifneq (,$(filter mac cocoa,$(MOZ_WIDGET_TOOLKIT)))
+ PLATFORM = mac
+ endif
+@@ -127,4 +127,12 @@ include $(topsrcdir)/config/rules.mk
+ ifeq ($(OS_ARCH),Darwin)
+ EXTRA_DSO_LDOPTS += $(TK_LIBS)
++
++_libs_to_fix = \
++      -lxpcom \
++      -lxpcom_core \
++      -lxul \
++      -lmozjs \
++      $(filter -l%, $(NSS_LIBS))
++EXTRA_DSO_LDOPTS += $(foreach library, $(patsubst -l%, $(LIB_PREFIX)%$(DLL_SUFFIX), $(_libs_to_fix)), -dylib_file $(libdir)/$(MOZILLA_PKG_NAME)/$(library):$(DIST)/bin/$(library))
+ endif