]> gitweb @ CieloNegro.org - pkgsrc-firefox3.git/blobdiff - patches/patch-at
--enable-debug didn't work...
[pkgsrc-firefox3.git] / patches / patch-at
index 60d1bd5fdaa2b65ff16ad9bd54134b48aa0a4685..c2d9c96b34ba3a37852210d4a7b8bed4097e060f 100644 (file)
@@ -1,31 +1,21 @@
 $NetBSD$
 
---- security/manager/ssl/src/nsSSLThread.cpp.orig      2008-04-12 13:47:24.000000000 +0900
-+++ security/manager/ssl/src/nsSSLThread.cpp
-@@ -916,7 +916,7 @@ void nsSSLThread::Run(void)
-     // remember whether we'll write or read
-     nsSSLSocketThreadData::ssl_state busy_socket_ssl_state;
-   
--    {
-+    if (ssl_thread_singleton) {
-       // In this scope we need mutex protection,
-       // as we find out what needs to be done.
-       
-@@ -1078,7 +1078,7 @@ void nsSSLThread::Run(void)
-     // avoid setting event repeatedly
-     PRBool needToSetPollableEvent = PR_FALSE;
+--- gfx/src/thebes/Makefile.in.orig    2009-02-05 07:58:57.000000000 +0900
++++ gfx/src/thebes/Makefile.in
+@@ -139,6 +139,16 @@ EXTRA_DSO_LDOPTS += \
+               $(TK_LIBS) \
+               $(NULL)
  
--    {
-+    if (ssl_thread_singleton) {
-       nsAutoLock threadLock(ssl_thread_singleton->mMutex);
-       
-       mBusySocket->mThreadData->mSSLState = busy_socket_ssl_state;
-@@ -1102,7 +1102,7 @@ void nsSSLThread::Run(void)
-     }
-   }
--  {
-+  if (ssl_thread_singleton) {
-     nsAutoLock threadLock(ssl_thread_singleton->mMutex);
-     if (mBusySocket)
-     {
++ifeq ($(OS_ARCH),Darwin)
++_libs_to_fix = \
++      -lxul \
++      -lmozjs \
++      -lmozz \
++      -lmozlcms \
++      $(filter -l%, $(NSS_LIBS))
++EXTRA_DSO_LDOPTS += $(foreach library, $(patsubst -l%, $(LIB_PREFIX)%$(DLL_SUFFIX), $(_libs_to_fix)), -dylib_file $(libdir)/$(MOZILLA_PKG_NAME)/$(library):$(DIST)/bin/$(library))
++endif
++
+ ifdef MOZ_X11
+ EXTRA_DSO_LDOPTS += $(XLDFLAGS) $(XLIBS)
+ endif