]> gitweb @ CieloNegro.org - oh-my-god.git/blobdiff - src/Makefile.am
autoolisation
[oh-my-god.git] / src / Makefile.am
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644 (file)
index 0000000..8b88ce2
--- /dev/null
@@ -0,0 +1,23 @@
+DOCBOOK_MAIN = oh-my-god.xml
+
+DOCBOOK_FILES = \
+       $(DOCBOOK_MAIN) \
+       mission-chan.xml \
+       $(NULL)
+
+DOCBOOK_STYLESHEET = \
+       http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl
+
+EXTRA_DIST = $(DOCBOOK_FILES)
+
+html-local:
+       $(XMLLINT) --noout --xinclude --postvalid --noent $(DOCBOOK_MAIN)
+       $(XSLTPROC) \
+               --stringparam base.dir html/ \
+               --stringparam use.id.as.filename 1 \
+               --nonet \
+               $(DOCBOOK_STYLESHEET) \
+               $(DOCBOOK_MAIN)
+
+clean-local:
+       -rm -rf html