]> gitweb @ CieloNegro.org - pkgsrc-cinelerra-cv.git/commitdiff
wip...
authorPHO <pho@cielonegro.org>
Fri, 29 Jan 2010 07:20:15 +0000 (16:20 +0900)
committerPHO <pho@cielonegro.org>
Fri, 29 Jan 2010 07:20:15 +0000 (16:20 +0900)
Makefile
distinfo
patches/patch-audiooss_C [new file with mode: 0644]
patches/patch-ffmpeg_C [new file with mode: 0644]
patches/patch-filesystem_C [new file with mode: 0644]
patches/patch-quantize_c [new file with mode: 0644]
patches/patch-thread_C [new file with mode: 0644]

index a8b0f3c24db92fb4c74e38972fa7dbb6a292fbf5..357e23c72c1c5ea8e7602716958701aa29f0d26b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -57,4 +57,5 @@ post-patch:
 .include "../../multimedia/mjpegtools/buildlink3.mk"
 .include "../../multimedia/x264-devel/buildlink3.mk"
 .include "../../x11/libX11/buildlink3.mk"
 .include "../../multimedia/mjpegtools/buildlink3.mk"
 .include "../../multimedia/x264-devel/buildlink3.mk"
 .include "../../x11/libX11/buildlink3.mk"
+.include "../../x11/libXv/buildlink3.mk"
 .include "../../mk/bsd.pkg.mk"
 .include "../../mk/bsd.pkg.mk"
index fac9bc16e44f10adcbf7689a7c4c0c53ecd78590..35dd6577dc9f754bdbfd75f85f4703dcb9b04a6e 100644 (file)
--- a/distinfo
+++ b/distinfo
@@ -1,10 +1,15 @@
 $NetBSD$
 
 SHA1 (patch-alsa_m4) = 6a15005a08efa0ae96a44b2e9118a121f31f3fa5
 $NetBSD$
 
 SHA1 (patch-alsa_m4) = 6a15005a08efa0ae96a44b2e9118a121f31f3fa5
+SHA1 (patch-audiooss_C) = cd38e2cffdb3477732f929b41bf207d687ee008b
 SHA1 (patch-configure_in) = d6166055b7f6f4c083a4b480fc16244b323513e9
 SHA1 (patch-configure_in) = d6166055b7f6f4c083a4b480fc16244b323513e9
+SHA1 (patch-ffmpeg_C) = ff62028269104f5ebc9973872cdaaf407aa64dde
+SHA1 (patch-filesystem_C) = 98591b4ea29f303469552763193cd049105e2644
 SHA1 (patch-mpeg3ifo_c) = d0b9b7fbc16eeaa92f69d157c58485e6746f0eb9
 SHA1 (patch-mpeg3io_c) = 49a8714c37b201581e7bc89eb073fdd3346a2b01
 SHA1 (patch-mpeg3tocutil_c) = 8f5942d7cd8fbcb98748b0d8b04aa1c324f512f3
 SHA1 (patch-qtffmpeg_c) = a4cd7fee7fc5d11f0ddb3bc728795ac0e3bc2734
 SHA1 (patch-qtprivate_h) = 2c48c0719e4d5cad1ba8f9cfe03a9892ca49fe11
 SHA1 (patch-mpeg3ifo_c) = d0b9b7fbc16eeaa92f69d157c58485e6746f0eb9
 SHA1 (patch-mpeg3io_c) = 49a8714c37b201581e7bc89eb073fdd3346a2b01
 SHA1 (patch-mpeg3tocutil_c) = 8f5942d7cd8fbcb98748b0d8b04aa1c324f512f3
 SHA1 (patch-qtffmpeg_c) = a4cd7fee7fc5d11f0ddb3bc728795ac0e3bc2734
 SHA1 (patch-qtprivate_h) = 2c48c0719e4d5cad1ba8f9cfe03a9892ca49fe11
+SHA1 (patch-quantize_c) = 0c3062bf9357850e1d02a2456dff6c60254029f2
+SHA1 (patch-thread_C) = c11ffe8f2a0d7122dd2492fe4e40258212a3f62b
 SHA1 (patch-util_c) = 82c9512cc995c62b9300dce02261517d5b296879
 SHA1 (patch-util_c) = 82c9512cc995c62b9300dce02261517d5b296879
diff --git a/patches/patch-audiooss_C b/patches/patch-audiooss_C
new file mode 100644 (file)
index 0000000..d557d23
--- /dev/null
@@ -0,0 +1,13 @@
+$NetBSD$
+
+--- cinelerra/audiooss.C.orig  2010-01-29 07:11:32.000000000 +0000
++++ cinelerra/audiooss.C
+@@ -264,7 +264,7 @@ int AudioOSS::open_duplex()
+ // For the ice1712 the buffer must be maximum or no space will be allocated.
+                       if(device->driver == AUDIO_OSS_ENVY24) buffer_info = 0x7fff000f;
+                       if(ioctl(dsp_duplex[i], SNDCTL_DSP_SETFRAGMENT, &buffer_info)) printf("SNDCTL_DSP_SETFRAGMENT failed.\n");
+-                      if(ioctl(dsp_duplex[i], SNDCTL_DSP_SETDUPLEX, 1) == -1) printf("SNDCTL_DSP_SETDUPLEX failed\n");
++                      if(ioctl(dsp_duplex[i], SNDCTL_DSP_SETDUPLEX, reinterpret_cast<void*>(1)) == -1) printf("SNDCTL_DSP_SETDUPLEX failed\n");
+                       if(ioctl(dsp_duplex[i], SNDCTL_DSP_SETFMT, &format) < 0) printf("SNDCTL_DSP_SETFMT failed\n");
+                       int channels = device->get_ochannels();
+                       if(ioctl(dsp_duplex[i], SNDCTL_DSP_CHANNELS, &channels) < 0) printf("SNDCTL_DSP_CHANNELS failed\n");
diff --git a/patches/patch-ffmpeg_C b/patches/patch-ffmpeg_C
new file mode 100644 (file)
index 0000000..e31072f
--- /dev/null
@@ -0,0 +1,49 @@
+$NetBSD$
+
+--- cinelerra/ffmpeg.C.orig    2010-01-29 07:15:28.000000000 +0000
++++ cinelerra/ffmpeg.C
+@@ -2,7 +2,7 @@
+ #ifdef HAVE_SWSCALER
+ extern "C" {
+-#include <swscale.h>
++#include <libswscale/swscale.h>
+ }
+ #endif
+@@ -69,12 +69,10 @@ CodecID FFMPEG::codec_id(char *codec_str
+ PixelFormat FFMPEG::color_model_to_pix_fmt(int color_model) {
+       switch (color_model) 
+               { 
+-              case BC_YUV422: 
+-                        return PIX_FMT_YUV422;
+               case BC_RGB888:
+                       return PIX_FMT_RGB24;
+               case BC_BGR8888:  // NOTE: order flipped
+-                      return PIX_FMT_RGBA32;
++                      return PIX_FMT_RGBA;
+               case BC_BGR888:
+                       return PIX_FMT_BGR24;
+               case BC_YUV420P: 
+@@ -95,11 +93,9 @@ PixelFormat FFMPEG::color_model_to_pix_f
+ int FFMPEG::pix_fmt_to_color_model(PixelFormat pix_fmt) {
+       switch (pix_fmt) 
+               { 
+-              case PIX_FMT_YUV422:
+-                      return BC_YUV422;
+               case PIX_FMT_RGB24:
+                       return BC_RGB888;
+-              case PIX_FMT_RGBA32:
++              case PIX_FMT_RGBA:
+                       return BC_BGR8888;
+               case PIX_FMT_BGR24:
+                       return BC_BGR888;
+@@ -286,7 +282,7 @@ int FFMPEG::convert_cmodel(AVPicture *pi
+       // make an intermediate temp frame only if necessary
+       int cmodel_in = pix_fmt_to_color_model(pix_fmt_in);
+       if (cmodel_in == BC_TRANSPARENCY) {
+-              if (pix_fmt_in == PIX_FMT_RGBA32) {
++              if (pix_fmt_in == PIX_FMT_RGBA) {
+                       // avoid infinite recursion if things are broken
+                       printf("FFMPEG::convert_cmodel pix_fmt_in broken!\n");
+                       return 1;
diff --git a/patches/patch-filesystem_C b/patches/patch-filesystem_C
new file mode 100644 (file)
index 0000000..3a15f69
--- /dev/null
@@ -0,0 +1,22 @@
+$NetBSD$
+
+--- guicast/filesystem.C.orig  2010-01-29 07:08:10.000000000 +0000
++++ guicast/filesystem.C
+@@ -393,7 +393,7 @@ int FileSystem::test_filter(FileItem *fi
+ int FileSystem::update(char *new_dir)
+ {
+       DIR *dirstream;
+-      struct dirent64 *new_filename;
++      struct dirent *new_filename;
+       struct stat ostat;
+       struct tm *mod_time;
+       int i, j, k, include_this;
+@@ -408,7 +408,7 @@ int FileSystem::update(char *new_dir)
+       dirstream = opendir(current_dir);
+       if(!dirstream) return 1;          // failed to open directory
+-      while(new_filename = readdir64(dirstream))
++      while(new_filename = readdir(dirstream))
+       {
+               include_this = 1;
diff --git a/patches/patch-quantize_c b/patches/patch-quantize_c
new file mode 100644 (file)
index 0000000..30b179a
--- /dev/null
@@ -0,0 +1,12 @@
+$NetBSD$
+
+--- mpeg2enc/quantize.c.orig   2010-01-29 07:01:38.000000000 +0000
++++ mpeg2enc/quantize.c
+@@ -30,7 +30,6 @@
+ #include "config.h"
+ #include <stdio.h>
+ #include <math.h>
+-#include <fenv.h>
+ #include "global.h"
+ #include "cpu_accel.h"
+ #include "simd.h"
diff --git a/patches/patch-thread_C b/patches/patch-thread_C
new file mode 100644 (file)
index 0000000..58d1d32
--- /dev/null
@@ -0,0 +1,12 @@
+$NetBSD$
+
+--- guicast/thread.C.orig      2010-01-29 07:09:38.000000000 +0000
++++ guicast/thread.C
+@@ -239,6 +239,6 @@ int Thread::get_realtime()
+ int Thread::get_tid()
+ {
+-      return tid;
++      return reinterpret_cast<int>(tid);
+ }