]> gitweb @ CieloNegro.org - pkgsrc-cinelerra-cv.git/commitdiff
work in progress...
authorPHO <pho@cielonegro.org>
Fri, 29 Jan 2010 06:05:13 +0000 (15:05 +0900)
committerPHO <pho@cielonegro.org>
Fri, 29 Jan 2010 06:05:13 +0000 (15:05 +0900)
.gitignore [new file with mode: 0644]
DESCR [new file with mode: 0644]
Makefile [new file with mode: 0644]
PLIST [new file with mode: 0644]
distinfo [new file with mode: 0644]
patches/patch-alsa_m4 [new file with mode: 0644]
patches/patch-configure_in [new file with mode: 0644]
patches/patch-mpeg3ifo_c [new file with mode: 0644]
patches/patch-mpeg3io_c [new file with mode: 0644]
patches/patch-mpeg3tocutil_c [new file with mode: 0644]

diff --git a/.gitignore b/.gitignore
new file mode 100644 (file)
index 0000000..b8f99f5
--- /dev/null
@@ -0,0 +1 @@
+work
diff --git a/DESCR b/DESCR
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/Makefile b/Makefile
new file mode 100644 (file)
index 0000000..a8b0f3c
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,60 @@
+# $NetBSD$
+#
+
+DISTNAME=      cinelerra-cv
+CATEGORIES=    multimedia
+
+MAINTAINER=    pho@cielonegro.org
+HOMEPAGE=      http://cinelerra.org/
+COMMENT=       Non-linear video and audio editor and compositor
+LICENSE=       gnu-gpl-v2
+
+GIT_REPOSITORIES=      master
+#GIT_REPO.master=      git://git.cinelerra.org/j6t/cinelerra.git
+GIT_REPO.master=       /tmp/cinelerra.git # FIXME
+.include "../../wip/mk/git-package.mk"
+_GIT_FLAGS= # The repository is very large. We don't want git to be quiet.
+
+PKG_DESTDIR_SUPPORT=   user-destdir
+
+WRKSRC=                                ${WRKDIR}/cinelerra
+GNU_CONFIGURE=         yes
+USE_TOOLS+=                    pkg-config automake gmake
+USE_LIBTOOL=           yes
+USE_PKGLOCALEDIR=      yes
+USE_LANGUAGES=         c c++
+
+CONFIGURE_ARGS+=       --with-external-ffmpeg
+
+# These scripts don't pass the portability test but seem to be unused
+# anyway.
+CHECK_PORTABILITY_SKIP+= \
+       libmpeg3/configure \
+       quicktime/configure
+
+post-patch:
+       ${RUN} cd ${WRKSRC} && \
+               ./autogen.sh
+
+.include "../../audio/alsa-lib/buildlink3.mk"
+.include "../../audio/faac/buildlink3.mk"
+.include "../../audio/faad2/buildlink3.mk"
+.include "../../audio/lame/buildlink3.mk"
+.include "../../audio/liba52/buildlink3.mk"
+.include "../../audio/libsndfile/buildlink3.mk"
+.include "../../audio/libvorbis/buildlink3.mk"
+.include "../../wip/libuuid/buildlink3.mk" # should be in "devel" category
+.include "../../graphics/freetype2/buildlink3.mk"
+.include "../../graphics/jpeg/buildlink3.mk"
+.include "../../graphics/openexr/buildlink3.mk"
+.include "../../graphics/png/buildlink3.mk"
+.include "../../graphics/tiff/buildlink3.mk"
+.include "../../math/fftw/buildlink3.mk"
+.include "../../multimedia/ffmpeg/buildlink3.mk"
+.include "../../multimedia/libdv/buildlink3.mk"
+.include "../../multimedia/libogg/buildlink3.mk"
+.include "../../multimedia/libtheora/buildlink3.mk"
+.include "../../multimedia/mjpegtools/buildlink3.mk"
+.include "../../multimedia/x264-devel/buildlink3.mk"
+.include "../../x11/libX11/buildlink3.mk"
+.include "../../mk/bsd.pkg.mk"
diff --git a/PLIST b/PLIST
new file mode 100644 (file)
index 0000000..48d96a5
--- /dev/null
+++ b/PLIST
@@ -0,0 +1 @@
+@comment $NetBSD$
diff --git a/distinfo b/distinfo
new file mode 100644 (file)
index 0000000..b1342a3
--- /dev/null
+++ b/distinfo
@@ -0,0 +1,7 @@
+$NetBSD$
+
+SHA1 (patch-alsa_m4) = 6a15005a08efa0ae96a44b2e9118a121f31f3fa5
+SHA1 (patch-configure_in) = d6166055b7f6f4c083a4b480fc16244b323513e9
+SHA1 (patch-mpeg3ifo_c) = d0b9b7fbc16eeaa92f69d157c58485e6746f0eb9
+SHA1 (patch-mpeg3io_c) = 49a8714c37b201581e7bc89eb073fdd3346a2b01
+SHA1 (patch-mpeg3tocutil_c) = 8f5942d7cd8fbcb98748b0d8b04aa1c324f512f3
diff --git a/patches/patch-alsa_m4 b/patches/patch-alsa_m4
new file mode 100644 (file)
index 0000000..715f4d6
--- /dev/null
@@ -0,0 +1,13 @@
+$NetBSD$
+
+--- m4/alsa.m4.orig    2010-01-29 02:30:00.000000000 +0000
++++ m4/alsa.m4
+@@ -52,7 +52,7 @@ if test "$alsa_prefix" != "" ; then
+ fi
+ dnl add the alsa library
+-ALSA_LIBS="$ALSA_LIBS -lasound -lm -ldl -lpthread"
++ALSA_LIBS="$ALSA_LIBS -lasound -lm -lpthread"
+ LIBS=`echo $LIBS | sed 's/-lm//'`
+ LIBS=`echo $LIBS | sed 's/-ldl//'`
+ LIBS=`echo $LIBS | sed 's/-lpthread//'`
diff --git a/patches/patch-configure_in b/patches/patch-configure_in
new file mode 100644 (file)
index 0000000..7f24082
--- /dev/null
@@ -0,0 +1,14 @@
+$NetBSD$
+
+--- configure.in.orig  2010-01-29 05:05:28.000000000 +0000
++++ configure.in
+@@ -19,6 +19,9 @@ AC_ENABLE_SHARED
+ AC_DISABLE_STATIC
+ AC_PROG_LIBTOOL
++AC_CHECK_TYPE([__off64_t], [int64_t])
++AC_CHECK_HEADERS([mntent.h fstab.h])
++
+ # hack for libtool 1.5 -- this is ugly and probably wrong, but works
+ LTC_FLAGS="--tag=CC"
+ LTCXX_FLAGS="--tag=CXX"
diff --git a/patches/patch-mpeg3ifo_c b/patches/patch-mpeg3ifo_c
new file mode 100644 (file)
index 0000000..dbe07fb
--- /dev/null
@@ -0,0 +1,29 @@
+$NetBSD$
+
+--- libmpeg3/mpeg3ifo.c.orig   2010-01-29 04:58:31.000000000 +0000
++++ libmpeg3/mpeg3ifo.c
+@@ -1,4 +1,3 @@
+-#include <byteswap.h>
+ #include <dirent.h>
+ #include <fcntl.h>
+ #include <stdlib.h>
+@@ -6,10 +5,19 @@
+ #include <sys/types.h>
+ #include <unistd.h>
++#include "config.h"
+ #include "ifo.h"
+ #include "mpeg3private.h"
+ #include "mpeg3protos.h"
++#define bswap_16(x) ((((x) << 8) & 0xff00) | \
++                     (((x) >> 8) & 0x00ff))
++
++#define bswap_32(x) ((((x) << 24) & 0xff000000) | \
++                     (((x) <<  8) & 0x00ff0000) | \
++                     (((x) >>  8) & 0x0000ff00) | \
++                     (((x) >> 24) & 0x000000ff))
++
+ typedef struct
+ {
+ // Bytes relative to start of stream.
diff --git a/patches/patch-mpeg3io_c b/patches/patch-mpeg3io_c
new file mode 100644 (file)
index 0000000..5fd07c3
--- /dev/null
@@ -0,0 +1,99 @@
+$NetBSD$
+
+--- libmpeg3/mpeg3io.c.orig    2010-01-29 05:26:39.000000000 +0000
++++ libmpeg3/mpeg3io.c
+@@ -1,7 +1,7 @@
+ #include "mpeg3private.h"
+ #include "mpeg3protos.h"
+-#include <mntent.h>
++#include <fstab.h>
+ #include <stdint.h>
+ #include <stdlib.h>
+ #include <string.h>
+@@ -35,8 +35,8 @@ int mpeg3_copy_fs(mpeg3_fs_t *dst, mpeg3
+ int64_t mpeg3io_get_total_bytes(mpeg3_fs_t *fs)
+ {
+-      struct stat64 ostat;
+-      stat64(fs->path, &ostat);
++      struct stat ostat;
++      stat(fs->path, &ostat);
+       fs->total_bytes = ostat.st_size;
+       return fs->total_bytes;
+       
+@@ -50,8 +50,8 @@ int64_t mpeg3io_get_total_bytes(mpeg3_fs
+ int64_t mpeg3io_path_total_bytes(char *path)
+ {
+-      struct stat64 st;
+-      if(stat64(path, &st) < 0) return 0;
++      struct stat st;
++      if(stat(path, &st) < 0) return 0;
+       return st.st_size;
+ }
+@@ -61,7 +61,7 @@ int mpeg3io_open_file(mpeg3_fs_t *fs)
+       mpeg3_get_keys(fs->css, fs->path);
+ //printf("mpeg3io_open_file 1 %s\n", fs->path);
+-      if(!(fs->fd = fopen64(fs->path, "rb")))
++      if(!(fs->fd = fopen(fs->path, "rb")))
+       {
+               if (fs->path) fprintf(stderr,"[mpeg3io_open_file] Error opening file '%s': ",fs->path);
+               perror("");
+@@ -162,7 +162,7 @@ void mpeg3io_read_buffer(mpeg3_fs_t *fs)
+-              fseeko64(fs->fd, new_buffer_position, SEEK_SET);
++              fseek(fs->fd, new_buffer_position, SEEK_SET);
+               fread(fs->buffer, 1, remainder_start, fs->fd);
+@@ -177,7 +177,7 @@ void mpeg3io_read_buffer(mpeg3_fs_t *fs)
+               fs->buffer_position = fs->current_byte;
+               fs->buffer_offset = 0;
+-              result = fseeko64(fs->fd, fs->buffer_position, SEEK_SET);
++              result = fseek(fs->fd, fs->buffer_position, SEEK_SET);
+ //printf("mpeg3io_read_buffer 2 %llx %llx\n", fs->buffer_position, ftell(fs->fd));
+               fs->buffer_size = fread(fs->buffer, 1, MPEG3_IO_SIZE, fs->fd);
+@@ -216,27 +216,27 @@ void mpeg3io_complete_path(char *complet
+ int mpeg3io_device(char *path, char *device)
+ {
+-      struct stat64 file_st, device_st;
+-    struct mntent *mnt;
+-      FILE *fp;
++      struct stat file_st, device_st;
++    struct fstab *mnt;
++      int fp;
+-      if(stat64(path, &file_st) < 0)
++      if(stat(path, &file_st) < 0)
+       {
+               perror("mpeg3io_device");
+               return 1;
+       }
+-      fp = setmntent(MOUNTED, "r");
+-    while(fp && (mnt = getmntent(fp)))
++      fp = setfsent();
++    while(fp && (mnt = getfsent()))
+       {
+-              if(stat64(mnt->mnt_fsname, &device_st) < 0) continue;
++              if(stat(mnt->fs_spec, &device_st) < 0) continue;
+               if(device_st.st_rdev == file_st.st_dev)
+               {
+-                      strncpy(device, mnt->mnt_fsname, MPEG3_STRLEN);
++                      strncpy(device, mnt->fs_spec, MPEG3_STRLEN);
+                       break;
+               }
+       }
+-      endmntent(fp);
++      endfsent();
+       return 0;
+ }
diff --git a/patches/patch-mpeg3tocutil_c b/patches/patch-mpeg3tocutil_c
new file mode 100644 (file)
index 0000000..cbc6987
--- /dev/null
@@ -0,0 +1,16 @@
+$NetBSD$
+
+--- libmpeg3/mpeg3tocutil.c.orig       2010-01-29 05:32:17.000000000 +0000
++++ libmpeg3/mpeg3tocutil.c
+@@ -1415,8 +1415,8 @@ int64_t mpeg3_get_source_date(mpeg3_t *f
+ int64_t mpeg3_calculate_source_date(char *path)
+ {
+-      struct stat64 ostat;
+-      bzero(&ostat, sizeof(struct stat64));
+-      stat64(path, &ostat);
++      struct stat ostat;
++      bzero(&ostat, sizeof(struct stat));
++      stat(path, &ostat);
+       return ostat.st_mtime;
+ }