]> gitweb @ CieloNegro.org - pkgsrc-firefox3.git/blobdiff - Makefile
Give up --enable-crypto
[pkgsrc-firefox3.git] / Makefile
index aeb8b1e5b47cde0c2e40c2d2ee14a40c28066972..488ad42a12e7051af6c439ab51728462d7f328a3 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -27,7 +27,8 @@ PKGREVISION=          2
 
 XPTCFILES+=            xptcinvoke_asm_ppc_rhapsody.s
 
-XPTCFILES:=            ${XPTCFILES:C,^,../../firefox3/files/,}
+#XPTCFILES:=           ${XPTCFILES:C,^,../../../www/firefox3/files/,}
+XPTCFILES:=            ${XPTCFILES:C,^,../../../local/firefox3/files/,} # FIXME
 DESCR_SRC=             ${.CURDIR}/../../www/firefox/DESCR
 
 #DISTINFO_FILE=                ${.CURDIR}/../../www/firefox3/distinfo
@@ -70,6 +71,16 @@ stage-package:
        cp ${WRKSRC}/dist/firefox/components/browser.xpt \
           ${WRKSRC}/dist/bin/components/browser.xpt
 
+# Both libjar and filepicker has nsWildCard.cpp. This leads to a
+# linkage error on Darwin.
+.PHONY: rename-nsWildCard
+pre-configure: rename-nsWildCard
+rename-nsWildCard:
+       cp -f ${WRKSRC}/xpfe/components/filepicker/src/nsWildCard.cpp \
+               ${WRKSRC}/xpfe/components/filepicker/src/nsWildCard_filepicker.cpp
+       ${SED} -e 's!nsWildCard.cpp!nsWildCard_filepicker.cpp!g' -i .orig \
+               ${WRKSRC}/xpfe/components/filepicker/src/Makefile.in
+
 .if !empty(PKG_OPTIONS:Mmozilla-jemalloc)
 PLIST_SUBST+=          JEMALLOC=
 SCRIPTS_ENV+=          JEMALLOC=
@@ -116,6 +127,9 @@ CONFIGURE_ARGS+=    --disable-dbus
 # Avoids needing curl on Linux
 CONFIGURE_ARGS+=       --disable-crashreporter
 
+# FIXME: remove this if possible!
+CONFIGURE_ARGS+=       --disable-crypto
+
 PYTHON_FOR_BUILD_ONLY= yes
 .include "../../lang/python/application.mk"
 CONFIGURE_ENV+=                PYTHON=${PYTHONBIN:Q}