]> gitweb @ CieloNegro.org - pkgsrc-firefox3.git/blobdiff - patches/patch-dr
preflight...
[pkgsrc-firefox3.git] / patches / patch-dr
index fe5776d4b258dd8f4b815f1dcc3ee6617536d27e..d164f9b7cea7155aa0e7e40dfcd7e5de9152f34a 100644 (file)
@@ -1,9 +1,9 @@
 $NetBSD: patch-dr,v 1.1.1.1 2008/06/28 10:01:07 tnn Exp $
 
 diff -ruN ../Orig/mozilla/config/config.mk ./config/config.mk
---- ../Orig/mozilla/config/config.mk   2005-07-29 04:48:11.000000000 +0900
-+++ ./config/config.mk 2005-12-04 19:45:20.000000000 +0900
-@@ -121,7 +121,7 @@
+--- config/config.mk.orig      2008-08-14 19:00:34.000000000 +0900
++++ config/config.mk
+@@ -131,7 +131,7 @@ endif
  # but save the version to allow multiple versions of the same base
  # platform to be built in the same tree.
  #
@@ -12,3 +12,21 @@ diff -ruN ../Orig/mozilla/config/config.mk ./config/config.mk
  OS_RELEASE    := $(basename $(OS_RELEASE))
  
  # Allow the user to ignore the OS_VERSION, which is usually irrelevant.
+@@ -675,7 +675,7 @@ endif
+ ifeq ($(OS_ARCH),Darwin)
+ ifdef USE_PREBINDING
+ export LD_PREBIND=1
+-export LD_SEG_ADDR_TABLE=$(shell cd $(topsrcdir); pwd)/config/prebind-address-table
++export LD_PREBIND_ALLOW_OVERLAP=1
+ endif # USE_PREBINDING
+ ifdef NEXT_ROOT
+ export NEXT_ROOT
+@@ -752,7 +752,7 @@ MOZ_COMPONENTLIB_EXTRA_DSO_LIBS = mozcom
+ # Tell the linker where NSS is, if we're building crypto
+ ifeq ($(OS_ARCH),Darwin)
+ ifeq (,$(findstring crypto,$(MOZ_META_COMPONENTS)))
+-MOZ_COMPONENTLIB_EXTRA_LIBS = $(foreach library, $(patsubst -l%, $(LIB_PREFIX)%$(DLL_SUFFIX), $(filter -l%, $(NSS_LIBS))), -dylib_file @executable_path/$(library):$(DIST)/bin/$(library))
++MOZ_COMPONENTLIB_EXTRA_LIBS = $(foreach library, $(patsubst -l%, $(LIB_PREFIX)%$(DLL_SUFFIX), $(filter -l%, $(NSS_LIBS))), -dylib_file $(libdir)/$(MOZILLA_PKG_NAME)/$(library):$(DIST)/bin/$(library))
+ endif
+ endif
+ endif