]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/commitdiff
moved some USE_TOOLS from Makefile to stage0.mk, the actual user of those tools.
authorPHO <pho@cielonegro.org>
Thu, 22 Mar 2012 23:31:40 +0000 (08:31 +0900)
committerPHO <pho@cielonegro.org>
Thu, 22 Mar 2012 23:31:40 +0000 (08:31 +0900)
Makefile
stage0.mk

index f16a711d4754d77687b523474fd73dec618cc199..8ad240a370b1e78ff6b3a54fa5ea9ae749ea6416 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -50,7 +50,7 @@ CONFIGURE_ARGS+= --with-gcc=/usr/bin/gcc
 CONFIGURE_ARGS+= --with-gcc=${CCPATH}
 .endif
 
-USE_TOOLS+=    autoconf date gmake gtar perl perl:run
+USE_TOOLS+=    gmake perl:run
 CONFIGURE_ENV+=        PerlCmd=${PERL5:Q}
 
 # We don't want to extract all of the DISTFILEs.
index 39e0ded6be02353cbfe9df49da53e98f417a5b77..103ad3046e1715d084bd743a959b6348b7a75d46 100644 (file)
--- a/stage0.mk
+++ b/stage0.mk
@@ -1,5 +1,7 @@
 # $NetBSD$
 
+USE_TOOLS+=    autoconf date gtar perl
+
 # Build an unregisterised bootstrap compiler and install it directly
 # into the .buildlink directory. But we can't use "make install"
 # because we don't build it in a standard way (./configure && make).