]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/commitdiff
Refinement of phase messages
authorPHO <pho@cielonegro.org>
Fri, 3 Feb 2012 15:05:49 +0000 (00:05 +0900)
committerPHO <pho@cielonegro.org>
Fri, 3 Feb 2012 15:05:49 +0000 (00:05 +0900)
Makefile

index 67db91abaf629765fcf2cd58e5f712c38f6bfea9..83690d224fab72ddf1df68b384c5a2b71209593c 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -98,29 +98,29 @@ pre-configure: ${WRKDIR}/stamp-bootstrap-ghc
 
 ${WRKDIR}/stamp-prepare-bootstrap:
        ${RUN} cd ${WRKDIR} && \
-               ${ECHO} "====> Preparing bootstrap compiler" && \
+               ${PHASE_MSG} "Preparing bootstrap compiler for ${PKGNAME}" && \
                ${RM} -rf bootstrap && \
                ${MKDIR} -p bootstrap/${DISTNAME}/utils/ghc-pwd/dist-boot && \
-               ${GTAR} -cf - ${DISTNAME} | ${GTAR} -C bootstrap -xpvf - && \
+               ${GTAR} -cf - ${DISTNAME} | ${GTAR} -C bootstrap -xpf - && \
                ${LN} -sf ${PWD_CMD} bootstrap/${DISTNAME}/utils/ghc-pwd/dist-boot/ghc-pwd && \
-               ${TOUCH} $@
+               ${TOUCH} ${.TARGET}
 
 ${WRKDIR}/stamp-configure-hc-boot: ${WRKDIR}/stamp-prepare-bootstrap
        ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
-               ${ECHO} "====> Configuring for bootstrap compiler" && \
+               ${PHASE_MSG} "Configuring bootstrap compiler for ${PKGNAME}" && \
                ${SETENV} ${CONFIGURE_ENV} ./configure --enable-hc-boot --with-ghc="" ${CONFIGURE_ARGS} && \
-               ${TOUCH} $@
+               ${TOUCH} ${.TARGET}
 
 ${WRKDIR}/stamp-extract-hc: ${WRKDIR}/stamp-configure-hc-boot
        ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
-               ${ECHO} "====> Extracting bootstrap HC archive" && \
+               ${PHASE_MSG} "Extracting bootstrap HC archive for ${PKGNAME}" && \
                (cd .. && ${GTAR} -jxf ${DISTDIR}/${BOOTSTRAP_TARBALL}) && \
                ${SH} mkfiles && \
-               ${TOUCH} $@
+               ${TOUCH} ${.TARGET}
 
 ${WRKDIR}/stamp-rewrite-hc-paths: ${WRKDIR}/stamp-extract-hc
        ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
-               ${ECHO} "====> Rewriting GHC source paths" && \
+               ${PHASE_MSG} "Rewriting source paths in bootstrap compiler for ${PKGNAME}" && \
                ${SED} -e "s#\\[\\[PREFIX\\]\\]#${PREFIX}#g" ${BOOTSTRAP_BUILD_MK} > mk/build.mk && \
                for c in libraries/*/configure; do \
                        (cd `${DIRNAME} $$c` && ${SETENV} ${CONFIGURE_ENV} ${SH} configure ${CONFIGURE_ARGS}); \
@@ -131,11 +131,11 @@ ${WRKDIR}/stamp-rewrite-hc-paths: ${WRKDIR}/stamp-extract-hc
                        ${MV} -f $$i.tmp $$i; \
                done && \
                ${TOUCH} -r inplace/lib/package.conf.d */*/package-data.mk */*/*/package-data.mk && \
-               ${TOUCH} $@
+               ${TOUCH} ${.TARGET}
 
 ${WRKDIR}/stamp-bootstrap-ghc: ${WRKDIR}/stamp-rewrite-hc-paths
        ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
-               ${ECHO} "====> Building bootstrap compiler" && \
+               ${PHASE_MSG} "Building bootstrap compiler for ${PKGNAME}" && \
                ${GMAKE} bootstrapping-files && \
                ${GMAKE} all_ghc_stage2 && \
                ${GMAKE} inplace/bin/ghc-pkg && \
@@ -143,7 +143,7 @@ ${WRKDIR}/stamp-bootstrap-ghc: ${WRKDIR}/stamp-rewrite-hc-paths
                inplace/bin/ghc-pkg recache && \
                ${CP} -f inplace/bin/ghc-stage2 ${BUILDLINK_DIR}/bin/ghc && \
                ${CP} -f inplace/bin/ghc-pkg ${BUILDLINK_DIR}/bin/ghc-pkg && \
-               ${TOUCH} $@
+               ${TOUCH} ${.TARGET}
 
 do-configure:
 # Seemingly by mistake, ghc-7.0.3 has a prebuilt