]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/commitdiff
Try to avoid recompilation of bootstrap files as much as possible, even when the...
authorPHO <pho@cielonegro.org>
Fri, 3 Feb 2012 17:14:08 +0000 (02:14 +0900)
committerPHO <pho@cielonegro.org>
Fri, 3 Feb 2012 17:14:08 +0000 (02:14 +0900)
Makefile

index 83690d224fab72ddf1df68b384c5a2b71209593c..a50424af8c6bdf2f74c192c62f2475bc43e99f41 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -46,7 +46,7 @@ CONFIGURE_ARGS+= --with-gcc=/usr/bin/gcc
 CONFIGURE_ARGS+= --with-gcc=${CCPATH}
 .endif
 
-USE_TOOLS+=    gmake gtar perl:run
+USE_TOOLS+=                    gmake gtar perl:run
 CONFIGURE_ENV+=                PerlCmd=${PERL5:Q}
 
 # We don't want to extract all of the DISTFILEs.
@@ -101,7 +101,7 @@ ${WRKDIR}/stamp-prepare-bootstrap:
                ${PHASE_MSG} "Preparing bootstrap compiler for ${PKGNAME}" && \
                ${RM} -rf bootstrap && \
                ${MKDIR} -p bootstrap/${DISTNAME}/utils/ghc-pwd/dist-boot && \
-               ${GTAR} -cf - ${DISTNAME} | ${GTAR} -C bootstrap -xpf - && \
+               ${GTAR} -cf - ${DISTNAME} | ${GTAR} -C bootstrap -xf - && \
                ${LN} -sf ${PWD_CMD} bootstrap/${DISTNAME}/utils/ghc-pwd/dist-boot/ghc-pwd && \
                ${TOUCH} ${.TARGET}
 
@@ -112,10 +112,11 @@ ${WRKDIR}/stamp-configure-hc-boot: ${WRKDIR}/stamp-prepare-bootstrap
                ${TOUCH} ${.TARGET}
 
 ${WRKDIR}/stamp-extract-hc: ${WRKDIR}/stamp-configure-hc-boot
-       ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
+       ${RUN} cd ${WRKDIR}/bootstrap && \
                ${PHASE_MSG} "Extracting bootstrap HC archive for ${PKGNAME}" && \
-               (cd .. && ${GTAR} -jxf ${DISTDIR}/${BOOTSTRAP_TARBALL}) && \
-               ${SH} mkfiles && \
+               ${FIND} ${DISTNAME} -type d -o -type f | ${XARGS} ${TOUCH} -t 200001010000 && \
+               ${GTAR} -jxf ${DISTDIR}/${BOOTSTRAP_TARBALL} && \
+               (cd ${DISTNAME} && ${SH} mkfiles) && \
                ${TOUCH} ${.TARGET}
 
 ${WRKDIR}/stamp-rewrite-hc-paths: ${WRKDIR}/stamp-extract-hc