]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/commitdiff
Perform dead-code elimination only on NetBSD/i386 as it makes ld(1) take too much...
authorPHO <pho@cielonegro.org>
Sun, 4 Mar 2012 03:46:05 +0000 (12:46 +0900)
committerPHO <pho@cielonegro.org>
Sun, 4 Mar 2012 03:46:05 +0000 (12:46 +0900)
Makefile
files/bootstrap-bsd.mk

index 421ee4aed34c48dc58b0fd686664a5ee999de48b..fed43ba4311678b3fd79a210dca4e780a119a228 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -137,7 +137,21 @@ ${WRKDIR}/stamp-extract-hc: ${WRKDIR}/stamp-configure-hc-boot
 ${WRKDIR}/stamp-rewrite-hc-paths: ${WRKDIR}/stamp-extract-hc
        ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
                ${PHASE_MSG} "Rewriting source paths in bootstrapping compiler for ${PKGNAME}" && \
-               ${SED} -e "s#\\[\\[PREFIX\\]\\]#${PREFIX}#g" ${BOOTSTRAP_BUILD_MK} > mk/build.mk && \
+               ${SED} -e "s#\\[\\[PREFIX\\]\\]#${PREFIX}#g" ${BOOTSTRAP_BUILD_MK} > mk/build.mk
+.if ${MACHINE_ARCH} == "i386" && ${OPSYS} == "NetBSD"
+#   Unregisterised stage0 compiler gets too large (.text section being
+# over 64 MiB) without dead-code elimination, exceeding NetBSD/i386's
+# kernel default limitation.
+#   Note that stage1 currently doesn't bloat that much (about 42.6
+# MiB), but when it does we have to append
+# CONF_CC_OPTS_STAGE1="-fdata..." and
+# CONF_GCC_LINKER_OPTS_STAGE1="-Wl,--gc-sections" to CONFIGURE_ENV as
+# well. I guess that's a matter of time :(
+       ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
+               ${ECHO} "EXTRA_CC_OPTS += -fdata-sections -ffunction-sections" >> mk/build.mk && \
+               ${ECHO} "EXTRA_CC_OPTS += -Wl,--gc-sections" >> mk/build.mk
+.endif
+       ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
                for c in libraries/*/configure; do \
                        (cd `${DIRNAME} $$c` && ${SETENV} ${CONFIGURE_ENV} ${SH} configure ${CONFIGURE_ARGS}); \
                done && \
index fdf7056fe6e603294cd871c6cf58cd9f7c7f973d..aa46508b4782e5153b537fe0d9c0461f5a4d6d0d 100644 (file)
@@ -19,14 +19,3 @@ utils/ghc-pkg_dist-install_v_EXTRA_CC_OPTS += -L[[PREFIX]]/lib -lm -liconv -luti
 
 SRC_CC_OPTS += -I[[PREFIX]]/include
 INTEGER_LIBRARY = integer-simple
-
-#   Unregisterised stage0 compiler gets too large (.text section being
-# over 64 MiB) without dead-code elimination, exceeding NetBSD/i386's
-# kernel default limitation.
-#   Note that stage1 currently doesn't bloat that much (about 42.6
-# MiB), but when it does we have to append
-# CONF_CC_OPTS_STAGE1="-fdata..." and
-# CONF_GCC_LINKER_OPTS_STAGE1="-Wl,--gc-sections" to CONFIGURE_ENV as
-# well. I guess that's a matter of time :(
-EXTRA_CC_OPTS += -fdata-sections -ffunction-sections
-EXTRA_CC_OPTS += -Wl,--gc-sections