]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/commitdiff
...
authorPHO <pho@cielonegro.org>
Thu, 24 Dec 2009 04:24:03 +0000 (13:24 +0900)
committerPHO <pho@cielonegro.org>
Thu, 24 Dec 2009 04:24:03 +0000 (13:24 +0900)
Makefile
PLIST.NetBSD-i386
distinfo
patches/patch-ak [new file with mode: 0644]

index cee8f41950d10fdd38d3d4a97b0cf8ceb9038878..dbe893ed11387e7536a35466ff2a0170e7670b67 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -24,7 +24,20 @@ PKG_DESTDIR_SUPPORT= user-destdir
 # Unregisterised HC packages are architecture dependent. We have to
 # create more HC packages to support more architectures.
 ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386
-# Note: Darwin-*-powerpc is temporarily disabled for now. It shall come back in the near future. Thanks for your patience.
+# Note: Darwin-*-powerpc is temporarily disabled for now. It shall
+# come back in the near future. Thanks for your patience.
+
+# We must provide the real pass to gcc to the ./configure script,
+# because GHC has a runtime dependency on it. Aren't there any better
+# way than this?
+.include "../../mk/compiler.mk"
+.if empty(CCPATH)
+WARNINGS+= "This package depends on pkgsrc's undocumented variable CCPATH but it disappeared somehow."
+WARNINGS+= "Using hard-coded /usr/bin/gcc as the C compiler..."
+CONFIGURE_ARGS+= --with-gcc=/usr/bin/gcc
+.else
+CONFIGURE_ARGS+= --with-gcc=${CCPATH}
+.endif
 
 USE_TOOLS+=    gmake bsdtar perl:run
 CONFIGURE_ENV+=                PerlCmd=${PERL5:Q}
index ac21cb0c308d078ab46332326825f298b2ce745f..adcd1bda636f0c7a1104229d922c3e13eeddf320 100644 (file)
@@ -2004,7 +2004,7 @@ lib/${PKGNAME}/package.conf.d/dph-prim-seq-0.4.0-23150bc82f21bd4268b1551af7a3290
 lib/${PKGNAME}/package.conf.d/dph-seq-0.4.0-1f5167ea371010387123b68e975177b2.conf
 lib/${PKGNAME}/package.conf.d/extensible-exceptions-0.1.1.1-95db30aec4429ef77db437055a224b2f.conf
 lib/${PKGNAME}/package.conf.d/filepath-1.1.0.3-07812de93a673f50011d47451bcaac87.conf
-lib/${PKGNAME}/package.conf.d/${PKGNAME}-359a715c922d608b78bb3526fb1fa3dd.conf
+lib/${PKGNAME}/package.conf.d/${PKGNAME}-420e93e9c9ab3e0e8c66592c5c9f65e3.conf
 lib/${PKGNAME}/package.conf.d/ghc-binary-0.5.0.2-359d07c3fa596bee47da084cc306672c.conf
 lib/${PKGNAME}/package.conf.d/ghc-prim-0.2.0.0-3fbcc20c802efcd7c82089ec77d92990.conf
 lib/${PKGNAME}/package.conf.d/haskell98-1.0.1.1-0fdaf3b26bc38c43ce8371edf538dbf6.conf
index 7d8bd7cc28b669e9469859244ad526acd191182b..0d2fa76f99a2dd30f16eb3e83f0c00684ab67f45 100644 (file)
--- a/distinfo
+++ b/distinfo
@@ -13,3 +13,4 @@ SHA1 (patch-aa) = 61a7c503a9d8fd0e06d2f43926e3568f1ae1efb2
 SHA1 (patch-ab) = 68c78447f458958a8cfdd316991444fbdae5bc31
 SHA1 (patch-af) = 81ae37eeaca5992868f6955b99113aaae010df22
 SHA1 (patch-ah) = 5470ab2e1bb746ef3009e5f02ac0b28b8e9d9688
+SHA1 (patch-ak) = de67817c6e310c28e8012790bf0feb43d729dd30
diff --git a/patches/patch-ak b/patches/patch-ak
new file mode 100644 (file)
index 0000000..d5a5c44
--- /dev/null
@@ -0,0 +1,10 @@
+$NetBSD$
+
+--- libraries/integer-gmp/gmp/config.mk.in.orig        2009-12-11 03:25:53.000000000 +0900
++++ libraries/integer-gmp/gmp/config.mk.in
+@@ -5,3 +5,5 @@ endif
+ ifeq "$(HaveFrameworkGMP)" ""
+  HaveFrameworkGMP = @HaveFrameworkGMP@
+ endif
++
++libraries/integer-gmp_CC_OPTS += @CPPFLAGS@ @LDFLAGS@