From: PHO <pho@cielonegro.org>
Date: Fri, 22 Jan 2010 09:03:11 +0000 (+0900)
Subject: Fix: ghc-asm fails when PLATFORM=powerpc-unknown-darwin
X-Git-Tag: GHC-6.12.2~10
X-Git-Url: https://git.cielonegro.org/gitweb.cgi?a=commitdiff_plain;h=3df232b53c35f12792765ce200ca8f52310556e5;p=pkgsrc-ghc.git

Fix: ghc-asm fails when PLATFORM=powerpc-unknown-darwin
---

diff --git a/Makefile b/Makefile
index 399d09d..9d18724 100644
--- a/Makefile
+++ b/Makefile
@@ -49,7 +49,6 @@ CONFIGURE_ENV+=		PerlCmd=${PERL5:Q}
 # We don't want to extract all of the DISTFILEs.
 EXTRACT_ONLY=	${DISTNAME}-src.tar.bz2
 
-PLATFORM= ${MACHINE_ARCH}-unknown-${LOWER_OPSYS}
 CONFIGURE_ARGS += \
 	--build=${PLATFORM} \
 	--host=${PLATFORM} \
@@ -71,16 +70,17 @@ CONFIGURE_ARGS += \
 # running "ghc-pkg recache".
 
 .if ${MACHINE_ARCH} == "i386" && ${OPSYS} == "NetBSD"
-BOOTSTRAP_TARBALL  = ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
+PLATFORM           = i386-unknown-netbsd
 
 .elif ${MACHINE_ARCH} == "i386" && ${OPSYS} == "FreeBSD"
-BOOTSTRAP_TARBALL = ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
+PLATFORM           = i386-unknown-freebsd
 
 .elif ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
-BOOTSTRAP_TARBALL = ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap.mk
+PLATFORM           = powerpc-apple-darwin
+
 # Existence of libelf makes LeadingUnderscore being "NO", which is
 # incorrect. See ghc-6.12.1/aclocal.m4 (FP_LEADING_UNDERSCORE)
 CONFLICTS=	libelf-[0-9]*
@@ -89,6 +89,8 @@ CONFLICTS=	libelf-[0-9]*
 PKG_FAIL_REASON+=	"internal error: unsupported platform"
 .endif
 
+BOOTSTRAP_TARBALL = ${DISTNAME}-boot-${PLATFORM}.tar.bz2
+
 pre-configure:
 	${RUN} cd ${WRKDIR} && \
 		${ECHO} "====> Preparing bootstrap compiler" && \