]> gitweb @ CieloNegro.org - pkgsrc-firefox3.git/blobdiff - Makefile
Added a missing patch
[pkgsrc-firefox3.git] / Makefile
index 97f86e8e457acdb07294311ec8b5b607a057ac39..6fce328af44df4f1fa3e50d66573bea7cf20e918 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -71,6 +71,16 @@ stage-package:
        cp ${WRKSRC}/dist/firefox/components/browser.xpt \
           ${WRKSRC}/dist/bin/components/browser.xpt
 
+# Both libjar and filepicker has nsWildCard.cpp. This leads to a
+# linkage error on Darwin.
+.PHONY: rename-nsWildCard
+pre-configure: rename-nsWildCard
+rename-nsWildCard:
+       cp -f ${WRKSRC}/xpfe/components/filepicker/src/nsWildCard.cpp \
+               ${WRKSRC}/xpfe/components/filepicker/src/nsWildCard_filepicker.cpp
+       ${SED} -e 's!nsWildCard.cpp!nsWildCard_filepicker.cpp!g' -i .orig \
+               ${WRKSRC}/xpfe/components/filepicker/src/Makefile.in
+
 .if !empty(PKG_OPTIONS:Mmozilla-jemalloc)
 PLIST_SUBST+=          JEMALLOC=
 SCRIPTS_ENV+=          JEMALLOC=
@@ -117,6 +127,9 @@ CONFIGURE_ARGS+=    --disable-dbus
 # Avoids needing curl on Linux
 CONFIGURE_ARGS+=       --disable-crashreporter
 
+# FIXME: remove this after
+CONFIGURE_ARGS+=       --enable-debug
+
 PYTHON_FOR_BUILD_ONLY= yes
 .include "../../lang/python/application.mk"
 CONFIGURE_ENV+=                PYTHON=${PYTHONBIN:Q}