]> gitweb @ CieloNegro.org - pkgsrc-firefox3.git/commitdiff
Added a missing patch
authorPHO <pho@cielonegro.org>
Wed, 4 Feb 2009 23:01:05 +0000 (08:01 +0900)
committerPHO <pho@cielonegro.org>
Wed, 4 Feb 2009 23:01:05 +0000 (08:01 +0900)
Makefile
distinfo
patches/patch-at [new file with mode: 0644]

index 806e58c2d440ee41d61f49181fd74ec56c835c87..6fce328af44df4f1fa3e50d66573bea7cf20e918 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -127,6 +127,9 @@ CONFIGURE_ARGS+=    --disable-dbus
 # Avoids needing curl on Linux
 CONFIGURE_ARGS+=       --disable-crashreporter
 
+# FIXME: remove this after
+CONFIGURE_ARGS+=       --enable-debug
+
 PYTHON_FOR_BUILD_ONLY= yes
 .include "../../lang/python/application.mk"
 CONFIGURE_ENV+=                PYTHON=${PYTHONBIN:Q}
index 2fc5622739846c2f4820ba22843dd84e8ec24a33..b6985a04995fb8bb24013cf6284434e873ba1032 100644 (file)
--- a/distinfo
+++ b/distinfo
@@ -22,6 +22,7 @@ SHA1 (patch-ap) = 552694ac2d6ca713aec98ec394f1215c048c2392
 SHA1 (patch-aq) = 91a9a3f39286a9fedfd4122084f2fb9f427040fb
 SHA1 (patch-ar) = fab004236f5f0224386bb7ca7e64210a1b2b3cc5
 SHA1 (patch-as) = c0c53394379166419c2aaed8410715c6c98f8a14
+SHA1 (patch-at) = 486a94ff0fd7041621ec6306b9d5c66cf721ac3c
 SHA1 (patch-ax) = cbfe7a6392d5d2fefff123679ba1c056b1cc0aa9
 SHA1 (patch-ba) = 3bd713cf2edcc61f489cea8269ca60e27c26f1d9
 SHA1 (patch-bb) = c7286542a9fe97ac9819a00c345272efb7e90e9c
diff --git a/patches/patch-at b/patches/patch-at
new file mode 100644 (file)
index 0000000..1570a19
--- /dev/null
@@ -0,0 +1,19 @@
+$NetBSD$
+
+--- gfx/src/thebes/Makefile.in.orig    2009-02-05 07:58:57.000000000 +0900
++++ gfx/src/thebes/Makefile.in
+@@ -139,6 +139,14 @@ EXTRA_DSO_LDOPTS += \
+               $(TK_LIBS) \
+               $(NULL)
++ifeq ($(OS_ARCH),Darwin)
++_libs_to_fix = \
++      -lxul \
++      -lmozjs \
++      $(filter -l%, $(NSS_LIBS))
++EXTRA_DSO_LDOPTS += $(foreach library, $(patsubst -l%, $(LIB_PREFIX)%$(DLL_SUFFIX), $(_libs_to_fix)), -dylib_file $(libdir)/$(MOZILLA_PKG_NAME)/$(library):$(DIST)/bin/$(library))
++endif
++
+ ifdef MOZ_X11
+ EXTRA_DSO_LDOPTS += $(XLDFLAGS) $(XLIBS)
+ endif