]> gitweb @ CieloNegro.org - pkgsrc-cinelerra-cv.git/blobdiff - patches/patch-suv-data-Makefile_am
Don't try to link .a archives into .so modules...
[pkgsrc-cinelerra-cv.git] / patches / patch-suv-data-Makefile_am
diff --git a/patches/patch-suv-data-Makefile_am b/patches/patch-suv-data-Makefile_am
new file mode 100644 (file)
index 0000000..dfa4eb5
--- /dev/null
@@ -0,0 +1,36 @@
+$NetBSD$
+
+--- plugins/suv/data/Makefile.am.orig  2010-02-01 07:26:12.000000000 +0000
++++ plugins/suv/data/Makefile.am
+@@ -1,6 +1,5 @@
+-noinst_LIBRARIES = libimagedata.a
+-libimagedata_a_SOURCES =
+-nodist_libimagedata_a_SOURCES = suv.data
++noinst_LTLIBRARIES = libimagedata.la
++nodist_libimagedata_la_SOURCES = imagedata.c
+ PNGS = \
+       about.png \
+@@ -587,16 +586,18 @@ PNGS = \
+       zoomtumble_top.png \
+       zoomtumble_up.png
+-# this rule creates the .o file from the concatenated PNGs
+-.data.$(OBJEXT):
+-      $(OBJCOPY) -I binary -B $(OBJCOPYARCH) -O $(OBJCOPYTARGET) $< $@
++# this rule creates the .c file from the concatenated PNGs
++imagedata.c: suv.data
++      echo "unsigned char _binary_suv_data_start[] = {" > $@
++      cat $< | xxd -i >> $@
++      echo "};" >> $@
+ suv.data: $(PNGS)
+       $(top_builddir)/guicast/bootstrap $@ $^ || { rm -f $@; exit 1; }
+ clean-local:
+       rm -f suv.data
+- 
++
+ EXTRA_DIST = \
+       $(PNGS) \
+       buttonbar.xcf.bz2 \