]> gitweb @ CieloNegro.org - pkgsrc-cinelerra-cv.git/commitdiff
Don't try to link .a archives into .so modules...
authorPHO <pho@cielonegro.org>
Mon, 1 Feb 2010 08:11:06 +0000 (17:11 +0900)
committerPHO <pho@cielonegro.org>
Mon, 1 Feb 2010 08:11:06 +0000 (17:11 +0900)
Makefile
distinfo
patches/defaulttheme-Makefile_am [new file with mode: 0644]
patches/patch-bluedottheme-Makefile_am [new file with mode: 0644]
patches/patch-bluedottheme-data-Makefile_am [new file with mode: 0644]
patches/patch-defaulttheme-data-Makefile_am [new file with mode: 0644]
patches/patch-suv-Makefile_am [new file with mode: 0644]
patches/patch-suv-data-Makefile_am [new file with mode: 0644]

index 002c22d0ad58fd4101dcc09602c803ee812409b8..825e7dbd49fb403b1576fdc35ab6968dad62c043 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -36,6 +36,9 @@ post-patch:
        ${RUN} cd ${WRKSRC} && \
                ./autogen.sh
 
+# We need 'xxd' in build time, which is in the vim-share package.
+BUILD_DEPENDS+= vim-share-[0-9]*:../../editors/vim-share
+
 .include "../../audio/alsa-lib/buildlink3.mk"
 .include "../../audio/faac/buildlink3.mk"
 .include "../../audio/faad2/buildlink3.mk"
index ae5d82af1a594c1ba1be261bf078acc6353eaba5..c5b4b3ad946e4c3b73b0610b1cec4ced4f928701 100644 (file)
--- a/distinfo
+++ b/distinfo
@@ -2,10 +2,13 @@ $NetBSD$
 
 SHA1 (patch-alsa_m4) = 8622849fd0539f961be8c42bb95f5df5284e8c61
 SHA1 (patch-audiooss_C) = cd38e2cffdb3477732f929b41bf207d687ee008b
+SHA1 (patch-bluedottheme-Makefile_am) = 06fcec076630967cd5f286f831458c7c64b52113
+SHA1 (patch-bluedottheme-data-Makefile_am) = 6ca22da9bb10d12c9fb98bc854b54d2f981100c4
 SHA1 (patch-cdripper_C) = 5d8ada1407fb6f5054929a9886648117c0ea83b8
 SHA1 (patch-cdripper_h) = 6fb86963a24fc46f72c6244be37079c9d15b742a
 SHA1 (patch-cinelerra_Makefile_am) = a1ff38ffdac1e874a32904bdc8fb1e7e5a0a904f
 SHA1 (patch-configure_in) = 415f6fcb23bd0fb7d496892edfc4e7655847e993
+SHA1 (patch-defaulttheme-data-Makefile_am) = cc65f376db2ade2f3d4d00eda6b0aa45b7cfebbb
 SHA1 (patch-ffmpeg_C) = ff62028269104f5ebc9973872cdaaf407aa64dde
 SHA1 (patch-filesystem_C) = 98591b4ea29f303469552763193cd049105e2644
 SHA1 (patch-ieee1394_ioctl_h) = 0939e6b1fa2cfbdd035c4100babb2804697636f1
@@ -17,6 +20,8 @@ SHA1 (patch-qtprivate_h) = 2c48c0719e4d5cad1ba8f9cfe03a9892ca49fe11
 SHA1 (patch-quantize_c) = 0c3062bf9357850e1d02a2456dff6c60254029f2
 SHA1 (patch-renderfarm_C) = 88e7fe3fb6d7ac8c294f26e067c8ad4fc4f06bbb
 SHA1 (patch-renderfarmclient_C) = 3564f488fd1190a550d490813bbafe9208fbbfaf
+SHA1 (patch-suv-Makefile_am) = 1be34e033f5a399f5cf4cd29dfe45bf624128395
+SHA1 (patch-suv-data-Makefile_am) = 97bc93a05f0a1bb2102394c9bdb67767ccc4c26c
 SHA1 (patch-thread_C) = c11ffe8f2a0d7122dd2492fe4e40258212a3f62b
 SHA1 (patch-title_C) = 9792fc3a33f1a7f434b6c18fa6ab5b87a807fa50
 SHA1 (patch-util_c) = e979f22de2ffc5ff2275ea0865e77f342042808f
diff --git a/patches/defaulttheme-Makefile_am b/patches/defaulttheme-Makefile_am
new file mode 100644 (file)
index 0000000..05b8400
--- /dev/null
@@ -0,0 +1,13 @@
+$NetBSD$
+
+--- plugins/defaulttheme/Makefile.am.orig      2010-02-01 07:58:01.000000000 +0000
++++ plugins/defaulttheme/Makefile.am
+@@ -2,7 +2,7 @@ SUBDIRS = data
+ plugin_LTLIBRARIES = blondtheme.la
+ blondtheme_la_LDFLAGS = -avoid-version -module -shared 
+-blondtheme_la_LIBADD = data/libimagedata.a
++blondtheme_la_LIBADD = data/libimagedata.la
+ blondtheme_la_SOURCES = defaulttheme.C 
+ AM_CXXFLAGS = $(LARGEFILE_CFLAGS)
diff --git a/patches/patch-bluedottheme-Makefile_am b/patches/patch-bluedottheme-Makefile_am
new file mode 100644 (file)
index 0000000..aea6002
--- /dev/null
@@ -0,0 +1,13 @@
+$NetBSD$
+
+--- plugins/bluedottheme/Makefile.am.orig      2010-02-01 07:55:25.000000000 +0000
++++ plugins/bluedottheme/Makefile.am
+@@ -2,7 +2,7 @@ SUBDIRS = data
+ plugin_LTLIBRARIES = bluedottheme.la
+ bluedottheme_la_LDFLAGS = -avoid-version -module -shared 
+-bluedottheme_la_LIBADD = data/libimagedata.a
++bluedottheme_la_LIBADD = data/libimagedata.la
+ bluedottheme_la_SOURCES = bluedottheme.C 
+ AM_CXXFLAGS = $(LARGEFILE_CFLAGS)
diff --git a/patches/patch-bluedottheme-data-Makefile_am b/patches/patch-bluedottheme-data-Makefile_am
new file mode 100644 (file)
index 0000000..c5b8513
--- /dev/null
@@ -0,0 +1,29 @@
+$NetBSD$
+
+--- plugins/bluedottheme/data/Makefile.am.orig 2010-02-01 07:53:45.000000000 +0000
++++ plugins/bluedottheme/data/Makefile.am
+@@ -1,6 +1,5 @@
+-noinst_LIBRARIES = libimagedata.a
+-libimagedata_a_SOURCES =
+-nodist_libimagedata_a_SOURCES = bluedottheme.data
++noinst_LTLIBRARIES = libimagedata.la
++nodist_libimagedata_la_SOURCES = imagedata.c
+ PNGS = \
+ about_bg.png \
+@@ -372,10 +371,11 @@ ymeter_yellow.png \
+ zoombar_left.png \
+ zoombar_right.png
+-
+-# this rule creates the .o file from the concatenated PNGs
+-.data.$(OBJEXT):
+-      $(OBJCOPY) -I binary -B $(OBJCOPYARCH) -O $(OBJCOPYTARGET) $< $@
++# this rule creates the .c file from the concatenated PNGs
++imagedata.c: bluedottheme.data
++      echo "unsigned char _binary_bluedottheme_data_start[] = {" > $@
++      cat $< | xxd -i >> $@
++      echo "};" >> $@
+ bluedottheme.data: $(PNGS)
+       $(top_builddir)/guicast/bootstrap $@ $^ || { rm -f $@; exit 1; }
diff --git a/patches/patch-defaulttheme-data-Makefile_am b/patches/patch-defaulttheme-data-Makefile_am
new file mode 100644 (file)
index 0000000..42248c1
--- /dev/null
@@ -0,0 +1,36 @@
+$NetBSD$
+
+--- plugins/defaulttheme/data/Makefile.am.orig 2010-02-01 07:55:54.000000000 +0000
++++ plugins/defaulttheme/data/Makefile.am
+@@ -1,6 +1,5 @@
+-noinst_LIBRARIES = libimagedata.a
+-libimagedata_a_SOURCES =
+-nodist_libimagedata_a_SOURCES = defaulttheme.data
++noinst_LTLIBRARIES = libimagedata.la
++nodist_libimagedata_la_SOURCES = imagedata.c
+ # The following bash scripts makes up the list of used PNG's
+@@ -318,16 +317,18 @@ ymeter_yellow.png \
+ zoombar_left.png \
+ zoombar_right.png
+-# this rule creates the .o file from the concatenated PNGs
+-.data.$(OBJEXT):
+-      $(OBJCOPY) -I binary -B $(OBJCOPYARCH) -O $(OBJCOPYTARGET) $< $@
++# this rule creates the .c file from the concatenated PNGs
++imagedata.c: defaulttheme.data
++      echo "unsigned char _binary_defaulttheme_data_start[] = {" > $@
++      cat $< | xxd -i >> $@
++      echo "};" >> $@
+ defaulttheme.data: $(PNGS)
+       $(top_builddir)/guicast/bootstrap $@ $^ || { rm -f $@; exit 1; }
+ clean-local:
+       rm -f defaulttheme.data
+- 
++
+ EXTRA_DIST = \
+       $(PNGS) \
+       about.xcf.bz2 \
diff --git a/patches/patch-suv-Makefile_am b/patches/patch-suv-Makefile_am
new file mode 100644 (file)
index 0000000..97de32a
--- /dev/null
@@ -0,0 +1,13 @@
+$NetBSD$
+
+--- plugins/suv/Makefile.am.orig       2010-02-01 07:20:36.000000000 +0000
++++ plugins/suv/Makefile.am
+@@ -2,7 +2,7 @@ SUBDIRS = data
+ plugin_LTLIBRARIES = suv.la
+ suv_la_LDFLAGS = -avoid-version -module -shared 
+-suv_la_LIBADD = data/libimagedata.a
++suv_la_LIBADD = data/libimagedata.la
+ suv_la_SOURCES = suv.C 
+ AM_CXXFLAGS = $(LARGEFILE_CFLAGS)
diff --git a/patches/patch-suv-data-Makefile_am b/patches/patch-suv-data-Makefile_am
new file mode 100644 (file)
index 0000000..dfa4eb5
--- /dev/null
@@ -0,0 +1,36 @@
+$NetBSD$
+
+--- plugins/suv/data/Makefile.am.orig  2010-02-01 07:26:12.000000000 +0000
++++ plugins/suv/data/Makefile.am
+@@ -1,6 +1,5 @@
+-noinst_LIBRARIES = libimagedata.a
+-libimagedata_a_SOURCES =
+-nodist_libimagedata_a_SOURCES = suv.data
++noinst_LTLIBRARIES = libimagedata.la
++nodist_libimagedata_la_SOURCES = imagedata.c
+ PNGS = \
+       about.png \
+@@ -587,16 +586,18 @@ PNGS = \
+       zoomtumble_top.png \
+       zoomtumble_up.png
+-# this rule creates the .o file from the concatenated PNGs
+-.data.$(OBJEXT):
+-      $(OBJCOPY) -I binary -B $(OBJCOPYARCH) -O $(OBJCOPYTARGET) $< $@
++# this rule creates the .c file from the concatenated PNGs
++imagedata.c: suv.data
++      echo "unsigned char _binary_suv_data_start[] = {" > $@
++      cat $< | xxd -i >> $@
++      echo "};" >> $@
+ suv.data: $(PNGS)
+       $(top_builddir)/guicast/bootstrap $@ $^ || { rm -f $@; exit 1; }
+ clean-local:
+       rm -f suv.data
+- 
++
+ EXTRA_DIST = \
+       $(PNGS) \
+       buttonbar.xcf.bz2 \