]> gitweb @ CieloNegro.org - pkgsrc-firefox3.git/commitdiff
Bugfix of the patch for nsSSLThread.cpp
authorPHO <pho@cielonegro.org>
Wed, 4 Feb 2009 10:44:23 +0000 (19:44 +0900)
committerPHO <pho@cielonegro.org>
Wed, 4 Feb 2009 10:44:23 +0000 (19:44 +0900)
distinfo
patches/patch-at

index 45cabbc8f4ab7e64709d099d1cef83ec9249a220..f0cbaf67da68705c4bf2136281c5f0707566ec83 100644 (file)
--- a/distinfo
+++ b/distinfo
@@ -22,7 +22,7 @@ SHA1 (patch-ap) = 552694ac2d6ca713aec98ec394f1215c048c2392
 SHA1 (patch-aq) = 91a9a3f39286a9fedfd4122084f2fb9f427040fb
 SHA1 (patch-ar) = fab004236f5f0224386bb7ca7e64210a1b2b3cc5
 SHA1 (patch-as) = c0c53394379166419c2aaed8410715c6c98f8a14
-SHA1 (patch-at) = f831b63b90a7c672b36f29070620f93beda663d1
+SHA1 (patch-at) = ae3a1a5e7938b0afe6a825217767e8ba87ec6dbf
 SHA1 (patch-ax) = cbfe7a6392d5d2fefff123679ba1c056b1cc0aa9
 SHA1 (patch-ba) = 3bd713cf2edcc61f489cea8269ca60e27c26f1d9
 SHA1 (patch-bb) = c7286542a9fe97ac9819a00c345272efb7e90e9c
index cdb29dfa64d15ee439c1effe2b502cde406da26e..f1d89e55d58a6c1dfb220c73708ac0472bffdaa0 100644 (file)
@@ -2,28 +2,20 @@ $NetBSD$
 
 --- security/manager/ssl/src/nsSSLThread.cpp.orig      2008-04-12 13:47:24.000000000 +0900
 +++ security/manager/ssl/src/nsSSLThread.cpp
-@@ -1102,7 +1102,24 @@ void nsSSLThread::Run(void)
+@@ -1078,7 +1078,7 @@ void nsSSLThread::Run(void)
+     // avoid setting event repeatedly
+     PRBool needToSetPollableEvent = PR_FALSE;
+-    {
++    if (ssl_thread_singleton) {
+       nsAutoLock threadLock(ssl_thread_singleton->mMutex);
+       
+       mBusySocket->mThreadData->mSSLState = busy_socket_ssl_state;
+@@ -1102,7 +1102,7 @@ void nsSSLThread::Run(void)
      }
    }
  
 -  {
-+  /*
-+    Sometimes the singleton object is gone at this time. I don't know why. (PHO)
-+    
-+    #0  nsSSLThread::~nsSSLThread (this=0x7492050) at nsSSLThread.cpp:61
-+    #1  0x017c6d7c in nsNSSComponent::~nsNSSComponent (this=0x748cb80) at nsNSSComponent.cpp:318
-+    #2  0x017c279c in nsNSSComponent::Release (this=0x748cb80) at nsNSSComponent.cpp:1774
-+    #3  0x017d0d04 in nsNSSComponentConstructor (aOuter=0x748cb80, aIID=@0x1b5dfc0, aResult=0xf0305a28) at nsNSSModule.cpp:166
-+    #4  0x01a13528 in nsComponentManagerImpl::CreateInstance () at nsCertTree.cpp:1300
-+    #5  0x01a13728 in nsComponentManagerImpl::GetService () at nsCertTree.cpp:1300
-+    #6  0x019d1ed4 in nsGetServiceByCIDWithError::operator() () at nsCertTree.cpp:1300
-+    #7  0x019d0c54 in nsCOMPtr_base::assign_from_gs_cid_with_error () at nsCertTree.cpp:1300
-+    #8  0x017cc860 in nsHandleSSLError (socketInfo=0x63aa2c0, err=-12268) at ../../../../dist/include/xpcom/nsCOMPtr.h:669
-+    #9  0x017cd120 in nsSSLThread::checkHandshake (bytesTransfered=-1, wasReading=0, ssl_layer_fd=0x63a5a90, socketInfo=0x63aa2c0) at nsNSSIOLayer.cpp:1674
-+    #10 0x017bce68 in nsSSLThread::Run (this=0x63a32d0) at nsSSLThread.cpp:1040
-+    #11 0x00064670 in _pt_root ()
-+    #12 0x9002bd08 in _pthread_body ()
-+   */
 +  if (ssl_thread_singleton) {
      nsAutoLock threadLock(ssl_thread_singleton->mMutex);
      if (mBusySocket)