]> gitweb @ CieloNegro.org - pkgsrc-firefox3.git/commitdiff
Added the patch for nsStackWalk.cpp
authorPHO <pho@cielonegro.org>
Tue, 3 Feb 2009 16:09:19 +0000 (01:09 +0900)
committerPHO <pho@cielonegro.org>
Tue, 3 Feb 2009 16:09:19 +0000 (01:09 +0900)
distinfo
patches/patch-ai [new file with mode: 0644]

index 6b002056cdff3dc000827d50cd6dd07c1ab228b6..ab7bcfdb8daddfdab0456c3ba3f3cdd72f28168d 100644 (file)
--- a/distinfo
+++ b/distinfo
@@ -11,6 +11,7 @@ SHA1 (patch-ae) = fea251aabc772c3d4ad3044c8295af45cc9cab2d
 SHA1 (patch-af) = 74ebf2c0f079b37b1e9023235a56027d4f395ea4
 SHA1 (patch-ag) = f23dd38f6cfc4d2287ebeac57307c005521acb39
 SHA1 (patch-ah) = dc79aa2d7f5ddc93ecf2a63e2d38e497c5a156cc
+SHA1 (patch-ai) = 641442d96b0443a24c91192fcf33f301001fb8f3
 SHA1 (patch-ao) = 3b283b2cbb13464c788d11b3c7297dfb90b2d755
 SHA1 (patch-ap) = 552694ac2d6ca713aec98ec394f1215c048c2392
 SHA1 (patch-aq) = fcd28831cf5fc012afba386ceeee95945bf82606
diff --git a/patches/patch-ai b/patches/patch-ai
new file mode 100644 (file)
index 0000000..154148e
--- /dev/null
@@ -0,0 +1,40 @@
+$NetBSD$
+
+--- xpcom/base/nsStackWalk.cpp.orig    2009-02-04 01:06:49.000000000 +0900
++++ xpcom/base/nsStackWalk.cpp
+@@ -1107,7 +1107,7 @@ NS_FormatCodeAddressDetails(void *aPC, c
+ // WIN32 x86 stack walking code
+ // i386 or PPC Linux stackwalking code or Solaris
+-#elif HAVE_DLADDR && (HAVE__UNWIND_BACKTRACE || (defined(linux) && defined(__GNUC__) && (defined(__i386) || defined(PPC))) || (defined(__sun) && (defined(__sparc) || defined(sparc) || defined(__i386) || defined(i386))) || (defined(XP_MACOSX) && (defined(__ppc__) || defined(__i386))))
++#elif HAVE_DLADDR && (HAVE__UNWIND_BACKTRACE || (defined(linux) && defined(__GNUC__) && (defined(__i386) || defined(PPC))) || (defined(__sun) && (defined(__sparc) || defined(sparc) || defined(__i386) || defined(i386))) || (defined(__APPLE__) && (defined(__ppc__) || defined(__i386))))
+ #include <stdlib.h>
+ #include <string.h>
+@@ -1124,7 +1124,7 @@ NS_FormatCodeAddressDetails(void *aPC, c
+ #define __USE_GNU
+ #endif
+-#if defined(HAVE_LIBDL) || defined(XP_MACOSX)
++#if defined(HAVE_LIBDL) || defined(__APPLE__)
+ #include <dlfcn.h>
+ #endif
+@@ -1394,7 +1394,7 @@ NS_FormatCodeAddressDetails(void *aPC, c
+ #else // not __sun-specific
+-#if (defined(linux) && defined(__GNUC__) && (defined(__i386) || defined(PPC))) || (defined(XP_MACOSX) && (defined(__i386) || defined(__ppc__))) // i386 or PPC Linux or Mac stackwalking code
++#if (defined(linux) && defined(__GNUC__) && (defined(__i386) || defined(PPC))) || (defined(__APPLE__) && (defined(__i386) || defined(__ppc__))) // i386 or PPC Linux or Mac stackwalking code
+ #if __GLIBC__ > 2 || __GLIBC_MINOR > 1
+ #define HAVE___LIBC_STACK_END 1
+@@ -1437,7 +1437,7 @@ NS_StackWalk(NS_WalkStackCallback aCallb
+         (long(next) & 3)) {
+       break;
+     }
+-#if (defined(__ppc__) && defined(XP_MACOSX)) || defined(__powerpc64__)
++#if (defined(__ppc__) && defined(__APPLE__)) || defined(__powerpc64__)
+     // ppc mac or powerpc64 linux
+     void *pc = *(bp+2);
+ #else // i386 or powerpc32 linux