]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
7.0.1 for powerpc-apple-darwin (still crashes on --interactive)
[pkgsrc-ghc.git] / Makefile
index ae6de059ef03e59ec893ff8469b6a033deec34f6..04bc5cad20044947ed2d7c5524ea115c59d08936 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,9 @@
 # $NetBSD: Makefile,v 1.42 2008/07/07 14:58:00 kristerw Exp $
 
 DISTNAME=              ghc-${VERSION}
-VERSION=               6.12.3
+VERSION=               7.0.1
 CATEGORIES=            lang
-MASTER_SITES=  http://darcs.haskell.org/download/dist/${VERSION}/
+MASTER_SITES=  http://new-www.haskell.org/ghc/dist/${VERSION}/
 MAINTAINER=            kristerw@NetBSD.org
 HOMEPAGE=              http://www.haskell.org/ghc/
 COMMENT=               Compiler for the functional language Haskell
@@ -28,7 +28,11 @@ PKG_DESTDIR_SUPPORT= user-destdir
 # these packages are built with integer-simple, not integer-gmp, to
 # reduce some complexity by not depending on the GMP. The resulting
 # registerised GHC uses integer-gmp so this won't be a problem.
-ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386 Darwin-*-powerpc
+#
+# If you want to build HC packages yourself, follow instructions in
+# the ./TODO file.
+#ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386 Darwin-*-powerpc
+ONLY_FOR_PLATFORM= Darwin-*-powerpc
 
 # We must provide the real pass to gcc to the ./configure script,
 # because GHC has a runtime dependency on it. Aren't there any ways
@@ -91,19 +95,34 @@ PKG_FAIL_REASON+=   "internal error: unsupported platform"
 
 BOOTSTRAP_TARBALL = ${DISTNAME}-boot-${PLATFORM}.tar.bz2
 
-pre-configure:
+pre-configure: ${WRKDIR}/stamp-bootstrap-ghc
+
+${WRKDIR}/stamp-prepare-bootstrap:
        ${RUN} cd ${WRKDIR} && \
                ${ECHO} "====> Preparing bootstrap compiler" && \
+               ${RM} -rf bootstrap && \
                ${MKDIR} bootstrap && \
                ${CP} -r ${DISTNAME} bootstrap && \
                cd bootstrap/${DISTNAME} && \
                ${LN} -sf ${PWD_CMD} utils/ghc-pwd/ghc-pwd && \
+               ${TOUCH} $@
+
+${WRKDIR}/stamp-configure-hc-boot: ${WRKDIR}/stamp-prepare-bootstrap
+       ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
                ${ECHO} "====> Configuring for bootstrap compiler" && \
                ${SETENV} ${CONFIGURE_ENV} ./configure --enable-hc-boot --with-ghc="" ${CONFIGURE_ARGS} && \
+               ${TOUCH} $@
+
+${WRKDIR}/stamp-extract-hc: ${WRKDIR}/stamp-configure-hc-boot
+       ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
                ${ECHO} "====> Extracting bootstrap HC archive" && \
                (cd .. && bsdtar jxfm ${DISTDIR}/${BOOTSTRAP_TARBALL}) && \
                ${SH} mkfiles && \
-               ${ECHO} "====> Building bootstrap compiler" && \
+               ${TOUCH} $@
+
+${WRKDIR}/stamp-rewrite-hc-paths: ${WRKDIR}/stamp-extract-hc
+       ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
+               ${ECHO} "====> Rewriting GHC source paths" && \
                ${SED} -e "s#\\[\\[PREFIX\\]\\]#${PREFIX}#g" ${BOOTSTRAP_BUILD_MK} > mk/build.mk && \
                for c in libraries/*/configure; do \
                        (cd `${DIRNAME} $$c` && ${SETENV} ${CONFIGURE_ENV} ${SH} configure ${CONFIGURE_ARGS}); \
@@ -113,13 +132,19 @@ pre-configure:
                        ${MV} -f $$i.tmp $$i; \
                done && \
                ${TOUCH} -r inplace/lib/package.conf.d */*/package-data.mk */*/*/package-data.mk && \
+               ${TOUCH} $@
+
+${WRKDIR}/stamp-bootstrap-ghc: ${WRKDIR}/stamp-rewrite-hc-paths
+       ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
+               ${ECHO} "====> Building bootstrap compiler" && \
                ${GMAKE} bootstrapping-files && \
                ${GMAKE} all_ghc_stage2 && \
                ${GMAKE} inplace/bin/ghc-pkg && \
                ${GMAKE} inplace/lib/unlit && \
                inplace/bin/ghc-pkg recache && \
-               ${CP} inplace/bin/ghc-stage2 ${BUILDLINK_DIR}/bin/ghc && \
-               ${CP} inplace/bin/ghc-pkg ${BUILDLINK_DIR}/bin/ghc-pkg
+               ${CP} -f inplace/bin/ghc-stage2 ${BUILDLINK_DIR}/bin/ghc && \
+               ${CP} -f inplace/bin/ghc-pkg ${BUILDLINK_DIR}/bin/ghc-pkg && \
+               ${TOUCH} $@
 
 do-configure:
        ${RUN} cd ${WRKSRC} && \
@@ -134,7 +159,7 @@ do-configure:
        ${RUN} ${ECHO} "libraries/terminfo_CONFIGURE_OPTS += \
                --configure-option=--with-curses-includes=${PREFIX}/include \
                --configure-option=--with-curses-libraries=${PREFIX}/lib" >> ${WRKSRC}/mk/build.mk
-# The ghc compiler does normally split the generated C files into small
+# The ghc compiler does normally split the generated asm files into small
 # parts before sending them to gcc, to enable the linker to eliminate
 # unused parts.  This does however not play nice with the pkgsrc
 # framework, and the result is that the build takes more than 5 times
@@ -148,28 +173,10 @@ do-configure:
        ${RUN} ${ECHO} "HSCOLOUR_SRCS = NO" >> ${WRKSRC}/mk/build.mk
 # To avoid powerpc crash...
 # See http://hackage.haskell.org/trac/ghc/ticket/4034
-.if ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
-       ${RUN} ${ECHO} "GhcRtsHcOpts = -optc-O0 -optc-g" >> ${WRKSRC}/mk/build.mk
-       ${RUN} ${ECHO} "GhcRtsCcOpts = -O0 -g" >> ${WRKSRC}/mk/build.mk
-.endif
-
-pre-build:
-# We have to sacrifice the GHCi library for GHC itself to work around
-# for powerpc ld bug.  See
-# http://hackage.haskell.org/trac/ghc/ticket/3260
-.if ${MACHINE_ARCH} == "powerpc"
-       ${RUN} ${MKDIR} ${WRKSRC}/compiler/stage1/build
-       ${RUN} ${TOUCH} -t `expr \`date '+%Y'\` + 1`12310000 \
-                                       ${WRKSRC}/compiler/stage1/build/HS${DISTNAME}.o
-       ${RUN} ${MKDIR} ${WRKSRC}/compiler/stage2/build
-       ${RUN} ${TOUCH} -t `expr \`date '+%Y'\` + 1`12310000 \
-                                       ${WRKSRC}/compiler/stage2/build/HS${DISTNAME}.o
-.endif
-
-.if ${MACHINE_ARCH} == "powerpc"
-WARNINGS+= "You won't be able to use GHCi library for GHC itself\
-because of powerpc ld bug."
-.endif
+#.if ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
+#      ${RUN} ${ECHO} "GhcRtsHcOpts = -optc-O0 -optc-g" >> ${WRKSRC}/mk/build.mk
+#      ${RUN} ${ECHO} "GhcRtsCcOpts = -O0 -g" >> ${WRKSRC}/mk/build.mk
+#.endif
 
 # Some unused scripts don't pass the portability test.
 CHECK_PORTABILITY_SKIP+=       distrib/prep-bin-dist-mingw