]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
We no longer need to directly pass --with-gmp-{includes,libraries} to libraries/integ...
[pkgsrc-ghc.git] / Makefile
index 492c75576e76fec883f2f50769a41bd604b80d9a..127868ece18266f6563d5aab8adb39f1e40c5ff3 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -149,13 +149,9 @@ ${WRKDIR}/stamp-bootstrap-ghc: ${WRKDIR}/stamp-rewrite-hc-paths
 do-configure:
        ${RUN} cd ${WRKSRC} && \
                ${SETENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
-# We need to tell the libraries/integer-gmp/configure that libgmp is
+# We need to tell the libraries/terminfo/configure that our ncurses is
 # in a non-standard path. Without that, the resulting GHC tries to
 # link programs by executing ld(1) without passing it -L${PREFIX}/lib.
-       ${RUN} ${ECHO} "libraries/integer-gmp_CONFIGURE_OPTS += \
-               --configure-option=--with-gmp-includes=${PREFIX}/include \
-               --configure-option=--with-gmp-libraries=${PREFIX}/lib" > ${WRKSRC}/mk/build.mk
-# The ncurses is also in a non-standard path.
        ${RUN} ${ECHO} "libraries/terminfo_CONFIGURE_OPTS += \
                --configure-option=--with-curses-includes=${PREFIX}/include \
                --configure-option=--with-curses-libraries=${PREFIX}/lib" >> ${WRKSRC}/mk/build.mk
@@ -178,6 +174,9 @@ do-configure:
 #      ${RUN} ${ECHO} "GhcRtsCcOpts = -O0 -g" >> ${WRKSRC}/mk/build.mk
 #.endif
 
+# Substitutions for INSTALL and DEINSTALL.
+FILES_SUBST+=  DISTNAME=${DISTNAME}
+
 # Some unused scripts don't pass the portability test.
 CHECK_PORTABILITY_SKIP+=       distrib/prep-bin-dist-mingw