]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
Untested x86_64 support
[pkgsrc-ghc.git] / Makefile
index 691fb8b9b0e99dff0d4df0f833d387113f688d30..1a8276cd95095c3cbdc6ad069e65be038f082ccf 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -11,17 +11,19 @@ COMMENT=            Compiler for the functional language Haskell
 DISTFILES=             ${DISTNAME}-src.tar.bz2 \
                                ghc-6.6.1-src.tar.bz2 \
                                ghc-6.6.1-i386-unknown-freebsd-hc.tar.gz \
+                               ghc-6.6.1-x86_64-unknown-linux-hc.tar.gz \
                                ghc-6.6.1-powerpc-apple-darwin-hc.tar.gz
 
 SITES.ghc-6.6.1-src.tar.bz2                                            = http://www.haskell.org/ghc/dist/6.6.1/
 SITES.ghc-6.6.1-powerpc-apple-darwin-hc.tar.gz = http://static.cielonegro.org/archive/
+SITES.ghc-6.6.1-x86_64-unknown-linux-hc.tar.gz = http://static.cielonegro.org/archive/
 SITES.ghc-6.6.1-i386-unknown-freebsd-hc.tar.gz = http://static.cielonegro.org/archive/
 
 .include "../../mk/bsd.prefs.mk"
 
 # Unregisterised HC packages are architecture dependent. We have to
 # create more HC packages to support more architectures.
-ONLY_FOR_PLATFORM= *-*-i386 *-*-powerpc
+ONLY_FOR_PLATFORM= *-*-i386 *-*-x86_64 *-*-powerpc
 
 GNU_CONFIGURE=         yes
 CONFIGURE_ENV+=                PerlCmd=${PERL5:Q}
@@ -33,6 +35,8 @@ EXTRACT_ONLY= ${DISTNAME}-src.tar.bz2 \
 
 .if ${MACHINE_ARCH} == "i386"
 EXTRACT_ONLY += ghc-6.6.1-i386-unknown-freebsd-hc.tar.gz
+.elif ${MACHINE_ARCH} == "x86_64"
+EXTRACT_ONLY += ghc-6.6.1-x86_64-unknown-linux-hc.tar.gz
 .elif ${MACHINE_ARCH} == "powerpc"
 EXTRACT_ONLY += ghc-6.6.1-powerpc-apple-darwin-hc.tar.gz
 .endif
@@ -49,7 +53,7 @@ pre-configure:
        cd ${WRKDIR}/ghc-6.6.1 && \
                ${CHMOD} +x ./distrib/hc-build && \
                ${ENV} ${CONFIGURE_ENV} ./distrib/hc-build -C --disable-readline --enable-hc-boot-unregisterised && \
-               ${FIND} . -type f -and -perm +o+x -and -name '*-inplace' | \
+               ${FIND} . -type f -and -perm -o+x -and -name '*-inplace' | \
                        while read i; do \
                                ${CP} $$i ${BUILDLINK_DIR}/bin/`basename $$i | sed -e 's/-inplace//'`; \
                        done