]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
It finally passes developer's tests on FreeBSD!
[pkgsrc-ghc.git] / Makefile
index 9164300fcf9267087b302e08d1afdc526f5eaa27..3fc3d82e8f879cc7792f161cfaeb63fd3a26264d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -24,17 +24,15 @@ PKG_DESTDIR_SUPPORT=        user-destdir
 #ONLY_FOR_PLATFORM= *-*-i386 *-*-powerpc
 ONLY_FOR_PLATFORM= *-*-i386
 
-USE_TOOLS+=    gmake bsdtar perl
+USE_TOOLS+=    gmake bsdtar perl:run
+CONFIGURE_ENV+=                PerlCmd=${PERL5:Q}
 
 # We don't want to extract all of the DISTFILEs.
 EXTRACT_ONLY=  ${DISTNAME}-src.tar.bz2
 
-# We need to tell the ./configure that libgmp is in a non-standard path. Without
-# that, the resulting GHC tries to link programs by executing ld(1) without
-# passing it -L${PREFIX}/lib.
 CONFIGURE_ARGS += \
        --prefix=${PREFIX} \
-       --mandir=${PKGMANDIR} \
+       --mandir=${PREFIX}/${PKGMANDIR} \
        --with-gmp-includes=${PREFIX}/include \
        --with-gmp-libraries=${PREFIX}/lib \
        --with-iconv-includes=${PREFIX}/include \
@@ -74,7 +72,7 @@ pre-configure:
                (cd .. && bsdtar jxfm ${DISTDIR}/${BOOTSTRAP_TARBALL}) && \
                ${SH} mkfiles && \
                ${ECHO} "====> Building bootstrap compiler" && \
-               ${SED} -e 's#\\[\\[PREFIX\\]\\]#${PREFIX}#g' ${BUILD_MK} > mk/build.mk && \
+               ${SED} -e "s#\\[\\[PREFIX\\]\\]#${PREFIX}#g" ${BUILD_MK} > mk/build.mk && \
                for c in libraries/*/configure; do \
                        (cd `${DIRNAME} $$c` && ${ENV} ${CONFIGURE_ENV} ${SH} configure ${CONFIGURE_ARGS}); \
                done && \
@@ -89,9 +87,15 @@ pre-configure:
                ${CP} inplace/bin/ghc-stage2 ${BUILDLINK_DIR}/bin/ghc && \
                ${CP} inplace/bin/ghc-pkg ${BUILDLINK_DIR}/bin/ghc-pkg
 
+# We need to tell the libraries/integer-gmp/configure that libgmp is
+# in a non-standard path. Without that, the resulting GHC tries to
+# link programs by executing ld(1) without passing it -L${PREFIX}/lib.
 do-configure:
        ${RUN} cd ${WRKSRC} && \
                ${ENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
+       ${RUN} ${ECHO} "libraries/integer-gmp_CONFIGURE_OPTS += \
+               --configure-option=--with-gmp-includes=${PREFIX}/include \
+               --configure-option=--with-gmp-libraries=${PREFIX}/lib" > ${WRKSRC}/mk/build.mk
 
 # The ghc compiler does normally split the generated C files into small
 # parts before sending them to gcc, to enable the linker to eliminate
@@ -102,11 +106,16 @@ do-configure:
 # for a description of the problem.
 # Disable file splitting until pkgsrc gets improved.
 pre-build:
-       ${ECHO} "SplitObjs=NO" > ${WRKSRC}/mk/build.mk
+       ${RUN} ${ECHO} "SplitObjs = NO" >> ${WRKSRC}/mk/build.mk
 
 # Some unused scripts don't pass the portability test.
 CHECK_PORTABILITY_SKIP+=       distrib/prep-bin-dist-mingw
 
+# GHC currently *requires* ${PREFIX}/lib to be in
+# "/etc/ld-elf.so.conf". See
+# http://hackage.haskell.org/trac/ghc/ticket/2933
+CHECK_SHLIBS_SUPPORTED=        no
+
 BUILDLINK_DEPMETHOD.libxslt = build
 .include "../../converters/libiconv/buildlink3.mk"
 .include "../../devel/gmp/buildlink3.mk"