]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
upstream update to 6.10.3
[pkgsrc-ghc.git] / Makefile
index 691fb8b9b0e99dff0d4df0f833d387113f688d30..4bf1b2c129afe5dde718cd9000c0ff84ee8f4eb8 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
 # $NetBSD: Makefile,v 1.42 2008/07/07 14:58:00 kristerw Exp $
 
 DISTNAME=              ghc-${VERSION}
-VERSION=               6.10.1
+VERSION=               6.10.3
 CATEGORIES=            lang
 MASTER_SITES=  http://www.haskell.org/ghc/dist/${VERSION}/
 MAINTAINER=            kristerw@NetBSD.org
@@ -49,7 +49,7 @@ pre-configure:
        cd ${WRKDIR}/ghc-6.6.1 && \
                ${CHMOD} +x ./distrib/hc-build && \
                ${ENV} ${CONFIGURE_ENV} ./distrib/hc-build -C --disable-readline --enable-hc-boot-unregisterised && \
-               ${FIND} . -type f -and -perm +o+x -and -name '*-inplace' | \
+               ${FIND} . -type f -and -perm -o+x -and -name '*-inplace' | \
                        while read i; do \
                                ${CP} $$i ${BUILDLINK_DIR}/bin/`basename $$i | sed -e 's/-inplace//'`; \
                        done
@@ -61,11 +61,13 @@ pre-configure:
 # as long than when the files are not split.  See
 #    http://mail-index.netbsd.org/tech-pkg/2006/07/30/0005.html
 # for a description of the problem.
-# Disable file splitting until pkgsrc has been improved.
+# Disable file splitting until pkgsrc gets improved.
 pre-build:
        ${ECHO} "SplitObjs=NO" > ${WRKSRC}/mk/build.mk
 
+# Some unused scripts don't pass the portability test.
+CHECK_PORTABILITY_SKIP+=       distrib/prep-bin-dist-mingw
+
 .include "../../devel/gmp/buildlink3.mk"
-.include "../../wip/editline/buildlink3.mk"
 .include "../../mk/pthread.buildlink3.mk"
 .include "../../mk/bsd.pkg.mk"