]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
upstream update to 6.10.3
[pkgsrc-ghc.git] / Makefile
index 85e4505e2371b4188426305da6e14eaa4cb95ab1..4bf1b2c129afe5dde718cd9000c0ff84ee8f4eb8 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
 # $NetBSD: Makefile,v 1.42 2008/07/07 14:58:00 kristerw Exp $
 
 DISTNAME=              ghc-${VERSION}
-VERSION=               6.10.1
+VERSION=               6.10.3
 CATEGORIES=            lang
 MASTER_SITES=  http://www.haskell.org/ghc/dist/${VERSION}/
 MAINTAINER=            kristerw@NetBSD.org
@@ -9,13 +9,13 @@ HOMEPAGE=             http://www.haskell.org/ghc/
 COMMENT=               Compiler for the functional language Haskell
 
 DISTFILES=             ${DISTNAME}-src.tar.bz2 \
-                               ghc-6.4.2-src.tar.bz2 \
-                               ghc-6.4.2-i386-unknown-netbsd-hc.tar.gz \
-                               ghc-6.4.2-powerpc-apple-darwin-hc.tar.gz
+                               ghc-6.6.1-src.tar.bz2 \
+                               ghc-6.6.1-i386-unknown-freebsd-hc.tar.gz \
+                               ghc-6.6.1-powerpc-apple-darwin-hc.tar.gz
 
-SITES.ghc-6.4.2-src.tar.bz2                                            = http://www.haskell.org/ghc/dist/6.4.2/
-SITES.ghc-6.4.2-i386-unknown-netbsd-hc.tar.gz  = ${MASTER_SITE_LOCAL}
-SITES.ghc-6.4.2-powerpc-apple-darwin-hc.tar.gz = http://static.cielonegro.org/archive/
+SITES.ghc-6.6.1-src.tar.bz2                                            = http://www.haskell.org/ghc/dist/6.6.1/
+SITES.ghc-6.6.1-powerpc-apple-darwin-hc.tar.gz = http://static.cielonegro.org/archive/
+SITES.ghc-6.6.1-i386-unknown-freebsd-hc.tar.gz = http://static.cielonegro.org/archive/
 
 .include "../../mk/bsd.prefs.mk"
 
@@ -29,12 +29,12 @@ USE_TOOLS+=                 gmake perl:run find:run cp:run
 
 # We don't want to extract all of the DISTFILEs.
 EXTRACT_ONLY=  ${DISTNAME}-src.tar.bz2 \
-                               ghc-6.4.2-src.tar.bz2
+                               ghc-6.6.1-src.tar.bz2
 
 .if ${MACHINE_ARCH} == "i386"
-EXTRACT_ONLY += ghc-6.4.2-i386-unknown-netbsd-hc.tar.gz
+EXTRACT_ONLY += ghc-6.6.1-i386-unknown-freebsd-hc.tar.gz
 .elif ${MACHINE_ARCH} == "powerpc"
-EXTRACT_ONLY += ghc-6.4.2-powerpc-apple-darwin-hc.tar.gz
+EXTRACT_ONLY += ghc-6.6.1-powerpc-apple-darwin-hc.tar.gz
 .endif
 
 # Build an unregisterised bootstrap compiler and install it directly
@@ -46,9 +46,10 @@ EXTRACT_ONLY += ghc-6.4.2-powerpc-apple-darwin-hc.tar.gz
 # files into ${BUILDLINK_DIR}/bin with dropping the "-inplace" at
 # their tails.
 pre-configure:
-       cd ${WRKDIR}/ghc-6.4.2 && \
-               ${ENV} ${CONFIGURE_ENV} ./distrib/hc-build -C --enable-hc-boot-unregisterised && \
-               ${FIND} . -type f -and -perm +o+x -and -name '*-inplace' | \
+       cd ${WRKDIR}/ghc-6.6.1 && \
+               ${CHMOD} +x ./distrib/hc-build && \
+               ${ENV} ${CONFIGURE_ENV} ./distrib/hc-build -C --disable-readline --enable-hc-boot-unregisterised && \
+               ${FIND} . -type f -and -perm -o+x -and -name '*-inplace' | \
                        while read i; do \
                                ${CP} $$i ${BUILDLINK_DIR}/bin/`basename $$i | sed -e 's/-inplace//'`; \
                        done
@@ -60,11 +61,13 @@ pre-configure:
 # as long than when the files are not split.  See
 #    http://mail-index.netbsd.org/tech-pkg/2006/07/30/0005.html
 # for a description of the problem.
-# Disable file splitting until pkgsrc has been improved.
+# Disable file splitting until pkgsrc gets improved.
 pre-build:
        ${ECHO} "SplitObjs=NO" > ${WRKSRC}/mk/build.mk
 
+# Some unused scripts don't pass the portability test.
+CHECK_PORTABILITY_SKIP+=       distrib/prep-bin-dist-mingw
+
 .include "../../devel/gmp/buildlink3.mk"
-.include "../../wip/editline/buildlink3.mk"
 .include "../../mk/pthread.buildlink3.mk"
 .include "../../mk/bsd.pkg.mk"