]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
powerpc-apple-darwin
[pkgsrc-ghc.git] / Makefile
index a2aec8c4a2f03f752460174a6badadd9a9b8e823..54cad06f359bb72de2c5f18395f54925f5457c27 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
 # $NetBSD: Makefile,v 1.42 2008/07/07 14:58:00 kristerw Exp $
 
 DISTNAME=              ghc-${VERSION}
-VERSION=               6.12.1
+VERSION=               6.12.2
 CATEGORIES=            lang
 MASTER_SITES=  http://www.haskell.org/ghc/dist/${VERSION}/
 MAINTAINER=            kristerw@NetBSD.org
@@ -10,7 +10,8 @@ COMMENT=              Compiler for the functional language Haskell
 LICENSE=               modified-bsd
 
 DISTFILES=             ${DISTNAME}-src.tar.bz2 \
-                               ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2 \
+                               ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
+#                              ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2 \
                                ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2 \
                                ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
 
@@ -121,20 +122,19 @@ pre-configure:
                ${CP} inplace/bin/ghc-stage2 ${BUILDLINK_DIR}/bin/ghc && \
                ${CP} inplace/bin/ghc-pkg ${BUILDLINK_DIR}/bin/ghc-pkg
 
-# We need to tell the libraries/integer-gmp/configure that libgmp is
-# in a non-standard path. Without that, the resulting GHC tries to
-# link programs by executing ld(1) without passing it -L${PREFIX}/lib.
 do-configure:
        ${RUN} cd ${WRKSRC} && \
                ${SETENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
+# We need to tell the libraries/integer-gmp/configure that libgmp is
+# in a non-standard path. Without that, the resulting GHC tries to
+# link programs by executing ld(1) without passing it -L${PREFIX}/lib.
        ${RUN} ${ECHO} "libraries/integer-gmp_CONFIGURE_OPTS += \
                --configure-option=--with-gmp-includes=${PREFIX}/include \
                --configure-option=--with-gmp-libraries=${PREFIX}/lib" > ${WRKSRC}/mk/build.mk
+# The ncurses is also in a non-standard path.
        ${RUN} ${ECHO} "libraries/terminfo_CONFIGURE_OPTS += \
                --configure-option=--with-curses-includes=${PREFIX}/include \
                --configure-option=--with-curses-libraries=${PREFIX}/lib" >> ${WRKSRC}/mk/build.mk
-
-pre-build:
 # The ghc compiler does normally split the generated C files into small
 # parts before sending them to gcc, to enable the linker to eliminate
 # unused parts.  This does however not play nice with the pkgsrc
@@ -147,6 +147,14 @@ pre-build:
 # If we don't explicitly disable HsColour, PLIST gets changed
 # depending on whether we have installed it or not.
        ${RUN} ${ECHO} "HSCOLOUR_SRCS = NO" >> ${WRKSRC}/mk/build.mk
+# To avoid powerpc crash...
+# See http://hackage.haskell.org/trac/ghc/ticket/4034
+.if ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
+       ${RUN} ${ECHO} "GhcRtsHcOpts = -optc-O0 -optc-g" >> ${WRKSRC}/mk/build.mk
+       ${RUN} ${ECHO} "GhcRtsCcOpts = -O0 -g" >> ${WRKSRC}/mk/build.mk
+.endif
+
+pre-build:
 # We have to sacrifice the GHCi library for GHC itself to work around
 # for powerpc ld bug.  See
 # http://hackage.haskell.org/trac/ghc/ticket/3260