]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
GHC 7.4.1 for powerpc-apple-darwin
[pkgsrc-ghc.git] / Makefile
index 3e50ccd2c09bef1160749b3b946869ac1ba9ccdd..59ec94d6ba87e6ff7e5fc69631f6fa03b277b94f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
 # $NetBSD: Makefile,v 1.42 2008/07/07 14:58:00 kristerw Exp $
 
 DISTNAME=              ghc-${VERSION}
-VERSION=               7.0.3
+VERSION=               7.4.1
 CATEGORIES=            lang
 MASTER_SITES=  http://www.haskell.org/ghc/dist/${VERSION}/
 MAINTAINER=            kristerw@NetBSD.org
@@ -10,11 +10,10 @@ COMMENT=            Compiler for the functional language Haskell
 LICENSE=               modified-bsd
 
 DISTFILES=             ${DISTNAME}-src.tar.bz2
-DISTFILES+=            ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
-DISTFILES+=            ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
+#DISTFILES+=           ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
+#DISTFILES+=           ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
 DISTFILES+=            ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
 
-
 SITES.${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2     = http://static.cielonegro.org/archive/
 SITES.${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2    = http://static.cielonegro.org/archive/
 SITES.${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2    = http://static.cielonegro.org/archive/
@@ -46,7 +45,7 @@ CONFIGURE_ARGS+= --with-gcc=/usr/bin/gcc
 CONFIGURE_ARGS+= --with-gcc=${CCPATH}
 .endif
 
-USE_TOOLS+=                    gmake gtar perl:run
+USE_TOOLS+=                    autoconf date gmake gtar perl perl:run
 CONFIGURE_ENV+=                PerlCmd=${PERL5:Q}
 
 # We don't want to extract all of the DISTFILEs.
@@ -74,14 +73,17 @@ CONFIGURE_ARGS += \
 
 .if ${MACHINE_ARCH} == "i386" && ${OPSYS} == "NetBSD"
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
+BOOTSTRAP_CAPI_C   = ${PKGDIR}/files/capi-wrappers-netbsd-i386.c
 PLATFORM           = i386-unknown-netbsd
 
 .elif ${MACHINE_ARCH} == "i386" && ${OPSYS} == "FreeBSD"
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
+BOOTSTRAP_CAPI_C   = ${PKGDIR}/files/capi-wrappers-freebsd-i386.c
 PLATFORM           = i386-unknown-freebsd
 
 .elif ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap.mk
+BOOTSTRAP_CAPI_C   = ${PKGDIR}/files/capi-wrappers-darwin-powerpc.c
 PLATFORM           = powerpc-apple-darwin
 # Existence of libelf makes LeadingUnderscore being "NO", which is
 # incorrect for this platform. See ghc-6.12.1/aclocal.m4
@@ -93,27 +95,38 @@ PKG_FAIL_REASON+=   "internal error: unsupported platform"
 .endif
 
 BOOTSTRAP_TARBALL = ${DISTNAME}-boot-${PLATFORM}.tar.bz2
+BOOTSTRAP_MAIN_C  = ${PKGDIR}/files/bootstrap-main.c
 
 pre-configure: ${WRKDIR}/stamp-bootstrap-ghc
 
-${WRKDIR}/stamp-prepare-bootstrap:
+${WRKDIR}/stamp-autoreconf:
+       ${RUN} cd ${WRKSRC} && \
+               ${PHASE_MSG} "Regenerating configuration scripts for ${PKGNAME}" && \
+               ${PERL5} boot && \
+               ${TOUCH} ${.TARGET}
+
+${WRKDIR}/stamp-prepare-bootstrap: ${WRKDIR}/stamp-autoreconf
        ${RUN} cd ${WRKDIR} && \
-               ${PHASE_MSG} "Preparing bootstrap compiler for ${PKGNAME}" && \
+               ${PHASE_MSG} "Preparing bootstrapping compiler for ${PKGNAME}" && \
                ${RM} -rf bootstrap && \
-               ${MKDIR} -p bootstrap/${DISTNAME}/utils/ghc-pwd/dist-boot && \
+               ${MKDIR} bootstrap && \
                ${GTAR} -cf - ${DISTNAME} | ${GTAR} -C bootstrap -xf - && \
-               ${LN} -sf ${PWD_CMD} bootstrap/${DISTNAME}/utils/ghc-pwd/dist-boot/ghc-pwd && \
+               ${CP} ${BOOTSTRAP_MAIN_C} bootstrap/${DISTNAME}/rts/bootstrap-main.c && \
+               ${CP} ${BOOTSTRAP_CAPI_C} bootstrap/${DISTNAME}/rts/capi-wrappers.c  && \
                ${TOUCH} ${.TARGET}
 
 ${WRKDIR}/stamp-configure-hc-boot: ${WRKDIR}/stamp-prepare-bootstrap
        ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
-               ${PHASE_MSG} "Configuring bootstrap compiler for ${PKGNAME}" && \
+               ${PHASE_MSG} "Configuring bootstrapping compiler for ${PKGNAME}" && \
                ${SETENV} ${CONFIGURE_ENV} ./configure --enable-hc-boot --with-ghc="" ${CONFIGURE_ARGS} && \
                ${TOUCH} ${.TARGET}
 
 ${WRKDIR}/stamp-extract-hc: ${WRKDIR}/stamp-configure-hc-boot
        ${RUN} cd ${WRKDIR}/bootstrap && \
                ${PHASE_MSG} "Extracting bootstrap HC archive for ${PKGNAME}" && \
+               if ${TEST} "`${DATE} '+%Y%m%d%H%M'`" -le 200001010000; then \
+                       ${FAIL_MSG} "Adjust your system clock: `${DATE}`"; \
+               fi && \
                ${FIND} ${DISTNAME} -type d -o -type f | ${XARGS} ${TOUCH} -t 200001010000 && \
                ${GTAR} -jxf ${DISTDIR}/${BOOTSTRAP_TARBALL} && \
                (cd ${DISTNAME} && ${SH} mkfiles) && \
@@ -121,27 +134,36 @@ ${WRKDIR}/stamp-extract-hc: ${WRKDIR}/stamp-configure-hc-boot
 
 ${WRKDIR}/stamp-rewrite-hc-paths: ${WRKDIR}/stamp-extract-hc
        ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
-               ${PHASE_MSG} "Rewriting source paths in bootstrap compiler for ${PKGNAME}" && \
+               ${PHASE_MSG} "Rewriting source paths in bootstrapping compiler for ${PKGNAME}" && \
                ${SED} -e "s#\\[\\[PREFIX\\]\\]#${PREFIX}#g" ${BOOTSTRAP_BUILD_MK} > mk/build.mk && \
                for c in libraries/*/configure; do \
                        (cd `${DIRNAME} $$c` && ${SETENV} ${CONFIGURE_ENV} ${SH} configure ${CONFIGURE_ARGS}); \
                done && \
-               for i in inplace/lib/package.conf.d/*.conf */*/package-data.mk */*/*/package-data.mk; do \
+               for i in inplace/lib/package.conf.d/*.conf \
+                                */package.conf.inplace \
+                                */*/package-data.mk \
+                                */*/*/package-data.mk \
+                                */*/*/*/package-data.mk; do \
                        ${SED} -e "s#\\[\\[PREFIX\\]\\]#${PREFIX}#g" \
                                   -e "s#\\[\\[GHC_SOURCE_PATH\\]\\]#`${PWD_CMD}`#g" $$i > $$i.tmp; \
                        ${MV} -f $$i.tmp $$i; \
                done && \
                ${TOUCH} -r inplace/lib/package.conf.d \
+                                       inplace/lib/package.conf.d/*.conf \
+                                       */package.conf.inplace \
                                        */*/package-data.mk \
                                        */*/*/package-data.mk \
+                                       */*/*/*/package-data.mk \
                                        compiler/stage?/build/Config.hs && \
                ${TOUCH} ${.TARGET}
 
 ${WRKDIR}/stamp-bootstrap-ghc: ${WRKDIR}/stamp-rewrite-hc-paths
        ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
-               ${PHASE_MSG} "Building bootstrap compiler for ${PKGNAME}" && \
+               ${PHASE_MSG} "Creating bootstrapping files for ${PKGNAME}" && \
                ${GMAKE} bootstrapping-files && \
+               ${PHASE_MSG} "Building bootstrapping compiler for ${PKGNAME}" && \
                ${GMAKE} all_ghc_stage2 && \
+               ${PHASE_MSG} "Building bootstrapping toolkit for ${PKGNAME}" && \
                ${GMAKE} inplace/bin/ghc-pkg && \
                ${GMAKE} inplace/lib/unlit && \
                inplace/bin/ghc-pkg recache && \
@@ -150,10 +172,6 @@ ${WRKDIR}/stamp-bootstrap-ghc: ${WRKDIR}/stamp-rewrite-hc-paths
                ${TOUCH} ${.TARGET}
 
 do-configure:
-# Seemingly by mistake, ghc-7.0.3 has a prebuilt
-# utils/ghc-pwd/dist-boot/ghc-pwd for amd64 GNU/Linux.
-       ${RUN} cd ${WRKSRC} && \
-               rm -rf utils/ghc-pwd/dist-boot
        ${RUN} cd ${WRKSRC} && \
                ${SETENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
 # We need to tell the libraries/terminfo/configure that our ncurses is
@@ -174,12 +192,6 @@ do-configure:
 # If we don't explicitly disable HsColour, PLIST gets changed
 # depending on whether we have installed it or not.
        ${RUN} ${ECHO} "HSCOLOUR_SRCS = NO" >> ${WRKSRC}/mk/build.mk
-# To avoid powerpc crash...
-# See http://hackage.haskell.org/trac/ghc/ticket/4034
-#.if ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
-#      ${RUN} ${ECHO} "GhcRtsHcOpts = -optc-O0 -optc-g" >> ${WRKSRC}/mk/build.mk
-#      ${RUN} ${ECHO} "GhcRtsCcOpts = -O0 -g" >> ${WRKSRC}/mk/build.mk
-#.endif
 
 # Substitutions for INSTALL and DEINSTALL.
 FILES_SUBST+=  DISTNAME=${DISTNAME}