]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
touch HSghc-6.12.1.o to the next year's Dec 31th
[pkgsrc-ghc.git] / Makefile
index 35246cf0bb61f6a801d75ed3cce7cba707c3e5d0..7364efc108a79ed852061179c372606ba7ca02a3 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -11,28 +11,32 @@ LICENSE=            modified-bsd
 
 DISTFILES=             ${DISTNAME}-src.tar.bz2 \
                                ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2 \
-                               ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
+                               ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2 \
+                               ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
 
 SITES.${DISTNAME}-src.tar.bz2                                          = http://www.haskell.org/ghc/dist/${VERSION}/
 SITES.${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2     = http://static.cielonegro.org/archive/
 SITES.${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2    = http://static.cielonegro.org/archive/
+SITES.${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2    = http://static.cielonegro.org/archive/
 
 PKG_DESTDIR_SUPPORT=   user-destdir
 
 .include "../../mk/bsd.prefs.mk"
 
 # Unregisterised HC packages are architecture dependent. We have to
-# create more HC packages to support more architectures.
-ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386
-# Note: Darwin-*-powerpc is temporarily disabled for now. It shall
-# come back in the near future. Thanks for your patience.
+# create more HC packages to support more architectures. Note that
+# these packages are built with integer-simple, not integer-gmp, to
+# reduce some complexity by not depending on the GMP. The resulting
+# registerised GHC uses integer-gmp so this won't be a problem.
+ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386 Darwin-*-powerpc
 
 # We must provide the real pass to gcc to the ./configure script,
 # because GHC has a runtime dependency on it. Aren't there any better
 # way than this?
 .include "../../mk/compiler.mk"
 .if empty(CCPATH)
-WARNINGS+= "This package depends on pkgsrc's undocumented variable CCPATH but it disappeared somehow."
+WARNINGS+= "This package depends on pkgsrc's undocumented variable\
+CCPATH but it disappeared somehow."
 WARNINGS+= "Using hard-coded /usr/bin/gcc as the C compiler..."
 CONFIGURE_ARGS+= --with-gcc=/usr/bin/gcc
 .else
@@ -45,7 +49,6 @@ CONFIGURE_ENV+=               PerlCmd=${PERL5:Q}
 # We don't want to extract all of the DISTFILEs.
 EXTRACT_ONLY=  ${DISTNAME}-src.tar.bz2
 
-PLATFORM= ${MACHINE_ARCH}-unknown-${LOWER_OPSYS}
 CONFIGURE_ARGS += \
        --build=${PLATFORM} \
        --host=${PLATFORM} \
@@ -67,21 +70,27 @@ CONFIGURE_ARGS += \
 # running "ghc-pkg recache".
 
 .if ${MACHINE_ARCH} == "i386" && ${OPSYS} == "NetBSD"
-BOOTSTRAP_TARBALL  = ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
+PLATFORM           = i386-unknown-netbsd
 
 .elif ${MACHINE_ARCH} == "i386" && ${OPSYS} == "FreeBSD"
-BOOTSTRAP_TARBALL = ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
+PLATFORM           = i386-unknown-freebsd
 
-#.elif ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
-#BOOTSTRAP_TARBALL = ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
-#BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap.mk
+.elif ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
+BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap.mk
+PLATFORM           = powerpc-apple-darwin
+
+# Existence of libelf makes LeadingUnderscore being "NO", which is
+# incorrect. See ghc-6.12.1/aclocal.m4 (FP_LEADING_UNDERSCORE)
+CONFLICTS=     libelf-[0-9]*
 
 .else
 PKG_FAIL_REASON+=      "internal error: unsupported platform"
 .endif
 
+BOOTSTRAP_TARBALL = ${DISTNAME}-boot-${PLATFORM}.tar.bz2
+
 pre-configure:
        ${RUN} cd ${WRKDIR} && \
                ${ECHO} "====> Preparing bootstrap compiler" && \
@@ -135,6 +144,22 @@ do-configure:
 # Disable file splitting until pkgsrc gets improved.
 pre-build:
        ${RUN} ${ECHO} "SplitObjs = NO" >> ${WRKSRC}/mk/build.mk
+# We have to sacrifice the GHCi library for GHC itself to work around
+# for powerpc ld bug.  See
+# http://hackage.haskell.org/trac/ghc/ticket/3260
+.if ${MACHINE_ARCH} == "powerpc"
+       ${RUN} ${MKDIR} ${WRKSRC}/compiler/stage1/build
+       ${RUN} ${TOUCH} -t `expr \`date '+%Y'\` + 1`12310000 \
+                                       ${WRKSRC}/compiler/stage1/build/HS${DISTNAME}.o
+       ${RUN} ${MKDIR} ${WRKSRC}/compiler/stage2/build
+       ${RUN} ${TOUCH} -t `expr \`date '+%Y'\` + 1`12310000 \
+                                       ${WRKSRC}/compiler/stage2/build/HS${DISTNAME}.o
+.endif
+
+.if ${MACHINE_ARCH} == "powerpc"
+WARNINGS+= "You won't be able to use GHCi library for GHC itself\
+because of powerpc ld bug."
+.endif
 
 # Some unused scripts don't pass the portability test.
 CHECK_PORTABILITY_SKIP+=       distrib/prep-bin-dist-mingw