]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
touch HSghc-6.12.1.o to the next year's Dec 31th
[pkgsrc-ghc.git] / Makefile
index a647d2668760f672707115d1a6f055e38e4a950e..7364efc108a79ed852061179c372606ba7ca02a3 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -11,19 +11,37 @@ LICENSE=            modified-bsd
 
 DISTFILES=             ${DISTNAME}-src.tar.bz2 \
                                ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2 \
-                               ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
+                               ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2 \
+                               ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
 
 SITES.${DISTNAME}-src.tar.bz2                                          = http://www.haskell.org/ghc/dist/${VERSION}/
 SITES.${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2     = http://static.cielonegro.org/archive/
 SITES.${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2    = http://static.cielonegro.org/archive/
+SITES.${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2    = http://static.cielonegro.org/archive/
 
 PKG_DESTDIR_SUPPORT=   user-destdir
 
 .include "../../mk/bsd.prefs.mk"
 
 # Unregisterised HC packages are architecture dependent. We have to
-# create more HC packages to support more architectures.
-ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386
+# create more HC packages to support more architectures. Note that
+# these packages are built with integer-simple, not integer-gmp, to
+# reduce some complexity by not depending on the GMP. The resulting
+# registerised GHC uses integer-gmp so this won't be a problem.
+ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386 Darwin-*-powerpc
+
+# We must provide the real pass to gcc to the ./configure script,
+# because GHC has a runtime dependency on it. Aren't there any better
+# way than this?
+.include "../../mk/compiler.mk"
+.if empty(CCPATH)
+WARNINGS+= "This package depends on pkgsrc's undocumented variable\
+CCPATH but it disappeared somehow."
+WARNINGS+= "Using hard-coded /usr/bin/gcc as the C compiler..."
+CONFIGURE_ARGS+= --with-gcc=/usr/bin/gcc
+.else
+CONFIGURE_ARGS+= --with-gcc=${CCPATH}
+.endif
 
 USE_TOOLS+=    gmake bsdtar perl:run
 CONFIGURE_ENV+=                PerlCmd=${PERL5:Q}
@@ -32,6 +50,9 @@ CONFIGURE_ENV+=               PerlCmd=${PERL5:Q}
 EXTRACT_ONLY=  ${DISTNAME}-src.tar.bz2
 
 CONFIGURE_ARGS += \
+       --build=${PLATFORM} \
+       --host=${PLATFORM} \
+       --target=${PLATFORM} \
        --prefix=${PREFIX} \
        --mandir=${PREFIX}/${PKGMANDIR} \
        --with-gmp-includes=${PREFIX}/include \
@@ -49,21 +70,27 @@ CONFIGURE_ARGS += \
 # running "ghc-pkg recache".
 
 .if ${MACHINE_ARCH} == "i386" && ${OPSYS} == "NetBSD"
-BOOTSTRAP_TARBALL  = ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
+PLATFORM           = i386-unknown-netbsd
 
 .elif ${MACHINE_ARCH} == "i386" && ${OPSYS} == "FreeBSD"
-BOOTSTRAP_TARBALL = ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
+PLATFORM           = i386-unknown-freebsd
 
-#.elif ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
-#BOOTSTRAP_TARBALL = ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
-#BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap.mk
+.elif ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
+BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap.mk
+PLATFORM           = powerpc-apple-darwin
+
+# Existence of libelf makes LeadingUnderscore being "NO", which is
+# incorrect. See ghc-6.12.1/aclocal.m4 (FP_LEADING_UNDERSCORE)
+CONFLICTS=     libelf-[0-9]*
 
 .else
 PKG_FAIL_REASON+=      "internal error: unsupported platform"
 .endif
 
+BOOTSTRAP_TARBALL = ${DISTNAME}-boot-${PLATFORM}.tar.bz2
+
 pre-configure:
        ${RUN} cd ${WRKDIR} && \
                ${ECHO} "====> Preparing bootstrap compiler" && \
@@ -72,14 +99,14 @@ pre-configure:
                cd bootstrap/${DISTNAME} && \
                ${LN} -sf ${PWD_CMD} utils/ghc-pwd/ghc-pwd && \
                ${ECHO} "====> Configuring for bootstrap compiler" && \
-               ${ENV} ${CONFIGURE_ENV} ./configure --enable-hc-boot ${CONFIGURE_ARGS} && \
+               ${SETENV} ${CONFIGURE_ENV} ./configure --enable-hc-boot ${CONFIGURE_ARGS} && \
                ${ECHO} "====> Extracting bootstrap HC archive" && \
                (cd .. && bsdtar jxfm ${DISTDIR}/${BOOTSTRAP_TARBALL}) && \
                ${SH} mkfiles && \
                ${ECHO} "====> Building bootstrap compiler" && \
                ${SED} -e "s#\\[\\[PREFIX\\]\\]#${PREFIX}#g" ${BOOTSTRAP_BUILD_MK} > mk/build.mk && \
                for c in libraries/*/configure; do \
-                       (cd `${DIRNAME} $$c` && ${ENV} ${CONFIGURE_ENV} ${SH} configure ${CONFIGURE_ARGS}); \
+                       (cd `${DIRNAME} $$c` && ${SETENV} ${CONFIGURE_ENV} ${SH} configure ${CONFIGURE_ARGS}); \
                done && \
                for i in inplace/lib/package.conf.d/*.conf */*/package-data.mk */*/*/package-data.mk; do \
                        ${SED} -e "s#\\[\\[GHC_SOURCE_PATH\\]\\]#`${PWD_CMD}`#g" $$i > $$i.tmp; \
@@ -99,7 +126,7 @@ pre-configure:
 # link programs by executing ld(1) without passing it -L${PREFIX}/lib.
 do-configure:
        ${RUN} cd ${WRKSRC} && \
-               ${ENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
+               ${SETENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
        ${RUN} ${ECHO} "libraries/integer-gmp_CONFIGURE_OPTS += \
                --configure-option=--with-gmp-includes=${PREFIX}/include \
                --configure-option=--with-gmp-libraries=${PREFIX}/lib" > ${WRKSRC}/mk/build.mk
@@ -117,6 +144,22 @@ do-configure:
 # Disable file splitting until pkgsrc gets improved.
 pre-build:
        ${RUN} ${ECHO} "SplitObjs = NO" >> ${WRKSRC}/mk/build.mk
+# We have to sacrifice the GHCi library for GHC itself to work around
+# for powerpc ld bug.  See
+# http://hackage.haskell.org/trac/ghc/ticket/3260
+.if ${MACHINE_ARCH} == "powerpc"
+       ${RUN} ${MKDIR} ${WRKSRC}/compiler/stage1/build
+       ${RUN} ${TOUCH} -t `expr \`date '+%Y'\` + 1`12310000 \
+                                       ${WRKSRC}/compiler/stage1/build/HS${DISTNAME}.o
+       ${RUN} ${MKDIR} ${WRKSRC}/compiler/stage2/build
+       ${RUN} ${TOUCH} -t `expr \`date '+%Y'\` + 1`12310000 \
+                                       ${WRKSRC}/compiler/stage2/build/HS${DISTNAME}.o
+.endif
+
+.if ${MACHINE_ARCH} == "powerpc"
+WARNINGS+= "You won't be able to use GHCi library for GHC itself\
+because of powerpc ld bug."
+.endif
 
 # Some unused scripts don't pass the portability test.
 CHECK_PORTABILITY_SKIP+=       distrib/prep-bin-dist-mingw