]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
TODO fix
[pkgsrc-ghc.git] / Makefile
index 3c84795fe323ee2a7ffb0f46c77072641ef67f7c..794adbf6bde0f2f90d009d75302a21c7ff4cab44 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,20 +1,20 @@
 # $NetBSD: Makefile,v 1.42 2008/07/07 14:58:00 kristerw Exp $
 
 DISTNAME=              ghc-${VERSION}
-VERSION=               6.12.2
+VERSION=               6.12.3
 CATEGORIES=            lang
-MASTER_SITES=  http://www.haskell.org/ghc/dist/${VERSION}/
+MASTER_SITES=  http://darcs.haskell.org/download/dist/${VERSION}/
 MAINTAINER=            kristerw@NetBSD.org
 HOMEPAGE=              http://www.haskell.org/ghc/
 COMMENT=               Compiler for the functional language Haskell
 LICENSE=               modified-bsd
 
-DISTFILES=             ${DISTNAME}-src.tar.bz2 \
-                               ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2 \
-                               ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2 \
-                               ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
+DISTFILES=             ${DISTNAME}-src.tar.bz2
+DISTFILES+=            ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
+DISTFILES+=            ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
+DISTFILES+=            ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
+
 
-SITES.${DISTNAME}-src.tar.bz2                                          = http://www.haskell.org/ghc/dist/${VERSION}/
 SITES.${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2     = http://static.cielonegro.org/archive/
 SITES.${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2    = http://static.cielonegro.org/archive/
 SITES.${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2    = http://static.cielonegro.org/archive/
@@ -28,11 +28,14 @@ PKG_DESTDIR_SUPPORT=        user-destdir
 # these packages are built with integer-simple, not integer-gmp, to
 # reduce some complexity by not depending on the GMP. The resulting
 # registerised GHC uses integer-gmp so this won't be a problem.
+#
+# If you want to build HC packages yourself, follow instructions in
+# the ./TODO file.
 ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386 Darwin-*-powerpc
 
 # We must provide the real pass to gcc to the ./configure script,
-# because GHC has a runtime dependency on it. Aren't there any better
-# way than this?
+# because GHC has a runtime dependency on it. Aren't there any ways
+# better than this?
 .include "../../mk/compiler.mk"
 .if empty(CCPATH)
 WARNINGS+= "This package depends on pkgsrc's undocumented variable\
@@ -80,6 +83,8 @@ PLATFORM           = i386-unknown-freebsd
 .elif ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap.mk
 PLATFORM           = powerpc-apple-darwin
+WARNINGS+= "You won't be able to use GHCi library for GHC itself\
+because of Mach-O limitation."
 
 # Existence of libelf makes LeadingUnderscore being "NO", which is
 # incorrect. See ghc-6.12.1/aclocal.m4 (FP_LEADING_UNDERSCORE)
@@ -153,24 +158,6 @@ do-configure:
        ${RUN} ${ECHO} "GhcRtsCcOpts = -O0 -g" >> ${WRKSRC}/mk/build.mk
 .endif
 
-pre-build:
-# We have to sacrifice the GHCi library for GHC itself to work around
-# for powerpc ld bug.  See
-# http://hackage.haskell.org/trac/ghc/ticket/3260
-.if ${MACHINE_ARCH} == "powerpc"
-       ${RUN} ${MKDIR} ${WRKSRC}/compiler/stage1/build
-       ${RUN} ${TOUCH} -t `expr \`date '+%Y'\` + 1`12310000 \
-                                       ${WRKSRC}/compiler/stage1/build/HS${DISTNAME}.o
-       ${RUN} ${MKDIR} ${WRKSRC}/compiler/stage2/build
-       ${RUN} ${TOUCH} -t `expr \`date '+%Y'\` + 1`12310000 \
-                                       ${WRKSRC}/compiler/stage2/build/HS${DISTNAME}.o
-.endif
-
-.if ${MACHINE_ARCH} == "powerpc"
-WARNINGS+= "You won't be able to use GHCi library for GHC itself\
-because of powerpc ld bug."
-.endif
-
 # Some unused scripts don't pass the portability test.
 CHECK_PORTABILITY_SKIP+=       distrib/prep-bin-dist-mingw