]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
comments
[pkgsrc-ghc.git] / Makefile
index ddf834ea1d64e0250109d6a5bd4c015671d9017b..8a4e142c0bf96224cd5839cd00967aa03e9256f1 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -22,7 +22,10 @@ PKG_DESTDIR_SUPPORT= user-destdir
 .include "../../mk/bsd.prefs.mk"
 
 # Unregisterised HC packages are architecture dependent. We have to
-# create more HC packages to support more architectures.
+# create more HC packages to support more architectures. Note that
+# these packages are built with integer-simple, not integer-gmp, to
+# reduce some complexity by not depending on the GMP. The resulting
+# registerised GHC uses integer-gmp so this won't be a problem.
 ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386
 # Note: Darwin-*-powerpc is temporarily disabled for now. It shall
 # come back in the near future. Thanks for your patience.
@@ -45,7 +48,7 @@ CONFIGURE_ENV+=               PerlCmd=${PERL5:Q}
 # We don't want to extract all of the DISTFILEs.
 EXTRACT_ONLY=  ${DISTNAME}-src.tar.bz2
 
-PLATFORM= ${LOWER_ARCH}-unknown-${LOWER_OPSYS}
+PLATFORM= ${MACHINE_ARCH}-unknown-${LOWER_OPSYS}
 CONFIGURE_ARGS += \
        --build=${PLATFORM} \
        --host=${PLATFORM} \