]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
GHC 7.0.3 for powerpc-apple-darwin. It looks fully working, including GHCi!
[pkgsrc-ghc.git] / Makefile
index 127868ece18266f6563d5aab8adb39f1e40c5ff3..9247eb87b199afa9e4a958b1c5da9ef95b2985fe 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,22 +1,22 @@
 # $NetBSD: Makefile,v 1.42 2008/07/07 14:58:00 kristerw Exp $
 
 DISTNAME=              ghc-${VERSION}
-VERSION=               7.0.1
+VERSION=               7.0.3
 CATEGORIES=            lang
-MASTER_SITES=  http://new-www.haskell.org/ghc/dist/${VERSION}/
+MASTER_SITES=  http://www.haskell.org/ghc/dist/${VERSION}/
 MAINTAINER=            kristerw@NetBSD.org
 HOMEPAGE=              http://www.haskell.org/ghc/
 COMMENT=               Compiler for the functional language Haskell
 LICENSE=               modified-bsd
 
 DISTFILES=             ${DISTNAME}-src.tar.bz2
-DISTFILES+=            ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
-DISTFILES+=            ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
+#DISTFILES+=           ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
+#DISTFILES+=           ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
 DISTFILES+=            ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
 
 
-SITES.${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2     = http://static.cielonegro.org/archive/
-SITES.${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2    = http://static.cielonegro.org/archive/
+#SITES.${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2    = http://static.cielonegro.org/archive/
+#SITES.${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2   = http://static.cielonegro.org/archive/
 SITES.${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2    = http://static.cielonegro.org/archive/
 
 PKG_DESTDIR_SUPPORT=   user-destdir
@@ -31,7 +31,8 @@ PKG_DESTDIR_SUPPORT=  user-destdir
 #
 # If you want to build HC packages yourself, follow instructions in
 # the ./TODO file.
-ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386 Darwin-*-powerpc
+#ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386 Darwin-*-powerpc
+ONLY_FOR_PLATFORM= Darwin-*-powerpc
 
 # We must provide the real pass to gcc to the ./configure script,
 # because GHC has a runtime dependency on it. Aren't there any ways
@@ -83,9 +84,9 @@ PLATFORM           = i386-unknown-freebsd
 .elif ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap.mk
 PLATFORM           = powerpc-apple-darwin
-
 # Existence of libelf makes LeadingUnderscore being "NO", which is
-# incorrect. See ghc-6.12.1/aclocal.m4 (FP_LEADING_UNDERSCORE)
+# incorrect for this platform. See ghc-6.12.1/aclocal.m4
+# (FP_LEADING_UNDERSCORE)
 CONFLICTS=     libelf-[0-9]*
 
 .else
@@ -100,10 +101,11 @@ ${WRKDIR}/stamp-prepare-bootstrap:
        ${RUN} cd ${WRKDIR} && \
                ${ECHO} "====> Preparing bootstrap compiler" && \
                ${RM} -rf bootstrap && \
-               ${MKDIR} bootstrap && \
+               ${MKDIR} -p bootstrap && \
                ${CP} -r ${DISTNAME} bootstrap && \
                cd bootstrap/${DISTNAME} && \
-               ${LN} -sf ${PWD_CMD} utils/ghc-pwd/ghc-pwd && \
+               ${MKDIR} -p utils/ghc-pwd/dist-boot && \
+               ${LN} -sf ${PWD_CMD} utils/ghc-pwd/dist-boot/ghc-pwd && \
                ${TOUCH} $@
 
 ${WRKDIR}/stamp-configure-hc-boot: ${WRKDIR}/stamp-prepare-bootstrap
@@ -147,6 +149,10 @@ ${WRKDIR}/stamp-bootstrap-ghc: ${WRKDIR}/stamp-rewrite-hc-paths
                ${TOUCH} $@
 
 do-configure:
+# Seemingly by mistake, ghc-7.0.3 has a prebuilt
+# utils/ghc-pwd/dist-boot/ghc-pwd for amd64 GNU/Linux.
+       ${RUN} cd ${WRKSRC} && \
+               rm -rf utils/ghc-pwd/dist-boot
        ${RUN} cd ${WRKSRC} && \
                ${SETENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
 # We need to tell the libraries/terminfo/configure that our ncurses is