]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
7.6.2 for x86_64-unknown-linux
[pkgsrc-ghc.git] / Makefile
index ae6de059ef03e59ec893ff8469b6a033deec34f6..9a01243b49811ca0d47a06e29d500105ea0cdf0d 100644 (file)
--- a/Makefile
+++ b/Makefile
 # $NetBSD: Makefile,v 1.42 2008/07/07 14:58:00 kristerw Exp $
+# -----------------------------------------------------------------------------
+# Package metadata
+#
+DISTNAME=      ghc-${VERSION}
+VERSION=       7.6.2
+CATEGORIES=    lang
+MASTER_SITES=  http://www.haskell.org/ghc/dist/${VERSION}/
+MAINTAINER=    pho@cielonero.org
+HOMEPAGE=      http://www.haskell.org/ghc/
+COMMENT=       Compiler for the functional language Haskell
+LICENSE=       modified-bsd
+
+# GHC requires GHC to build itself. Formerly we could work around this
+# bootstrapping problem by creating a special archive containing C
+# sources compiled from Haskell sources, but that's no longer
+# possible. So we have to prepare stripped-down binaries sufficient to
+# bootstrap compilers for each platforms. If you want to build them
+# yourself, follow an instruction in the ./TODO file.
+ONLY_FOR_PLATFORM= \
+       Darwin-*-powerpc \
+       FreeBSD-*-i386 \
+       Linux-*-x86_64 \
+       NetBSD-*-i386 \
+       NetBSD-*-x86_64
+
+
+# -----------------------------------------------------------------------------
+# Distfiles
+#
+DISTFILES=     ${DISTNAME}-src.tar.bz2
+#DISTFILES+=   ${DISTNAME}-boot-i386-unknown-freebsd8.0.tar.bz2
+#DISTFILES+=   ${DISTNAME}-boot-i386-unknown-netbsdelf6.99.1.tar.bz2
+DISTFILES+=    ${DISTNAME}-boot-powerpc-apple-darwin.tar.xz
+DISTFILES+=    ${DISTNAME}-boot-x86_64-unknown-linux.tar.xz
+DISTFILES+=    ${DISTNAME}-boot-x86_64-unknown-netbsd.tar.xz
 
-DISTNAME=              ghc-${VERSION}
-VERSION=               6.12.3
-CATEGORIES=            lang
-MASTER_SITES=  http://darcs.haskell.org/download/dist/${VERSION}/
-MAINTAINER=            kristerw@NetBSD.org
-HOMEPAGE=              http://www.haskell.org/ghc/
-COMMENT=               Compiler for the functional language Haskell
-LICENSE=               modified-bsd
-
-DISTFILES=             ${DISTNAME}-src.tar.bz2
-#DISTFILES+=           ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
-#DISTFILES+=           ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
-DISTFILES+=            ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
-
-
-SITES.${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2     = http://static.cielonegro.org/archive/
-SITES.${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2    = http://static.cielonegro.org/archive/
-SITES.${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2    = http://static.cielonegro.org/archive/
+.for i in ${DISTFILES:M*-boot-*}
+SITES.${i}=    http://static.cielonegro.org/archive/
+.endfor
 
-PKG_DESTDIR_SUPPORT=   user-destdir
+# We don't want to extract all of the DISTFILEs.
+EXTRACT_ONLY=  ${DISTNAME}-src.tar.bz2
 
-.include "../../mk/bsd.prefs.mk"
 
-# Unregisterised HC packages are architecture dependent. We have to
-# create more HC packages to support more architectures. Note that
-# these packages are built with integer-simple, not integer-gmp, to
-# reduce some complexity by not depending on the GMP. The resulting
-# registerised GHC uses integer-gmp so this won't be a problem.
-ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386 Darwin-*-powerpc
+# -----------------------------------------------------------------------------
+# Tools
+#
+USE_TOOLS+=                    autoconf gmake perl:run
+GNU_CONFIGURE=                 yes
+USE_GNU_CONFIGURE_HOST=        no
 
-# We must provide the real pass to gcc to the ./configure script,
+# We must provide the real path to gcc to the ./configure script,
 # because GHC has a runtime dependency on it. Aren't there any ways
 # better than this?
 .include "../../mk/compiler.mk"
 .if empty(CCPATH)
-WARNINGS+= "This package depends on pkgsrc's undocumented variable\
+CCPATH=        /usr/bin/gcc
+WARNINGS+="This package depends on pkgsrc's undocumented variable\
 CCPATH but it disappeared somehow."
-WARNINGS+= "Using hard-coded /usr/bin/gcc as the C compiler..."
-CONFIGURE_ARGS+= --with-gcc=/usr/bin/gcc
-.else
-CONFIGURE_ARGS+= --with-gcc=${CCPATH}
+WARNINGS+="Using hard-coded ${CCPATH:Q} as the C compiler..."
 .endif
 
-USE_TOOLS+=    gmake bsdtar perl:run
-CONFIGURE_ENV+=                PerlCmd=${PERL5:Q}
+CONFIGURE_ARGS+= \
+       --with-gcc=${CCPATH:Q} \
+       --with-gmp-includes=${PREFIX:Q}/include \
+       --with-gmp-libraries=${PREFIX:Q}/lib \
+       --with-iconv-includes=${PREFIX:Q}/include \
+       --with-iconv-libraries=${PREFIX:Q}/lib
+
+CONFIGURE_ENV+= \
+       PerlCmd=${PERL5:Q}
 
-# We don't want to extract all of the DISTFILEs.
-EXTRACT_ONLY=  ${DISTNAME}-src.tar.bz2
 
-CONFIGURE_ARGS += \
-       --build=${PLATFORM} \
-       --host=${PLATFORM} \
-       --target=${PLATFORM} \
-       --prefix=${PREFIX} \
-       --mandir=${PREFIX}/${PKGMANDIR} \
-       --with-gmp-includes=${PREFIX}/include \
-       --with-gmp-libraries=${PREFIX}/lib \
-       --with-iconv-includes=${PREFIX}/include \
-       --with-iconv-libraries=${PREFIX}/lib
-
-# Build an unregisterised bootstrap compiler and install it directly
-# into the .buildlink directory. But we can't use "make install"
-# because we don't build it in a standard way (./configure && make).
+# -----------------------------------------------------------------------------
+# Build hooks
 #
-# To install it, we just copy ghc and ghc-pkg from
-# "work/bootstrap/ghc-${VERSION}/inplace/bin" to
-# "${BUILDLINK_DIR}/bin". Note that in-place ghc isn't usable before
-# running "ghc-pkg recache".
 
-.if ${MACHINE_ARCH} == "i386" && ${OPSYS} == "NetBSD"
-BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
-PLATFORM           = i386-unknown-netbsd
+# We patch configure.ac in some directories.
+post-patch:
+       @${PHASE_MSG} "Regenerating configuration scripts for ${PKGNAME}"
+       ${RUN} cd ${WRKSRC:Q}/libraries/integer-gmp && autoconf
 
-.elif ${MACHINE_ARCH} == "i386" && ${OPSYS} == "FreeBSD"
-BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
-PLATFORM           = i386-unknown-freebsd
 
-.elif ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
-BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap.mk
-PLATFORM           = powerpc-apple-darwin
+# Define the target "pre-configure" and non-standard "bootstrap".
+.include "../../wip/ghc/bootstrap.mk"
 
-# Existence of libelf makes LeadingUnderscore being "NO", which is
-# incorrect. See ghc-6.12.1/aclocal.m4 (FP_LEADING_UNDERSCORE)
-CONFLICTS=     libelf-[0-9]*
 
-.else
-PKG_FAIL_REASON+=      "internal error: unsupported platform"
-.endif
+# Our pre-configure phase installs a bindist of bootstrapping compiler
+# directly into TOOLS_DIR so that ./configure can find it.
+do-configure:
+       ${RUN} cd ${WRKSRC:Q} && \
+               ${SETENV} ${CONFIGURE_ENV} ${SH} ./configure ${CONFIGURE_ARGS}
 
-BOOTSTRAP_TARBALL = ${DISTNAME}-boot-${PLATFORM}.tar.bz2
-
-pre-configure:
-       ${RUN} cd ${WRKDIR} && \
-               ${ECHO} "====> Preparing bootstrap compiler" && \
-               ${MKDIR} bootstrap && \
-               ${CP} -r ${DISTNAME} bootstrap && \
-               cd bootstrap/${DISTNAME} && \
-               ${LN} -sf ${PWD_CMD} utils/ghc-pwd/ghc-pwd && \
-               ${ECHO} "====> Configuring for bootstrap compiler" && \
-               ${SETENV} ${CONFIGURE_ENV} ./configure --enable-hc-boot --with-ghc="" ${CONFIGURE_ARGS} && \
-               ${ECHO} "====> Extracting bootstrap HC archive" && \
-               (cd .. && bsdtar jxfm ${DISTDIR}/${BOOTSTRAP_TARBALL}) && \
-               ${SH} mkfiles && \
-               ${ECHO} "====> Building bootstrap compiler" && \
-               ${SED} -e "s#\\[\\[PREFIX\\]\\]#${PREFIX}#g" ${BOOTSTRAP_BUILD_MK} > mk/build.mk && \
-               for c in libraries/*/configure; do \
-                       (cd `${DIRNAME} $$c` && ${SETENV} ${CONFIGURE_ENV} ${SH} configure ${CONFIGURE_ARGS}); \
-               done && \
-               for i in inplace/lib/package.conf.d/*.conf */*/package-data.mk */*/*/package-data.mk; do \
-                       ${SED} -e "s#\\[\\[GHC_SOURCE_PATH\\]\\]#`${PWD_CMD}`#g" $$i > $$i.tmp; \
-                       ${MV} -f $$i.tmp $$i; \
-               done && \
-               ${TOUCH} -r inplace/lib/package.conf.d */*/package-data.mk */*/*/package-data.mk && \
-               ${GMAKE} bootstrapping-files && \
-               ${GMAKE} all_ghc_stage2 && \
-               ${GMAKE} inplace/bin/ghc-pkg && \
-               ${GMAKE} inplace/lib/unlit && \
-               inplace/bin/ghc-pkg recache && \
-               ${CP} inplace/bin/ghc-stage2 ${BUILDLINK_DIR}/bin/ghc && \
-               ${CP} inplace/bin/ghc-pkg ${BUILDLINK_DIR}/bin/ghc-pkg
+# Here we generate mk/build.mk dynamically.
+       ${RUN} ${RM} -f ${WRKSRC:Q}/mk/build.mk
 
-do-configure:
-       ${RUN} cd ${WRKSRC} && \
-               ${SETENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
-# We need to tell the libraries/integer-gmp/configure that libgmp is
+# We need to tell the libraries/terminfo/configure that our ncurses is
 # in a non-standard path. Without that, the resulting GHC tries to
-# link programs by executing ld(1) without passing it -L${PREFIX}/lib.
-       ${RUN} ${ECHO} "libraries/integer-gmp_CONFIGURE_OPTS += \
-               --configure-option=--with-gmp-includes=${PREFIX}/include \
-               --configure-option=--with-gmp-libraries=${PREFIX}/lib" > ${WRKSRC}/mk/build.mk
-# The ncurses is also in a non-standard path.
+# link programs by executing ld(1) without passing it -L${PREFIX:Q}/lib.
        ${RUN} ${ECHO} "libraries/terminfo_CONFIGURE_OPTS += \
-               --configure-option=--with-curses-includes=${PREFIX}/include \
-               --configure-option=--with-curses-libraries=${PREFIX}/lib" >> ${WRKSRC}/mk/build.mk
-# The ghc compiler does normally split the generated C files into small
+               --configure-option=--with-curses-includes=${PREFIX:Q}/include \
+               --configure-option=--with-curses-libraries=${PREFIX:Q}/lib" >> ${WRKSRC:Q}/mk/build.mk
+
+# The ghc compiler does normally split the generated asm files into small
 # parts before sending them to gcc, to enable the linker to eliminate
 # unused parts.  This does however not play nice with the pkgsrc
 # framework, and the result is that the build takes more than 5 times
@@ -142,51 +110,79 @@ do-configure:
 #    http://mail-index.netbsd.org/tech-pkg/2006/07/30/0005.html
 # for a description of the problem.
 # Disable file splitting until pkgsrc gets improved.
-       ${RUN} ${ECHO} "SplitObjs = NO" >> ${WRKSRC}/mk/build.mk
-# If we don't explicitly disable HsColour, PLIST gets changed
-# depending on whether we have installed it or not.
-       ${RUN} ${ECHO} "HSCOLOUR_SRCS = NO" >> ${WRKSRC}/mk/build.mk
-# To avoid powerpc crash...
-# See http://hackage.haskell.org/trac/ghc/ticket/4034
-.if ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
-       ${RUN} ${ECHO} "GhcRtsHcOpts = -optc-O0 -optc-g" >> ${WRKSRC}/mk/build.mk
-       ${RUN} ${ECHO} "GhcRtsCcOpts = -O0 -g" >> ${WRKSRC}/mk/build.mk
-.endif
+       ${RUN} ${ECHO} "SplitObjs         = NO" >> ${WRKSRC:Q}/mk/build.mk
 
-pre-build:
-# We have to sacrifice the GHCi library for GHC itself to work around
-# for powerpc ld bug.  See
-# http://hackage.haskell.org/trac/ghc/ticket/3260
-.if ${MACHINE_ARCH} == "powerpc"
-       ${RUN} ${MKDIR} ${WRKSRC}/compiler/stage1/build
-       ${RUN} ${TOUCH} -t `expr \`date '+%Y'\` + 1`12310000 \
-                                       ${WRKSRC}/compiler/stage1/build/HS${DISTNAME}.o
-       ${RUN} ${MKDIR} ${WRKSRC}/compiler/stage2/build
-       ${RUN} ${TOUCH} -t `expr \`date '+%Y'\` + 1`12310000 \
-                                       ${WRKSRC}/compiler/stage2/build/HS${DISTNAME}.o
-.endif
+# If there is HsColour is in the PATH, GHC's build system tries to use
+# it without even checking if it really works. That's not what we
+# appreciate.
+       ${RUN} ${ECHO} "HSCOLOUR_SRCS     = NO" >> ${WRKSRC:Q}/mk/build.mk
 
-.if ${MACHINE_ARCH} == "powerpc"
-WARNINGS+= "You won't be able to use GHCi library for GHC itself\
-because of powerpc ld bug."
+# Don't even think of PDF.
+       ${RUN} ${ECHO} "BUILD_DOCBOOK_PS  = NO" >> ${WRKSRC:Q}/mk/build.mk
+       ${RUN} ${ECHO} "BUILD_DOCBOOK_PDF = NO" >> ${WRKSRC:Q}/mk/build.mk
+
+
+# -----------------------------------------------------------------------------
+# Installation/removal hooks
+#
+
+# Substitutions for INSTALL and DEINSTALL that handles package.cache.
+FILES_SUBST+=  DISTNAME=${DISTNAME}
+
+# We don't want package.cache to be in the PLIST.
+post-install:
+       ${RM} -f ${DESTDIR:Q}${PREFIX:Q}/lib/${DISTNAME}/package.conf.d/package.cache
+
+
+# -----------------------------------------------------------------------------
+# PLIST
+#
+# We can't use static PLIST because the package installs some files
+# whose names are randomly generated, namely
+# lib/${PKGNAME}/package.conf.d/*.conf
+#
+
+# If we were lucky we could just use "PLIST_TYPE = dynamic", but the
+# feature has seemingly bitrotted.
+.include "../../mk/bsd.prefs.mk"
+.if empty(DESTDIR)
+PKG_FAIL_REASON+="This package can not be built without using DESTDIR.\
+You need to set USE_DESTDIR to \"yes\"."
+.else
+GENERATE_PLIST+= \
+       cd ${DESTDIR:Q}${PREFIX:Q} && \
+               ${FIND} * \( -type f -or -type l \) | ${SORT} -d;
 .endif
 
-# Some unused scripts don't pass the portability test.
+
+# -----------------------------------------------------------------------------
+# Sanity checks
+#
+
+# There is an unused script which don't pass the portability test.
 CHECK_PORTABILITY_SKIP+=       distrib/prep-bin-dist-mingw
 
 # GHC currently *requires* ${PREFIX}/lib to be in
 # "/etc/ld-elf.so.conf". See
 # http://hackage.haskell.org/trac/ghc/ticket/2933
-CHECK_SHLIBS_SUPPORTED=        no
+CHECK_SHLIBS_SUPPORTED=        no
+
+
+# -----------------------------------------------------------------------------
+# Dependencies
+#
 
 # I guess pdcurses works well but not tested.
 USE_NCURSES=   yes
-.include "../../devel/ncurses/buildlink3.mk"
 
-BUILD_DEPENDS+=        docbook-xsl-[0-9]*:../../textproc/docbook-xsl
-BUILDLINK_DEPMETHOD.libxslt = build
+BUILDLINK_DEPMETHOD.docbook-xsl=       build
+BUILDLINK_DEPMETHOD.libxslt=           build
+BUILDLINK_DEPMETHOD.xz=                build
+.include "../../archivers/xz/buildlink3.mk"
 .include "../../converters/libiconv/buildlink3.mk"
 .include "../../devel/gmp/buildlink3.mk"
+.include "../../devel/ncurses/buildlink3.mk"
 .include "../../textproc/libxslt/buildlink3.mk"
+.include "../../textproc/docbook-xsl/buildlink3.mk"
 .include "../../mk/pthread.buildlink3.mk"
 .include "../../mk/bsd.pkg.mk"