]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.
[pkgsrc-ghc.git] / Makefile
index f16a711d4754d77687b523474fd73dec618cc199..9d935b760454b84f61199b3c5ee3d3318364ecc6 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -19,8 +19,6 @@ DISTFILES+=   ${DISTNAME}-boot-x86_64-unknown-linux-gnu.tar.bz2
 SITES.${i}=    http://static.cielonegro.org/archive/
 .endfor
 
-PKG_DESTDIR_SUPPORT=   user-destdir
-
 # Unregisterised HC packages are platform-dependent C sources. Yes,
 # they are C sources but are totally non-portable. We have to create
 # more HC packages to support more platforms. Note that those packages
@@ -50,7 +48,7 @@ CONFIGURE_ARGS+= --with-gcc=/usr/bin/gcc
 CONFIGURE_ARGS+= --with-gcc=${CCPATH}
 .endif
 
-USE_TOOLS+=    autoconf date gmake gtar perl perl:run
+USE_TOOLS+=    gmake perl:run
 CONFIGURE_ENV+=        PerlCmd=${PERL5:Q}
 
 # We don't want to extract all of the DISTFILEs.
@@ -68,7 +66,7 @@ CONFIGURE_ARGS += \
        --with-iconv-libraries=${PREFIX}/lib
 
 # Define ${PLATFORM} and the target "pre-configure".
-.include "../../wip/ghc/stage0.mk"
+.include "../../wip/ghc/bootstrap.mk"
 
 do-configure:
        ${RUN} cd ${WRKSRC} && \