]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
GHC depends on some ncurses specific functions.
[pkgsrc-ghc.git] / Makefile
index 399d09d818d8316ef60c0b5f16dcd655571ebc4f..a2aec8c4a2f03f752460174a6badadd9a9b8e823 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -49,7 +49,6 @@ CONFIGURE_ENV+=               PerlCmd=${PERL5:Q}
 # We don't want to extract all of the DISTFILEs.
 EXTRACT_ONLY=  ${DISTNAME}-src.tar.bz2
 
-PLATFORM= ${MACHINE_ARCH}-unknown-${LOWER_OPSYS}
 CONFIGURE_ARGS += \
        --build=${PLATFORM} \
        --host=${PLATFORM} \
@@ -71,16 +70,17 @@ CONFIGURE_ARGS += \
 # running "ghc-pkg recache".
 
 .if ${MACHINE_ARCH} == "i386" && ${OPSYS} == "NetBSD"
-BOOTSTRAP_TARBALL  = ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
+PLATFORM           = i386-unknown-netbsd
 
 .elif ${MACHINE_ARCH} == "i386" && ${OPSYS} == "FreeBSD"
-BOOTSTRAP_TARBALL = ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
+PLATFORM           = i386-unknown-freebsd
 
 .elif ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
-BOOTSTRAP_TARBALL = ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap.mk
+PLATFORM           = powerpc-apple-darwin
+
 # Existence of libelf makes LeadingUnderscore being "NO", which is
 # incorrect. See ghc-6.12.1/aclocal.m4 (FP_LEADING_UNDERSCORE)
 CONFLICTS=     libelf-[0-9]*
@@ -89,6 +89,8 @@ CONFLICTS=    libelf-[0-9]*
 PKG_FAIL_REASON+=      "internal error: unsupported platform"
 .endif
 
+BOOTSTRAP_TARBALL = ${DISTNAME}-boot-${PLATFORM}.tar.bz2
+
 pre-configure:
        ${RUN} cd ${WRKDIR} && \
                ${ECHO} "====> Preparing bootstrap compiler" && \
@@ -132,6 +134,7 @@ do-configure:
                --configure-option=--with-curses-includes=${PREFIX}/include \
                --configure-option=--with-curses-libraries=${PREFIX}/lib" >> ${WRKSRC}/mk/build.mk
 
+pre-build:
 # The ghc compiler does normally split the generated C files into small
 # parts before sending them to gcc, to enable the linker to eliminate
 # unused parts.  This does however not play nice with the pkgsrc
@@ -140,16 +143,20 @@ do-configure:
 #    http://mail-index.netbsd.org/tech-pkg/2006/07/30/0005.html
 # for a description of the problem.
 # Disable file splitting until pkgsrc gets improved.
-pre-build:
        ${RUN} ${ECHO} "SplitObjs = NO" >> ${WRKSRC}/mk/build.mk
+# If we don't explicitly disable HsColour, PLIST gets changed
+# depending on whether we have installed it or not.
+       ${RUN} ${ECHO} "HSCOLOUR_SRCS = NO" >> ${WRKSRC}/mk/build.mk
 # We have to sacrifice the GHCi library for GHC itself to work around
 # for powerpc ld bug.  See
 # http://hackage.haskell.org/trac/ghc/ticket/3260
 .if ${MACHINE_ARCH} == "powerpc"
        ${RUN} ${MKDIR} ${WRKSRC}/compiler/stage1/build
-       ${RUN} ${TOUCH} ${WRKSRC}/compiler/stage1/build/HS${DISTNAME}.o
+       ${RUN} ${TOUCH} -t `expr \`date '+%Y'\` + 1`12310000 \
+                                       ${WRKSRC}/compiler/stage1/build/HS${DISTNAME}.o
        ${RUN} ${MKDIR} ${WRKSRC}/compiler/stage2/build
-       ${RUN} ${TOUCH} ${WRKSRC}/compiler/stage2/build/HS${DISTNAME}.o
+       ${RUN} ${TOUCH} -t `expr \`date '+%Y'\` + 1`12310000 \
+                                       ${WRKSRC}/compiler/stage2/build/HS${DISTNAME}.o
 .endif
 
 .if ${MACHINE_ARCH} == "powerpc"
@@ -165,10 +172,11 @@ CHECK_PORTABILITY_SKIP+=  distrib/prep-bin-dist-mingw
 # http://hackage.haskell.org/trac/ghc/ticket/2933
 CHECK_SHLIBS_SUPPORTED=        no
 
+BUILD_DEPENDS+=        docbook-xsl-[0-9]*:../../textproc/docbook-xsl
 BUILDLINK_DEPMETHOD.libxslt = build
 .include "../../converters/libiconv/buildlink3.mk"
 .include "../../devel/gmp/buildlink3.mk"
+.include "../../devel/ncurses/buildlink3.mk" # I guess pdcurses works well but not tested.
 .include "../../textproc/libxslt/buildlink3.mk"
-.include "../../mk/termcap.buildlink3.mk"
 .include "../../mk/pthread.buildlink3.mk"
 .include "../../mk/bsd.pkg.mk"