]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
Upstream update to GHC 6.10.4
[pkgsrc-ghc.git] / Makefile
index 4bf1b2c129afe5dde718cd9000c0ff84ee8f4eb8..a732e84192e3686506f1098420780c49b4993151 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,12 +1,13 @@
 # $NetBSD: Makefile,v 1.42 2008/07/07 14:58:00 kristerw Exp $
 
 DISTNAME=              ghc-${VERSION}
-VERSION=               6.10.3
+VERSION=               6.10.4
 CATEGORIES=            lang
 MASTER_SITES=  http://www.haskell.org/ghc/dist/${VERSION}/
 MAINTAINER=            kristerw@NetBSD.org
 HOMEPAGE=              http://www.haskell.org/ghc/
 COMMENT=               Compiler for the functional language Haskell
+LICENSE=               modified-bsd
 
 DISTFILES=             ${DISTNAME}-src.tar.bz2 \
                                ghc-6.6.1-src.tar.bz2 \
@@ -17,6 +18,8 @@ SITES.ghc-6.6.1-src.tar.bz2                                           = http://www.haskell.org/ghc/dist/6.6.1/
 SITES.ghc-6.6.1-powerpc-apple-darwin-hc.tar.gz = http://static.cielonegro.org/archive/
 SITES.ghc-6.6.1-i386-unknown-freebsd-hc.tar.gz = http://static.cielonegro.org/archive/
 
+PKG_DESTDIR_SUPPORT=   user-destdir
+
 .include "../../mk/bsd.prefs.mk"
 
 # Unregisterised HC packages are architecture dependent. We have to
@@ -37,12 +40,18 @@ EXTRACT_ONLY += ghc-6.6.1-i386-unknown-freebsd-hc.tar.gz
 EXTRACT_ONLY += ghc-6.6.1-powerpc-apple-darwin-hc.tar.gz
 .endif
 
+# We need to tell the ./configure that libgmp is in a non-standard path. Without
+# that, the resulting GHC tries to link programs by executing ld(1) without
+# passing it -L${PREFIX}/lib.
+CONFIGURE_ARGS += --with-gmp-includes=${PREFIX}/include
+CONFIGURE_ARGS += --with-gmp-libraries=${PREFIX}/lib
+
 # Build an unregisterised bootstrap compiler and install it directly
 # into the .buildlink directory. But we can't use "make install"
 # because we don't build it in a standard way (./configure && make).
 #
 # To install it, we search for any non-symlink executables in
-# work/ghc-6.4.2 whose name ends with "-inplace". Then copy those
+# work/ghc-6.6.1 whose name ends with "-inplace". Then copy those
 # files into ${BUILDLINK_DIR}/bin with dropping the "-inplace" at
 # their tails.
 pre-configure: