]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
Darwin-*-powerpc: rethink about the way to avoid the "ld -r" problem.
[pkgsrc-ghc.git] / Makefile
index ded3b80cca5108e29b18c50c3e079dacfeca0daa..b44037cd2f93a5b42ecbbd586aafcac3961df9f2 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -80,6 +80,8 @@ PLATFORM           = i386-unknown-freebsd
 .elif ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap.mk
 PLATFORM           = powerpc-apple-darwin
+WARNINGS+= "You won't be able to use GHCi library for GHC itself\
+because of Mach-O limitation."
 
 # Existence of libelf makes LeadingUnderscore being "NO", which is
 # incorrect. See ghc-6.12.1/aclocal.m4 (FP_LEADING_UNDERSCORE)
@@ -153,24 +155,6 @@ do-configure:
        ${RUN} ${ECHO} "GhcRtsCcOpts = -O0 -g" >> ${WRKSRC}/mk/build.mk
 .endif
 
-pre-build:
-# We have to sacrifice the GHCi library for GHC itself to work around
-# for powerpc ld bug.  See
-# http://hackage.haskell.org/trac/ghc/ticket/3260
-.if ${MACHINE_ARCH} == "powerpc"
-       ${RUN} ${MKDIR} ${WRKSRC}/compiler/stage1/build
-       ${RUN} ${TOUCH} -t `expr \`date '+%Y'\` + 1`12310000 \
-                                       ${WRKSRC}/compiler/stage1/build/HS${DISTNAME}.o
-       ${RUN} ${MKDIR} ${WRKSRC}/compiler/stage2/build
-       ${RUN} ${TOUCH} -t `expr \`date '+%Y'\` + 1`12310000 \
-                                       ${WRKSRC}/compiler/stage2/build/HS${DISTNAME}.o
-.endif
-
-.if ${MACHINE_ARCH} == "powerpc"
-WARNINGS+= "You won't be able to use GHCi library for GHC itself\
-because of powerpc ld bug."
-.endif
-
 # Some unused scripts don't pass the portability test.
 CHECK_PORTABILITY_SKIP+=       distrib/prep-bin-dist-mingw