]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
regenerated PLIST.Darwin-powerpc
[pkgsrc-ghc.git] / Makefile
index 9d18724639e1c6e519982dd1eae845d09770b3e1..bb6636720dca57bd20ce14d0db1e430b7878b128 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -149,9 +149,11 @@ pre-build:
 # http://hackage.haskell.org/trac/ghc/ticket/3260
 .if ${MACHINE_ARCH} == "powerpc"
        ${RUN} ${MKDIR} ${WRKSRC}/compiler/stage1/build
-       ${RUN} ${TOUCH} ${WRKSRC}/compiler/stage1/build/HS${DISTNAME}.o
+       ${RUN} ${TOUCH} -t `expr \`date '+%Y'\` + 1`01010000 \
+                                       ${WRKSRC}/compiler/stage1/build/HS${DISTNAME}.o
        ${RUN} ${MKDIR} ${WRKSRC}/compiler/stage2/build
-       ${RUN} ${TOUCH} ${WRKSRC}/compiler/stage2/build/HS${DISTNAME}.o
+       ${RUN} ${TOUCH} -t `expr \`date '+%Y'\` + 1`01010000 \
+                                       ${WRKSRC}/compiler/stage2/build/HS${DISTNAME}.o
 .endif
 
 .if ${MACHINE_ARCH} == "powerpc"