]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
Fix --with-curses-includes to point to the correct path to ncurses headers
[pkgsrc-ghc.git] / Makefile
index 1639a3d042ed334b1b3f7bb65fce215b1ce00768..cba47056fe6e7b402e7804ccaae04d98944fe3fd 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -159,7 +159,7 @@ do-configure:
 # in a non-standard path. Without that, the resulting GHC tries to
 # link programs by executing ld(1) without passing it -L${PREFIX}/lib.
        ${RUN} ${ECHO} "libraries/terminfo_CONFIGURE_OPTS += \
-               --configure-option=--with-curses-includes=${PREFIX}/include \
+               --configure-option=--with-curses-includes=${PREFIX}/include/ncurses \
                --configure-option=--with-curses-libraries=${PREFIX}/lib" >> ${WRKSRC}/mk/build.mk
 # The ghc compiler does normally split the generated asm files into small
 # parts before sending them to gcc, to enable the linker to eliminate