]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
fix TODO
[pkgsrc-ghc.git] / Makefile
index b9d31283b122d57cba4c898cd1812ffbece4f6f1..cba47056fe6e7b402e7804ccaae04d98944fe3fd 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -39,7 +39,7 @@ ONLY_FOR_PLATFORM= FreeBSD-*-i386 Darwin-*-powerpc
 # better than this?
 .include "../../mk/compiler.mk"
 .if empty(CCPATH)
-WARNINGS+= "This package depends on pkgsrc's undocumented variable\
+WARNINGS+= "This package depends on pkgsrc's undocumented variable \
 CCPATH but it disappeared somehow."
 WARNINGS+= "Using hard-coded /usr/bin/gcc as the C compiler..."
 CONFIGURE_ARGS+= --with-gcc=/usr/bin/gcc
@@ -159,7 +159,7 @@ do-configure:
 # in a non-standard path. Without that, the resulting GHC tries to
 # link programs by executing ld(1) without passing it -L${PREFIX}/lib.
        ${RUN} ${ECHO} "libraries/terminfo_CONFIGURE_OPTS += \
-               --configure-option=--with-curses-includes=${PREFIX}/include \
+               --configure-option=--with-curses-includes=${PREFIX}/include/ncurses \
                --configure-option=--with-curses-libraries=${PREFIX}/lib" >> ${WRKSRC}/mk/build.mk
 # The ghc compiler does normally split the generated asm files into small
 # parts before sending them to gcc, to enable the linker to eliminate
@@ -183,7 +183,7 @@ do-configure:
 # Substitutions for INSTALL and DEINSTALL.
 FILES_SUBST+=  DISTNAME=${DISTNAME}
 
-# Some unused scripts don't pass the portability test.
+# There is an unused script which don't pass the portability test.
 CHECK_PORTABILITY_SKIP+=       distrib/prep-bin-dist-mingw
 
 # GHC currently *requires* ${PREFIX}/lib to be in