]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
Added INSTALL script
[pkgsrc-ghc.git] / Makefile
index 9164300fcf9267087b302e08d1afdc526f5eaa27..dbe893ed11387e7536a35466ff2a0170e7670b67 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -10,9 +10,11 @@ COMMENT=             Compiler for the functional language Haskell
 LICENSE=               modified-bsd
 
 DISTFILES=             ${DISTNAME}-src.tar.bz2 \
+                               ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2 \
                                ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
 
 SITES.${DISTNAME}-src.tar.bz2                                          = http://www.haskell.org/ghc/dist/${VERSION}/
+SITES.${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2     = http://static.cielonegro.org/archive/
 SITES.${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2    = http://static.cielonegro.org/archive/
 
 PKG_DESTDIR_SUPPORT=   user-destdir
@@ -21,20 +23,31 @@ PKG_DESTDIR_SUPPORT=        user-destdir
 
 # Unregisterised HC packages are architecture dependent. We have to
 # create more HC packages to support more architectures.
-#ONLY_FOR_PLATFORM= *-*-i386 *-*-powerpc
-ONLY_FOR_PLATFORM= *-*-i386
+ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386
+# Note: Darwin-*-powerpc is temporarily disabled for now. It shall
+# come back in the near future. Thanks for your patience.
+
+# We must provide the real pass to gcc to the ./configure script,
+# because GHC has a runtime dependency on it. Aren't there any better
+# way than this?
+.include "../../mk/compiler.mk"
+.if empty(CCPATH)
+WARNINGS+= "This package depends on pkgsrc's undocumented variable CCPATH but it disappeared somehow."
+WARNINGS+= "Using hard-coded /usr/bin/gcc as the C compiler..."
+CONFIGURE_ARGS+= --with-gcc=/usr/bin/gcc
+.else
+CONFIGURE_ARGS+= --with-gcc=${CCPATH}
+.endif
 
-USE_TOOLS+=    gmake bsdtar perl
+USE_TOOLS+=    gmake bsdtar perl:run
+CONFIGURE_ENV+=                PerlCmd=${PERL5:Q}
 
 # We don't want to extract all of the DISTFILEs.
 EXTRACT_ONLY=  ${DISTNAME}-src.tar.bz2
 
-# We need to tell the ./configure that libgmp is in a non-standard path. Without
-# that, the resulting GHC tries to link programs by executing ld(1) without
-# passing it -L${PREFIX}/lib.
 CONFIGURE_ARGS += \
        --prefix=${PREFIX} \
-       --mandir=${PKGMANDIR} \
+       --mandir=${PREFIX}/${PKGMANDIR} \
        --with-gmp-includes=${PREFIX}/include \
        --with-gmp-libraries=${PREFIX}/lib \
        --with-iconv-includes=${PREFIX}/include \
@@ -49,16 +62,20 @@ CONFIGURE_ARGS += \
 # "${BUILDLINK_DIR}/bin". Note that in-place ghc isn't usable before
 # running "ghc-pkg recache".
 
-.if ${MACHINE_ARCH} == "i386"
+.if ${MACHINE_ARCH} == "i386" && ${OPSYS} == "NetBSD"
+BOOTSTRAP_TARBALL  = ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
+BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
+
+.elif ${MACHINE_ARCH} == "i386" && ${OPSYS} == "FreeBSD"
 BOOTSTRAP_TARBALL = ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
-#.elif ${MACHINE_ARCH} == "powerpc"
+BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
+
+#.elif ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
 #BOOTSTRAP_TARBALL = ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
-.endif
+#BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap.mk
 
-.if ${OPSYS} == "NetBSD" || ${OPSYS} == "DragonFly" || ${OPSYS} == "FreeBSD" || ${OPSYS} == "OpenBSD"
-BUILD_MK = ${PKGDIR}/files/bsd-build.mk
 .else
-BUILD_MK = ${PKGDIR}/files/fallback-build.mk
+PKG_FAIL_REASON+=      "internal error: unsupported platform"
 .endif
 
 pre-configure:
@@ -74,12 +91,14 @@ pre-configure:
                (cd .. && bsdtar jxfm ${DISTDIR}/${BOOTSTRAP_TARBALL}) && \
                ${SH} mkfiles && \
                ${ECHO} "====> Building bootstrap compiler" && \
-               ${SED} -e 's#\\[\\[PREFIX\\]\\]#${PREFIX}#g' ${BUILD_MK} > mk/build.mk && \
+               ${SED} -e "s#\\[\\[PREFIX\\]\\]#${PREFIX}#g" ${BOOTSTRAP_BUILD_MK} > mk/build.mk && \
                for c in libraries/*/configure; do \
                        (cd `${DIRNAME} $$c` && ${ENV} ${CONFIGURE_ENV} ${SH} configure ${CONFIGURE_ARGS}); \
                done && \
-               ${SED} -i -e "s#\\[\\[GHC_SOURCE_PATH\\]\\]#`${PWD_CMD}`#g" \
-                       inplace/lib/package.conf.d/*.conf */*/package-data.mk */*/*/package-data.mk && \
+               for i in inplace/lib/package.conf.d/*.conf */*/package-data.mk */*/*/package-data.mk; do \
+                       ${SED} -e "s#\\[\\[GHC_SOURCE_PATH\\]\\]#`${PWD_CMD}`#g" $$i > $$i.tmp; \
+                       ${MV} -f $$i.tmp $$i; \
+               done && \
                ${TOUCH} -r inplace/lib/package.conf.d */*/package-data.mk */*/*/package-data.mk && \
                ${GMAKE} bootstrapping-files && \
                ${GMAKE} all_ghc_stage2 && \
@@ -89,9 +108,18 @@ pre-configure:
                ${CP} inplace/bin/ghc-stage2 ${BUILDLINK_DIR}/bin/ghc && \
                ${CP} inplace/bin/ghc-pkg ${BUILDLINK_DIR}/bin/ghc-pkg
 
+# We need to tell the libraries/integer-gmp/configure that libgmp is
+# in a non-standard path. Without that, the resulting GHC tries to
+# link programs by executing ld(1) without passing it -L${PREFIX}/lib.
 do-configure:
        ${RUN} cd ${WRKSRC} && \
                ${ENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
+       ${RUN} ${ECHO} "libraries/integer-gmp_CONFIGURE_OPTS += \
+               --configure-option=--with-gmp-includes=${PREFIX}/include \
+               --configure-option=--with-gmp-libraries=${PREFIX}/lib" > ${WRKSRC}/mk/build.mk
+       ${RUN} ${ECHO} "libraries/terminfo_CONFIGURE_OPTS += \
+               --configure-option=--with-curses-includes=${PREFIX}/include \
+               --configure-option=--with-curses-libraries=${PREFIX}/lib" >> ${WRKSRC}/mk/build.mk
 
 # The ghc compiler does normally split the generated C files into small
 # parts before sending them to gcc, to enable the linker to eliminate
@@ -102,11 +130,16 @@ do-configure:
 # for a description of the problem.
 # Disable file splitting until pkgsrc gets improved.
 pre-build:
-       ${ECHO} "SplitObjs=NO" > ${WRKSRC}/mk/build.mk
+       ${RUN} ${ECHO} "SplitObjs = NO" >> ${WRKSRC}/mk/build.mk
 
 # Some unused scripts don't pass the portability test.
 CHECK_PORTABILITY_SKIP+=       distrib/prep-bin-dist-mingw
 
+# GHC currently *requires* ${PREFIX}/lib to be in
+# "/etc/ld-elf.so.conf". See
+# http://hackage.haskell.org/trac/ghc/ticket/2933
+CHECK_SHLIBS_SUPPORTED=        no
+
 BUILDLINK_DEPMETHOD.libxslt = build
 .include "../../converters/libiconv/buildlink3.mk"
 .include "../../devel/gmp/buildlink3.mk"