]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
fixed broken Makefile
[pkgsrc-ghc.git] / Makefile
index a6a77b8294882aa0ecb21257ae123456914d7bba..ddf834ea1d64e0250109d6a5bd4c015671d9017b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -10,25 +10,34 @@ COMMENT=            Compiler for the functional language Haskell
 LICENSE=               modified-bsd
 
 DISTFILES=             ${DISTNAME}-src.tar.bz2 \
-                               ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2 \
-                               ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
+                               ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2 \
+                               ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
 
 SITES.${DISTNAME}-src.tar.bz2                                          = http://www.haskell.org/ghc/dist/${VERSION}/
-SITES.${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2    = http://static.cielonegro.org/archive/
 SITES.${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2     = http://static.cielonegro.org/archive/
+SITES.${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2    = http://static.cielonegro.org/archive/
 
 PKG_DESTDIR_SUPPORT=   user-destdir
 
-# PLIST cannot be generated statically because of hashed package
-# config files. This requires USE_DESTDIR=yes.
-PLIST_TYPE = dynamic
-
 .include "../../mk/bsd.prefs.mk"
 
 # Unregisterised HC packages are architecture dependent. We have to
 # create more HC packages to support more architectures.
-#ONLY_FOR_PLATFORM= *-*-i386 *-*-powerpc
-ONLY_FOR_PLATFORM= *-*-i386
+ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386
+# Note: Darwin-*-powerpc is temporarily disabled for now. It shall
+# come back in the near future. Thanks for your patience.
+
+# We must provide the real pass to gcc to the ./configure script,
+# because GHC has a runtime dependency on it. Aren't there any better
+# way than this?
+.include "../../mk/compiler.mk"
+.if empty(CCPATH)
+WARNINGS+= "This package depends on pkgsrc's undocumented variable CCPATH but it disappeared somehow."
+WARNINGS+= "Using hard-coded /usr/bin/gcc as the C compiler..."
+CONFIGURE_ARGS+= --with-gcc=/usr/bin/gcc
+.else
+CONFIGURE_ARGS+= --with-gcc=${CCPATH}
+.endif
 
 USE_TOOLS+=    gmake bsdtar perl:run
 CONFIGURE_ENV+=                PerlCmd=${PERL5:Q}
@@ -36,7 +45,11 @@ CONFIGURE_ENV+=              PerlCmd=${PERL5:Q}
 # We don't want to extract all of the DISTFILEs.
 EXTRACT_ONLY=  ${DISTNAME}-src.tar.bz2
 
+PLATFORM= ${LOWER_ARCH}-unknown-${LOWER_OPSYS}
 CONFIGURE_ARGS += \
+       --build=${PLATFORM} \
+       --host=${PLATFORM} \
+       --target=${PLATFORM} \
        --prefix=${PREFIX} \
        --mandir=${PREFIX}/${PKGMANDIR} \
        --with-gmp-includes=${PREFIX}/include \
@@ -53,20 +66,20 @@ CONFIGURE_ARGS += \
 # "${BUILDLINK_DIR}/bin". Note that in-place ghc isn't usable before
 # running "ghc-pkg recache".
 
-.if ${MACHINE_ARCH} == "i386"
-.  if ${OPSYS} == "FreeBSD"
+.if ${MACHINE_ARCH} == "i386" && ${OPSYS} == "NetBSD"
+BOOTSTRAP_TARBALL  = ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
+BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
+
+.elif ${MACHINE_ARCH} == "i386" && ${OPSYS} == "FreeBSD"
 BOOTSTRAP_TARBALL = ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
-.  else
-BOOTSTRAP_TARBALL = ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
-.  endif
-#.elif ${MACHINE_ARCH} == "powerpc"
+BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
+
+#.elif ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
 #BOOTSTRAP_TARBALL = ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
-.endif
+#BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap.mk
 
-.if ${OPSYS} == "NetBSD" || ${OPSYS} == "DragonFly" || ${OPSYS} == "FreeBSD" || ${OPSYS} == "OpenBSD"
-BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
 .else
-BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap.mk
+PKG_FAIL_REASON+=      "internal error: unsupported platform"
 .endif
 
 pre-configure:
@@ -77,14 +90,14 @@ pre-configure:
                cd bootstrap/${DISTNAME} && \
                ${LN} -sf ${PWD_CMD} utils/ghc-pwd/ghc-pwd && \
                ${ECHO} "====> Configuring for bootstrap compiler" && \
-               ${ENV} ${CONFIGURE_ENV} ./configure --enable-hc-boot ${CONFIGURE_ARGS} && \
+               ${SETENV} ${CONFIGURE_ENV} ./configure --enable-hc-boot ${CONFIGURE_ARGS} && \
                ${ECHO} "====> Extracting bootstrap HC archive" && \
                (cd .. && bsdtar jxfm ${DISTDIR}/${BOOTSTRAP_TARBALL}) && \
                ${SH} mkfiles && \
                ${ECHO} "====> Building bootstrap compiler" && \
                ${SED} -e "s#\\[\\[PREFIX\\]\\]#${PREFIX}#g" ${BOOTSTRAP_BUILD_MK} > mk/build.mk && \
                for c in libraries/*/configure; do \
-                       (cd `${DIRNAME} $$c` && ${ENV} ${CONFIGURE_ENV} ${SH} configure ${CONFIGURE_ARGS}); \
+                       (cd `${DIRNAME} $$c` && ${SETENV} ${CONFIGURE_ENV} ${SH} configure ${CONFIGURE_ARGS}); \
                done && \
                for i in inplace/lib/package.conf.d/*.conf */*/package-data.mk */*/*/package-data.mk; do \
                        ${SED} -e "s#\\[\\[GHC_SOURCE_PATH\\]\\]#`${PWD_CMD}`#g" $$i > $$i.tmp; \
@@ -104,7 +117,7 @@ pre-configure:
 # link programs by executing ld(1) without passing it -L${PREFIX}/lib.
 do-configure:
        ${RUN} cd ${WRKSRC} && \
-               ${ENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
+               ${SETENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
        ${RUN} ${ECHO} "libraries/integer-gmp_CONFIGURE_OPTS += \
                --configure-option=--with-gmp-includes=${PREFIX}/include \
                --configure-option=--with-gmp-libraries=${PREFIX}/lib" > ${WRKSRC}/mk/build.mk