]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
fixed broken Makefile
[pkgsrc-ghc.git] / Makefile
index cee8f41950d10fdd38d3d4a97b0cf8ceb9038878..ddf834ea1d64e0250109d6a5bd4c015671d9017b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -24,7 +24,20 @@ PKG_DESTDIR_SUPPORT= user-destdir
 # Unregisterised HC packages are architecture dependent. We have to
 # create more HC packages to support more architectures.
 ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386
-# Note: Darwin-*-powerpc is temporarily disabled for now. It shall come back in the near future. Thanks for your patience.
+# Note: Darwin-*-powerpc is temporarily disabled for now. It shall
+# come back in the near future. Thanks for your patience.
+
+# We must provide the real pass to gcc to the ./configure script,
+# because GHC has a runtime dependency on it. Aren't there any better
+# way than this?
+.include "../../mk/compiler.mk"
+.if empty(CCPATH)
+WARNINGS+= "This package depends on pkgsrc's undocumented variable CCPATH but it disappeared somehow."
+WARNINGS+= "Using hard-coded /usr/bin/gcc as the C compiler..."
+CONFIGURE_ARGS+= --with-gcc=/usr/bin/gcc
+.else
+CONFIGURE_ARGS+= --with-gcc=${CCPATH}
+.endif
 
 USE_TOOLS+=    gmake bsdtar perl:run
 CONFIGURE_ENV+=                PerlCmd=${PERL5:Q}
@@ -32,7 +45,11 @@ CONFIGURE_ENV+=              PerlCmd=${PERL5:Q}
 # We don't want to extract all of the DISTFILEs.
 EXTRACT_ONLY=  ${DISTNAME}-src.tar.bz2
 
+PLATFORM= ${LOWER_ARCH}-unknown-${LOWER_OPSYS}
 CONFIGURE_ARGS += \
+       --build=${PLATFORM} \
+       --host=${PLATFORM} \
+       --target=${PLATFORM} \
        --prefix=${PREFIX} \
        --mandir=${PREFIX}/${PKGMANDIR} \
        --with-gmp-includes=${PREFIX}/include \
@@ -73,14 +90,14 @@ pre-configure:
                cd bootstrap/${DISTNAME} && \
                ${LN} -sf ${PWD_CMD} utils/ghc-pwd/ghc-pwd && \
                ${ECHO} "====> Configuring for bootstrap compiler" && \
-               ${ENV} ${CONFIGURE_ENV} ./configure --enable-hc-boot ${CONFIGURE_ARGS} && \
+               ${SETENV} ${CONFIGURE_ENV} ./configure --enable-hc-boot ${CONFIGURE_ARGS} && \
                ${ECHO} "====> Extracting bootstrap HC archive" && \
                (cd .. && bsdtar jxfm ${DISTDIR}/${BOOTSTRAP_TARBALL}) && \
                ${SH} mkfiles && \
                ${ECHO} "====> Building bootstrap compiler" && \
                ${SED} -e "s#\\[\\[PREFIX\\]\\]#${PREFIX}#g" ${BOOTSTRAP_BUILD_MK} > mk/build.mk && \
                for c in libraries/*/configure; do \
-                       (cd `${DIRNAME} $$c` && ${ENV} ${CONFIGURE_ENV} ${SH} configure ${CONFIGURE_ARGS}); \
+                       (cd `${DIRNAME} $$c` && ${SETENV} ${CONFIGURE_ENV} ${SH} configure ${CONFIGURE_ARGS}); \
                done && \
                for i in inplace/lib/package.conf.d/*.conf */*/package-data.mk */*/*/package-data.mk; do \
                        ${SED} -e "s#\\[\\[GHC_SOURCE_PATH\\]\\]#`${PWD_CMD}`#g" $$i > $$i.tmp; \
@@ -100,7 +117,7 @@ pre-configure:
 # link programs by executing ld(1) without passing it -L${PREFIX}/lib.
 do-configure:
        ${RUN} cd ${WRKSRC} && \
-               ${ENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
+               ${SETENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
        ${RUN} ${ECHO} "libraries/integer-gmp_CONFIGURE_OPTS += \
                --configure-option=--with-gmp-includes=${PREFIX}/include \
                --configure-option=--with-gmp-libraries=${PREFIX}/lib" > ${WRKSRC}/mk/build.mk