]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
Better comments
[pkgsrc-ghc.git] / Makefile
index cba47056fe6e7b402e7804ccaae04d98944fe3fd..eb70d159f1431f81dc60ebb2539bbfa1b3229908 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
 # $NetBSD: Makefile,v 1.42 2008/07/07 14:58:00 kristerw Exp $
 
 DISTNAME=              ghc-${VERSION}
-VERSION=               7.0.3
+VERSION=               7.4.1
 CATEGORIES=            lang
 MASTER_SITES=  http://www.haskell.org/ghc/dist/${VERSION}/
 MAINTAINER=            kristerw@NetBSD.org
@@ -10,33 +10,31 @@ COMMENT=            Compiler for the functional language Haskell
 LICENSE=               modified-bsd
 
 DISTFILES=             ${DISTNAME}-src.tar.bz2
-DISTFILES+=            ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
-#DISTFILES+=           ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
-DISTFILES+=            ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
+DISTFILES+=            ${DISTNAME}-boot-i386-unknown-freebsd8.0.tar.bz2
+#DISTFILES+=           ${DISTNAME}-boot-i386-unknown-netbsdelf6.99.1.tar.bz2
+DISTFILES+=            ${DISTNAME}-boot-powerpc-apple-darwin9.8.0.tar.bz2
 
-
-#SITES.${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2    = http://static.cielonegro.org/archive/
-SITES.${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2    = http://static.cielonegro.org/archive/
-SITES.${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2    = http://static.cielonegro.org/archive/
+.for i in ${DISTFILES:M*-boot-*}
+SITES.${i}=            http://static.cielonegro.org/archive/
+.endfor
 
 PKG_DESTDIR_SUPPORT=   user-destdir
 
-.include "../../mk/bsd.prefs.mk"
-
-# Unregisterised HC packages are architecture dependent. We have to
-# create more HC packages to support more architectures. Note that
-# these packages are built with integer-simple, not integer-gmp, to
-# reduce some complexity by not depending on the GMP. The resulting
-# registerised GHC uses integer-gmp so this won't be a problem.
+# Unregisterised HC packages are platform-dependent C sources. Yes,
+# they are C sources but are totally non-portable. We have to create
+# more HC packages to support more platforms. Note that these packages
+# are built with integer-simple, not integer-gmp, to reduce some
+# complexity by not depending on the GMP. The resulting registerised
+# GHC uses integer-gmp so this won't be a problem.
 #
 # If you want to build HC packages yourself, follow instructions in
 # the ./TODO file.
-#ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386 Darwin-*-powerpc
-ONLY_FOR_PLATFORM= FreeBSD-*-i386 Darwin-*-powerpc
+ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386 Darwin-*-powerpc
 
 # We must provide the real pass to gcc to the ./configure script,
 # because GHC has a runtime dependency on it. Aren't there any ways
 # better than this?
+.include "../../mk/bsd.prefs.mk"
 .include "../../mk/compiler.mk"
 .if empty(CCPATH)
 WARNINGS+= "This package depends on pkgsrc's undocumented variable \
@@ -47,7 +45,7 @@ CONFIGURE_ARGS+= --with-gcc=/usr/bin/gcc
 CONFIGURE_ARGS+= --with-gcc=${CCPATH}
 .endif
 
-USE_TOOLS+=    gmake bsdtar perl:run
+USE_TOOLS+=                    autoconf date gmake gtar perl perl:run
 CONFIGURE_ENV+=                PerlCmd=${PERL5:Q}
 
 # We don't want to extract all of the DISTFILEs.
@@ -70,20 +68,23 @@ CONFIGURE_ARGS += \
 #
 # To install it, we just copy ghc and ghc-pkg from
 # "work/bootstrap/ghc-${VERSION}/inplace/bin" to
-# "${BUILDLINK_DIR}/bin". Note that in-place ghc isn't usable before
-# running "ghc-pkg recache".
+# "${BUILDLINK_DIR}/bin". Note that in-place ghc isn't usable until we
+# run "ghc-pkg recache".
 
 .if ${MACHINE_ARCH} == "i386" && ${OPSYS} == "NetBSD"
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
-PLATFORM           = i386-unknown-netbsd
+BOOTSTRAP_CAPI_C   = ${PKGDIR}/files/capi-wrappers-netbsd-i386.c
+PLATFORM           = i386-unknown-netbsdelf6.99.1
 
 .elif ${MACHINE_ARCH} == "i386" && ${OPSYS} == "FreeBSD"
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
-PLATFORM           = i386-unknown-freebsd
+BOOTSTRAP_CAPI_C   = ${PKGDIR}/files/capi-wrappers-freebsd-i386.c
+PLATFORM           = i386-unknown-freebsd8.0
 
 .elif ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap.mk
-PLATFORM           = powerpc-apple-darwin
+BOOTSTRAP_CAPI_C   = ${PKGDIR}/files/capi-wrappers-darwin-powerpc.c
+PLATFORM           = powerpc-apple-darwin9.8.0
 # Existence of libelf makes LeadingUnderscore being "NO", which is
 # incorrect for this platform. See ghc-6.12.1/aclocal.m4
 # (FP_LEADING_UNDERSCORE)
@@ -94,72 +95,90 @@ PKG_FAIL_REASON+=   "internal error: unsupported platform"
 .endif
 
 BOOTSTRAP_TARBALL = ${DISTNAME}-boot-${PLATFORM}.tar.bz2
+BOOTSTRAP_MAIN_C  = ${PKGDIR}/files/bootstrap-main.c
 
 pre-configure: ${WRKDIR}/stamp-bootstrap-ghc
 
-${WRKDIR}/stamp-prepare-bootstrap:
+${WRKDIR}/stamp-autoreconf:
+       ${RUN} cd ${WRKSRC} && \
+               ${PHASE_MSG} "Regenerating configuration scripts for ${PKGNAME}" && \
+               ${PERL5} boot && \
+               ${TOUCH} ${.TARGET}
+
+${WRKDIR}/stamp-prepare-bootstrap: ${WRKDIR}/stamp-autoreconf
        ${RUN} cd ${WRKDIR} && \
-               ${ECHO} "====> Preparing bootstrap compiler" && \
+               ${PHASE_MSG} "Preparing bootstrapping compiler for ${PKGNAME}" && \
                ${RM} -rf bootstrap && \
-               ${MKDIR} -p bootstrap && \
-               ${CP} -r ${DISTNAME} bootstrap && \
-               cd bootstrap/${DISTNAME} && \
-               ${MKDIR} -p utils/ghc-pwd/dist-boot && \
-               ${LN} -sf ${PWD_CMD} utils/ghc-pwd/dist-boot/ghc-pwd && \
-               ${TOUCH} $@
+               ${MKDIR} bootstrap && \
+               ${GTAR} -cf - ${DISTNAME} | ${GTAR} -C bootstrap -xf - && \
+               ${CP} ${BOOTSTRAP_MAIN_C} bootstrap/${DISTNAME}/rts/bootstrap-main.c && \
+               ${CP} ${BOOTSTRAP_CAPI_C} bootstrap/${DISTNAME}/rts/capi-wrappers.c  && \
+               ${TOUCH} ${.TARGET}
 
 ${WRKDIR}/stamp-configure-hc-boot: ${WRKDIR}/stamp-prepare-bootstrap
        ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
-               ${ECHO} "====> Configuring for bootstrap compiler" && \
+               ${PHASE_MSG} "Configuring bootstrapping compiler for ${PKGNAME}" && \
                ${SETENV} ${CONFIGURE_ENV} ./configure --enable-hc-boot --with-ghc="" ${CONFIGURE_ARGS} && \
-               ${TOUCH} $@
+               ${TOUCH} ${.TARGET}
 
 ${WRKDIR}/stamp-extract-hc: ${WRKDIR}/stamp-configure-hc-boot
-       ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
-               ${ECHO} "====> Extracting bootstrap HC archive" && \
-               (cd .. && bsdtar jxfm ${DISTDIR}/${BOOTSTRAP_TARBALL}) && \
-               ${SH} mkfiles && \
-               ${TOUCH} $@
+       ${RUN} cd ${WRKDIR}/bootstrap && \
+               ${PHASE_MSG} "Extracting bootstrap HC archive for ${PKGNAME}" && \
+               if ${TEST} "`${DATE} '+%Y%m%d%H%M'`" -le 200001010000; then \
+                       ${FAIL_MSG} "Adjust your system clock: `${DATE}`"; \
+               fi && \
+               ${FIND} ${DISTNAME} -type d -o -type f | ${XARGS} ${TOUCH} -t 200001010000 && \
+               ${GTAR} -jxf ${DISTDIR}/${BOOTSTRAP_TARBALL} && \
+               (cd ${DISTNAME} && ${SH} mkfiles) && \
+               ${TOUCH} ${.TARGET}
 
 ${WRKDIR}/stamp-rewrite-hc-paths: ${WRKDIR}/stamp-extract-hc
        ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
-               ${ECHO} "====> Rewriting GHC source paths" && \
+               ${PHASE_MSG} "Rewriting source paths in bootstrapping compiler for ${PKGNAME}" && \
                ${SED} -e "s#\\[\\[PREFIX\\]\\]#${PREFIX}#g" ${BOOTSTRAP_BUILD_MK} > mk/build.mk && \
                for c in libraries/*/configure; do \
                        (cd `${DIRNAME} $$c` && ${SETENV} ${CONFIGURE_ENV} ${SH} configure ${CONFIGURE_ARGS}); \
                done && \
-               for i in inplace/lib/package.conf.d/*.conf */*/package-data.mk */*/*/package-data.mk; do \
+               for i in inplace/lib/package.conf.d/*.conf \
+                                */package.conf.inplace \
+                                */*/package-data.mk \
+                                */*/*/package-data.mk \
+                                */*/*/*/package-data.mk; do \
                        ${SED} -e "s#\\[\\[PREFIX\\]\\]#${PREFIX}#g" \
                                   -e "s#\\[\\[GHC_SOURCE_PATH\\]\\]#`${PWD_CMD}`#g" $$i > $$i.tmp; \
                        ${MV} -f $$i.tmp $$i; \
                done && \
-               ${TOUCH} -r inplace/lib/package.conf.d */*/package-data.mk */*/*/package-data.mk && \
-               ${TOUCH} $@
+               ${TOUCH} -r inplace/lib/package.conf.d \
+                                       inplace/lib/package.conf.d/*.conf \
+                                       */package.conf.inplace \
+                                       */*/package-data.mk \
+                                       */*/*/package-data.mk \
+                                       */*/*/*/package-data.mk \
+                                       compiler/stage?/build/Config.hs && \
+               ${TOUCH} ${.TARGET}
 
 ${WRKDIR}/stamp-bootstrap-ghc: ${WRKDIR}/stamp-rewrite-hc-paths
        ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
-               ${ECHO} "====> Building bootstrap compiler" && \
-               ${GMAKE} bootstrapping-files && \
-               ${GMAKE} all_ghc_stage2 && \
-               ${GMAKE} inplace/bin/ghc-pkg && \
-               ${GMAKE} inplace/lib/unlit && \
+               ${PHASE_MSG} "Creating bootstrapping files for ${PKGNAME}" && \
+               ${BUILD_MAKE_CMD} bootstrapping-files && \
+               ${PHASE_MSG} "Building bootstrapping compiler for ${PKGNAME}" && \
+               ${BUILD_MAKE_CMD} all_ghc_stage2 && \
+               ${PHASE_MSG} "Building bootstrapping toolkit for ${PKGNAME}" && \
+               ${BUILD_MAKE_CMD} inplace/bin/ghc-pkg && \
+               ${BUILD_MAKE_CMD} inplace/lib/unlit && \
                inplace/bin/ghc-pkg recache && \
                ${CP} -f inplace/bin/ghc-stage2 ${BUILDLINK_DIR}/bin/ghc && \
                ${CP} -f inplace/bin/ghc-pkg ${BUILDLINK_DIR}/bin/ghc-pkg && \
-               ${TOUCH} $@
+               ${TOUCH} ${.TARGET}
 
 do-configure:
-# Seemingly by mistake, ghc-7.0.3 has a prebuilt
-# utils/ghc-pwd/dist-boot/ghc-pwd for amd64 GNU/Linux.
-       ${RUN} cd ${WRKSRC} && \
-               rm -rf utils/ghc-pwd/dist-boot
        ${RUN} cd ${WRKSRC} && \
                ${SETENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
 # We need to tell the libraries/terminfo/configure that our ncurses is
 # in a non-standard path. Without that, the resulting GHC tries to
 # link programs by executing ld(1) without passing it -L${PREFIX}/lib.
        ${RUN} ${ECHO} "libraries/terminfo_CONFIGURE_OPTS += \
-               --configure-option=--with-curses-includes=${PREFIX}/include/ncurses \
+               --configure-option=--with-curses-includes=${PREFIX}/include \
                --configure-option=--with-curses-libraries=${PREFIX}/lib" >> ${WRKSRC}/mk/build.mk
 # The ghc compiler does normally split the generated asm files into small
 # parts before sending them to gcc, to enable the linker to eliminate
@@ -173,12 +192,6 @@ do-configure:
 # If we don't explicitly disable HsColour, PLIST gets changed
 # depending on whether we have installed it or not.
        ${RUN} ${ECHO} "HSCOLOUR_SRCS = NO" >> ${WRKSRC}/mk/build.mk
-# To avoid powerpc crash...
-# See http://hackage.haskell.org/trac/ghc/ticket/4034
-#.if ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
-#      ${RUN} ${ECHO} "GhcRtsHcOpts = -optc-O0 -optc-g" >> ${WRKSRC}/mk/build.mk
-#      ${RUN} ${ECHO} "GhcRtsCcOpts = -O0 -g" >> ${WRKSRC}/mk/build.mk
-#.endif
 
 # Substitutions for INSTALL and DEINSTALL.
 FILES_SUBST+=  DISTNAME=${DISTNAME}