]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
Merge branch 'ghc-7.4.1'
[pkgsrc-ghc.git] / Makefile
index 9164300fcf9267087b302e08d1afdc526f5eaa27..f16a711d4754d77687b523474fd73dec618cc199 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,99 +1,85 @@
 # $NetBSD: Makefile,v 1.42 2008/07/07 14:58:00 kristerw Exp $
 
-DISTNAME=              ghc-${VERSION}
-VERSION=               6.12.1
-CATEGORIES=            lang
+DISTNAME=      ghc-${VERSION}
+VERSION=       7.4.1
+CATEGORIES=    lang
 MASTER_SITES=  http://www.haskell.org/ghc/dist/${VERSION}/
-MAINTAINER=            kristerw@NetBSD.org
-HOMEPAGE=              http://www.haskell.org/ghc/
-COMMENT=               Compiler for the functional language Haskell
-LICENSE=               modified-bsd
+MAINTAINER=    kristerw@NetBSD.org
+HOMEPAGE=      http://www.haskell.org/ghc/
+COMMENT=       Compiler for the functional language Haskell
+LICENSE=       modified-bsd
 
-DISTFILES=             ${DISTNAME}-src.tar.bz2 \
-                               ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
+DISTFILES=     ${DISTNAME}-src.tar.bz2
+DISTFILES+=    ${DISTNAME}-boot-i386-unknown-freebsd8.0.tar.bz2
+DISTFILES+=    ${DISTNAME}-boot-i386-unknown-netbsdelf6.99.1.tar.bz2
+DISTFILES+=    ${DISTNAME}-boot-powerpc-apple-darwin9.8.0.tar.bz2
+DISTFILES+=    ${DISTNAME}-boot-x86_64-unknown-linux-gnu.tar.bz2
 
-SITES.${DISTNAME}-src.tar.bz2                                          = http://www.haskell.org/ghc/dist/${VERSION}/
-SITES.${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2    = http://static.cielonegro.org/archive/
+.for i in ${DISTFILES:M*-boot-*}
+SITES.${i}=    http://static.cielonegro.org/archive/
+.endfor
 
 PKG_DESTDIR_SUPPORT=   user-destdir
 
+# Unregisterised HC packages are platform-dependent C sources. Yes,
+# they are C sources but are totally non-portable. We have to create
+# more HC packages to support more platforms. Note that those packages
+# are built with integer-simple, not integer-gmp, to reduce some
+# complexity by not depending on the GMP. The resulting registerised
+# GHC uses integer-gmp so this won't be a problem.
+#
+# If you want to build HC packages yourself, follow instructions in
+# the ./TODO file.
+ONLY_FOR_PLATFORM= \
+       Darwin-*-powerpc \
+       FreeBSD-*-i386 \
+       Linux-*-x86_64 \
+       NetBSD-*-i386
+
+# We must provide the real path to gcc to the ./configure script,
+# because GHC has a runtime dependency on it. Aren't there any ways
+# better than this?
 .include "../../mk/bsd.prefs.mk"
+.include "../../mk/compiler.mk"
+.if empty(CCPATH)
+WARNINGS+= "This package depends on pkgsrc's undocumented variable \
+CCPATH but it disappeared somehow."
+WARNINGS+= "Using hard-coded /usr/bin/gcc as the C compiler..."
+CONFIGURE_ARGS+= --with-gcc=/usr/bin/gcc
+.else
+CONFIGURE_ARGS+= --with-gcc=${CCPATH}
+.endif
 
-# Unregisterised HC packages are architecture dependent. We have to
-# create more HC packages to support more architectures.
-#ONLY_FOR_PLATFORM= *-*-i386 *-*-powerpc
-ONLY_FOR_PLATFORM= *-*-i386
-
-USE_TOOLS+=    gmake bsdtar perl
+USE_TOOLS+=    autoconf date gmake gtar perl perl:run
+CONFIGURE_ENV+=        PerlCmd=${PERL5:Q}
 
 # We don't want to extract all of the DISTFILEs.
 EXTRACT_ONLY=  ${DISTNAME}-src.tar.bz2
 
-# We need to tell the ./configure that libgmp is in a non-standard path. Without
-# that, the resulting GHC tries to link programs by executing ld(1) without
-# passing it -L${PREFIX}/lib.
 CONFIGURE_ARGS += \
+       --build=${PLATFORM} \
+       --host=${PLATFORM} \
+       --target=${PLATFORM} \
        --prefix=${PREFIX} \
-       --mandir=${PKGMANDIR} \
+       --mandir=${PREFIX}/${PKGMANDIR} \
        --with-gmp-includes=${PREFIX}/include \
        --with-gmp-libraries=${PREFIX}/lib \
        --with-iconv-includes=${PREFIX}/include \
        --with-iconv-libraries=${PREFIX}/lib
 
-# Build an unregisterised bootstrap compiler and install it directly
-# into the .buildlink directory. But we can't use "make install"
-# because we don't build it in a standard way (./configure && make).
-#
-# To install it, we just copy ghc and ghc-pkg from
-# "work/bootstrap/ghc-${VERSION}/inplace/bin" to
-# "${BUILDLINK_DIR}/bin". Note that in-place ghc isn't usable before
-# running "ghc-pkg recache".
-
-.if ${MACHINE_ARCH} == "i386"
-BOOTSTRAP_TARBALL = ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
-#.elif ${MACHINE_ARCH} == "powerpc"
-#BOOTSTRAP_TARBALL = ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
-.endif
-
-.if ${OPSYS} == "NetBSD" || ${OPSYS} == "DragonFly" || ${OPSYS} == "FreeBSD" || ${OPSYS} == "OpenBSD"
-BUILD_MK = ${PKGDIR}/files/bsd-build.mk
-.else
-BUILD_MK = ${PKGDIR}/files/fallback-build.mk
-.endif
-
-pre-configure:
-       ${RUN} cd ${WRKDIR} && \
-               ${ECHO} "====> Preparing bootstrap compiler" && \
-               ${MKDIR} bootstrap && \
-               ${CP} -r ${DISTNAME} bootstrap && \
-               cd bootstrap/${DISTNAME} && \
-               ${LN} -sf ${PWD_CMD} utils/ghc-pwd/ghc-pwd && \
-               ${ECHO} "====> Configuring for bootstrap compiler" && \
-               ${ENV} ${CONFIGURE_ENV} ./configure --enable-hc-boot ${CONFIGURE_ARGS} && \
-               ${ECHO} "====> Extracting bootstrap HC archive" && \
-               (cd .. && bsdtar jxfm ${DISTDIR}/${BOOTSTRAP_TARBALL}) && \
-               ${SH} mkfiles && \
-               ${ECHO} "====> Building bootstrap compiler" && \
-               ${SED} -e 's#\\[\\[PREFIX\\]\\]#${PREFIX}#g' ${BUILD_MK} > mk/build.mk && \
-               for c in libraries/*/configure; do \
-                       (cd `${DIRNAME} $$c` && ${ENV} ${CONFIGURE_ENV} ${SH} configure ${CONFIGURE_ARGS}); \
-               done && \
-               ${SED} -i -e "s#\\[\\[GHC_SOURCE_PATH\\]\\]#`${PWD_CMD}`#g" \
-                       inplace/lib/package.conf.d/*.conf */*/package-data.mk */*/*/package-data.mk && \
-               ${TOUCH} -r inplace/lib/package.conf.d */*/package-data.mk */*/*/package-data.mk && \
-               ${GMAKE} bootstrapping-files && \
-               ${GMAKE} all_ghc_stage2 && \
-               ${GMAKE} inplace/bin/ghc-pkg && \
-               ${GMAKE} inplace/lib/unlit && \
-               inplace/bin/ghc-pkg recache && \
-               ${CP} inplace/bin/ghc-stage2 ${BUILDLINK_DIR}/bin/ghc && \
-               ${CP} inplace/bin/ghc-pkg ${BUILDLINK_DIR}/bin/ghc-pkg
+# Define ${PLATFORM} and the target "pre-configure".
+.include "../../wip/ghc/stage0.mk"
 
 do-configure:
        ${RUN} cd ${WRKSRC} && \
-               ${ENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
-
-# The ghc compiler does normally split the generated C files into small
+               ${SETENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
+# We need to tell the libraries/terminfo/configure that our ncurses is
+# in a non-standard path. Without that, the resulting GHC tries to
+# link programs by executing ld(1) without passing it -L${PREFIX}/lib.
+       ${RUN} ${ECHO} "libraries/terminfo_CONFIGURE_OPTS += \
+               --configure-option=--with-curses-includes=${PREFIX}/include \
+               --configure-option=--with-curses-libraries=${PREFIX}/lib" >> ${WRKSRC}/mk/build.mk
+# The ghc compiler does normally split the generated asm files into small
 # parts before sending them to gcc, to enable the linker to eliminate
 # unused parts.  This does however not play nice with the pkgsrc
 # framework, and the result is that the build takes more than 5 times
@@ -101,16 +87,30 @@ do-configure:
 #    http://mail-index.netbsd.org/tech-pkg/2006/07/30/0005.html
 # for a description of the problem.
 # Disable file splitting until pkgsrc gets improved.
-pre-build:
-       ${ECHO} "SplitObjs=NO" > ${WRKSRC}/mk/build.mk
+       ${RUN} ${ECHO} "SplitObjs = NO" >> ${WRKSRC}/mk/build.mk
+# If we don't explicitly disable HsColour, PLIST gets changed
+# depending on whether we have installed it or not.
+       ${RUN} ${ECHO} "HSCOLOUR_SRCS = NO" >> ${WRKSRC}/mk/build.mk
 
-# Some unused scripts don't pass the portability test.
+# Substitutions for INSTALL and DEINSTALL.
+FILES_SUBST+=  DISTNAME=${DISTNAME}
+
+# There is an unused script which don't pass the portability test.
 CHECK_PORTABILITY_SKIP+=       distrib/prep-bin-dist-mingw
 
+# GHC currently *requires* ${PREFIX}/lib to be in
+# "/etc/ld-elf.so.conf". See
+# http://hackage.haskell.org/trac/ghc/ticket/2933
+CHECK_SHLIBS_SUPPORTED=        no
+
+# I guess pdcurses works well but not tested.
+USE_NCURSES=   yes
+.include "../../devel/ncurses/buildlink3.mk"
+
+BUILD_DEPENDS+=        docbook-xsl-[0-9]*:../../textproc/docbook-xsl
 BUILDLINK_DEPMETHOD.libxslt = build
 .include "../../converters/libiconv/buildlink3.mk"
 .include "../../devel/gmp/buildlink3.mk"
 .include "../../textproc/libxslt/buildlink3.mk"
-.include "../../mk/termcap.buildlink3.mk"
 .include "../../mk/pthread.buildlink3.mk"
 .include "../../mk/bsd.pkg.mk"