]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
Merge branch 'ghc-7.4.1'
[pkgsrc-ghc.git] / Makefile
index abe6b8572c18b14e2375b44a4b62a0b3a2413e8d..f16a711d4754d77687b523474fd73dec618cc199 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,41 +1,48 @@
 # $NetBSD: Makefile,v 1.42 2008/07/07 14:58:00 kristerw Exp $
 
-DISTNAME=              ghc-${VERSION}
-VERSION=               6.12.2
-CATEGORIES=            lang
+DISTNAME=      ghc-${VERSION}
+VERSION=       7.4.1
+CATEGORIES=    lang
 MASTER_SITES=  http://www.haskell.org/ghc/dist/${VERSION}/
-MAINTAINER=            kristerw@NetBSD.org
-HOMEPAGE=              http://www.haskell.org/ghc/
-COMMENT=               Compiler for the functional language Haskell
-LICENSE=               modified-bsd
+MAINTAINER=    kristerw@NetBSD.org
+HOMEPAGE=      http://www.haskell.org/ghc/
+COMMENT=       Compiler for the functional language Haskell
+LICENSE=       modified-bsd
 
-DISTFILES=             ${DISTNAME}-src.tar.bz2 \
-                               ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2 \
-                               ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
-#                              ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
+DISTFILES=     ${DISTNAME}-src.tar.bz2
+DISTFILES+=    ${DISTNAME}-boot-i386-unknown-freebsd8.0.tar.bz2
+DISTFILES+=    ${DISTNAME}-boot-i386-unknown-netbsdelf6.99.1.tar.bz2
+DISTFILES+=    ${DISTNAME}-boot-powerpc-apple-darwin9.8.0.tar.bz2
+DISTFILES+=    ${DISTNAME}-boot-x86_64-unknown-linux-gnu.tar.bz2
 
-SITES.${DISTNAME}-src.tar.bz2                                          = http://www.haskell.org/ghc/dist/${VERSION}/
-SITES.${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2     = http://static.cielonegro.org/archive/
-SITES.${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2    = http://static.cielonegro.org/archive/
-SITES.${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2    = http://static.cielonegro.org/archive/
+.for i in ${DISTFILES:M*-boot-*}
+SITES.${i}=    http://static.cielonegro.org/archive/
+.endfor
 
 PKG_DESTDIR_SUPPORT=   user-destdir
 
+# Unregisterised HC packages are platform-dependent C sources. Yes,
+# they are C sources but are totally non-portable. We have to create
+# more HC packages to support more platforms. Note that those packages
+# are built with integer-simple, not integer-gmp, to reduce some
+# complexity by not depending on the GMP. The resulting registerised
+# GHC uses integer-gmp so this won't be a problem.
+#
+# If you want to build HC packages yourself, follow instructions in
+# the ./TODO file.
+ONLY_FOR_PLATFORM= \
+       Darwin-*-powerpc \
+       FreeBSD-*-i386 \
+       Linux-*-x86_64 \
+       NetBSD-*-i386
+
+# We must provide the real path to gcc to the ./configure script,
+# because GHC has a runtime dependency on it. Aren't there any ways
+# better than this?
 .include "../../mk/bsd.prefs.mk"
-
-# Unregisterised HC packages are architecture dependent. We have to
-# create more HC packages to support more architectures. Note that
-# these packages are built with integer-simple, not integer-gmp, to
-# reduce some complexity by not depending on the GMP. The resulting
-# registerised GHC uses integer-gmp so this won't be a problem.
-ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386 Darwin-*-powerpc
-
-# We must provide the real pass to gcc to the ./configure script,
-# because GHC has a runtime dependency on it. Aren't there any better
-# way than this?
 .include "../../mk/compiler.mk"
 .if empty(CCPATH)
-WARNINGS+= "This package depends on pkgsrc's undocumented variable\
+WARNINGS+= "This package depends on pkgsrc's undocumented variable \
 CCPATH but it disappeared somehow."
 WARNINGS+= "Using hard-coded /usr/bin/gcc as the C compiler..."
 CONFIGURE_ARGS+= --with-gcc=/usr/bin/gcc
@@ -43,8 +50,8 @@ CONFIGURE_ARGS+= --with-gcc=/usr/bin/gcc
 CONFIGURE_ARGS+= --with-gcc=${CCPATH}
 .endif
 
-USE_TOOLS+=    gmake bsdtar perl:run
-CONFIGURE_ENV+=                PerlCmd=${PERL5:Q}
+USE_TOOLS+=    autoconf date gmake gtar perl perl:run
+CONFIGURE_ENV+=        PerlCmd=${PERL5:Q}
 
 # We don't want to extract all of the DISTFILEs.
 EXTRACT_ONLY=  ${DISTNAME}-src.tar.bz2
@@ -60,81 +67,19 @@ CONFIGURE_ARGS += \
        --with-iconv-includes=${PREFIX}/include \
        --with-iconv-libraries=${PREFIX}/lib
 
-# Build an unregisterised bootstrap compiler and install it directly
-# into the .buildlink directory. But we can't use "make install"
-# because we don't build it in a standard way (./configure && make).
-#
-# To install it, we just copy ghc and ghc-pkg from
-# "work/bootstrap/ghc-${VERSION}/inplace/bin" to
-# "${BUILDLINK_DIR}/bin". Note that in-place ghc isn't usable before
-# running "ghc-pkg recache".
-
-.if ${MACHINE_ARCH} == "i386" && ${OPSYS} == "NetBSD"
-BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
-PLATFORM           = i386-unknown-netbsd
-
-.elif ${MACHINE_ARCH} == "i386" && ${OPSYS} == "FreeBSD"
-BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
-PLATFORM           = i386-unknown-freebsd
-
-.elif ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
-BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap.mk
-PLATFORM           = powerpc-apple-darwin
-
-# Existence of libelf makes LeadingUnderscore being "NO", which is
-# incorrect. See ghc-6.12.1/aclocal.m4 (FP_LEADING_UNDERSCORE)
-CONFLICTS=     libelf-[0-9]*
-
-.else
-PKG_FAIL_REASON+=      "internal error: unsupported platform"
-.endif
-
-BOOTSTRAP_TARBALL = ${DISTNAME}-boot-${PLATFORM}.tar.bz2
-
-pre-configure:
-       ${RUN} cd ${WRKDIR} && \
-               ${ECHO} "====> Preparing bootstrap compiler" && \
-               ${MKDIR} bootstrap && \
-               ${CP} -r ${DISTNAME} bootstrap && \
-               cd bootstrap/${DISTNAME} && \
-               ${LN} -sf ${PWD_CMD} utils/ghc-pwd/ghc-pwd && \
-               ${ECHO} "====> Configuring for bootstrap compiler" && \
-               ${SETENV} ${CONFIGURE_ENV} ./configure --enable-hc-boot ${CONFIGURE_ARGS} && \
-               ${ECHO} "====> Extracting bootstrap HC archive" && \
-               (cd .. && bsdtar jxfm ${DISTDIR}/${BOOTSTRAP_TARBALL}) && \
-               ${SH} mkfiles && \
-               ${ECHO} "====> Building bootstrap compiler" && \
-               ${SED} -e "s#\\[\\[PREFIX\\]\\]#${PREFIX}#g" ${BOOTSTRAP_BUILD_MK} > mk/build.mk && \
-               for c in libraries/*/configure; do \
-                       (cd `${DIRNAME} $$c` && ${SETENV} ${CONFIGURE_ENV} ${SH} configure ${CONFIGURE_ARGS}); \
-               done && \
-               for i in inplace/lib/package.conf.d/*.conf */*/package-data.mk */*/*/package-data.mk; do \
-                       ${SED} -e "s#\\[\\[GHC_SOURCE_PATH\\]\\]#`${PWD_CMD}`#g" $$i > $$i.tmp; \
-                       ${MV} -f $$i.tmp $$i; \
-               done && \
-               ${TOUCH} -r inplace/lib/package.conf.d */*/package-data.mk */*/*/package-data.mk && \
-               ${GMAKE} bootstrapping-files && \
-               ${GMAKE} all_ghc_stage2 && \
-               ${GMAKE} inplace/bin/ghc-pkg && \
-               ${GMAKE} inplace/lib/unlit && \
-               inplace/bin/ghc-pkg recache && \
-               ${CP} inplace/bin/ghc-stage2 ${BUILDLINK_DIR}/bin/ghc && \
-               ${CP} inplace/bin/ghc-pkg ${BUILDLINK_DIR}/bin/ghc-pkg
+# Define ${PLATFORM} and the target "pre-configure".
+.include "../../wip/ghc/stage0.mk"
 
 do-configure:
        ${RUN} cd ${WRKSRC} && \
                ${SETENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
-# We need to tell the libraries/integer-gmp/configure that libgmp is
+# We need to tell the libraries/terminfo/configure that our ncurses is
 # in a non-standard path. Without that, the resulting GHC tries to
 # link programs by executing ld(1) without passing it -L${PREFIX}/lib.
-       ${RUN} ${ECHO} "libraries/integer-gmp_CONFIGURE_OPTS += \
-               --configure-option=--with-gmp-includes=${PREFIX}/include \
-               --configure-option=--with-gmp-libraries=${PREFIX}/lib" > ${WRKSRC}/mk/build.mk
-# The ncurses is also in a non-standard path.
        ${RUN} ${ECHO} "libraries/terminfo_CONFIGURE_OPTS += \
                --configure-option=--with-curses-includes=${PREFIX}/include \
                --configure-option=--with-curses-libraries=${PREFIX}/lib" >> ${WRKSRC}/mk/build.mk
-# The ghc compiler does normally split the generated C files into small
+# The ghc compiler does normally split the generated asm files into small
 # parts before sending them to gcc, to enable the linker to eliminate
 # unused parts.  This does however not play nice with the pkgsrc
 # framework, and the result is that the build takes more than 5 times
@@ -146,44 +91,26 @@ do-configure:
 # If we don't explicitly disable HsColour, PLIST gets changed
 # depending on whether we have installed it or not.
        ${RUN} ${ECHO} "HSCOLOUR_SRCS = NO" >> ${WRKSRC}/mk/build.mk
-# To avoid powerpc crash...
-# See http://hackage.haskell.org/trac/ghc/ticket/4034
-.if ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
-       ${RUN} ${ECHO} "GhcRtsHcOpts = -optc-O0 -optc-g" >> ${WRKSRC}/mk/build.mk
-       ${RUN} ${ECHO} "GhcRtsCcOpts = -O0 -g" >> ${WRKSRC}/mk/build.mk
-.endif
 
-pre-build:
-# We have to sacrifice the GHCi library for GHC itself to work around
-# for powerpc ld bug.  See
-# http://hackage.haskell.org/trac/ghc/ticket/3260
-.if ${MACHINE_ARCH} == "powerpc"
-       ${RUN} ${MKDIR} ${WRKSRC}/compiler/stage1/build
-       ${RUN} ${TOUCH} -t `expr \`date '+%Y'\` + 1`12310000 \
-                                       ${WRKSRC}/compiler/stage1/build/HS${DISTNAME}.o
-       ${RUN} ${MKDIR} ${WRKSRC}/compiler/stage2/build
-       ${RUN} ${TOUCH} -t `expr \`date '+%Y'\` + 1`12310000 \
-                                       ${WRKSRC}/compiler/stage2/build/HS${DISTNAME}.o
-.endif
-
-.if ${MACHINE_ARCH} == "powerpc"
-WARNINGS+= "You won't be able to use GHCi library for GHC itself\
-because of powerpc ld bug."
-.endif
+# Substitutions for INSTALL and DEINSTALL.
+FILES_SUBST+=  DISTNAME=${DISTNAME}
 
-# Some unused scripts don't pass the portability test.
+# There is an unused script which don't pass the portability test.
 CHECK_PORTABILITY_SKIP+=       distrib/prep-bin-dist-mingw
 
 # GHC currently *requires* ${PREFIX}/lib to be in
 # "/etc/ld-elf.so.conf". See
 # http://hackage.haskell.org/trac/ghc/ticket/2933
-CHECK_SHLIBS_SUPPORTED=        no
+CHECK_SHLIBS_SUPPORTED=        no
+
+# I guess pdcurses works well but not tested.
+USE_NCURSES=   yes
+.include "../../devel/ncurses/buildlink3.mk"
 
 BUILD_DEPENDS+=        docbook-xsl-[0-9]*:../../textproc/docbook-xsl
 BUILDLINK_DEPMETHOD.libxslt = build
 .include "../../converters/libiconv/buildlink3.mk"
 .include "../../devel/gmp/buildlink3.mk"
-.include "../../devel/ncurses/buildlink3.mk" # I guess pdcurses works well but not tested.
 .include "../../textproc/libxslt/buildlink3.mk"
 .include "../../mk/pthread.buildlink3.mk"
 .include "../../mk/bsd.pkg.mk"