]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
-perm -o+x
[pkgsrc-ghc.git] / Makefile
index 1a8276cd95095c3cbdc6ad069e65be038f082ccf..f178a5c164156cef875629079ed2e102d847f1ca 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -11,19 +11,17 @@ COMMENT=            Compiler for the functional language Haskell
 DISTFILES=             ${DISTNAME}-src.tar.bz2 \
                                ghc-6.6.1-src.tar.bz2 \
                                ghc-6.6.1-i386-unknown-freebsd-hc.tar.gz \
-                               ghc-6.6.1-x86_64-unknown-linux-hc.tar.gz \
                                ghc-6.6.1-powerpc-apple-darwin-hc.tar.gz
 
 SITES.ghc-6.6.1-src.tar.bz2                                            = http://www.haskell.org/ghc/dist/6.6.1/
 SITES.ghc-6.6.1-powerpc-apple-darwin-hc.tar.gz = http://static.cielonegro.org/archive/
-SITES.ghc-6.6.1-x86_64-unknown-linux-hc.tar.gz = http://static.cielonegro.org/archive/
 SITES.ghc-6.6.1-i386-unknown-freebsd-hc.tar.gz = http://static.cielonegro.org/archive/
 
 .include "../../mk/bsd.prefs.mk"
 
 # Unregisterised HC packages are architecture dependent. We have to
 # create more HC packages to support more architectures.
-ONLY_FOR_PLATFORM= *-*-i386 *-*-x86_64 *-*-powerpc
+ONLY_FOR_PLATFORM= *-*-i386 *-*-powerpc
 
 GNU_CONFIGURE=         yes
 CONFIGURE_ENV+=                PerlCmd=${PERL5:Q}
@@ -35,8 +33,6 @@ EXTRACT_ONLY= ${DISTNAME}-src.tar.bz2 \
 
 .if ${MACHINE_ARCH} == "i386"
 EXTRACT_ONLY += ghc-6.6.1-i386-unknown-freebsd-hc.tar.gz
-.elif ${MACHINE_ARCH} == "x86_64"
-EXTRACT_ONLY += ghc-6.6.1-x86_64-unknown-linux-hc.tar.gz
 .elif ${MACHINE_ARCH} == "powerpc"
 EXTRACT_ONLY += ghc-6.6.1-powerpc-apple-darwin-hc.tar.gz
 .endif