]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
-perm -o+x
[pkgsrc-ghc.git] / Makefile
index 85e4505e2371b4188426305da6e14eaa4cb95ab1..f178a5c164156cef875629079ed2e102d847f1ca 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -9,13 +9,13 @@ HOMEPAGE=             http://www.haskell.org/ghc/
 COMMENT=               Compiler for the functional language Haskell
 
 DISTFILES=             ${DISTNAME}-src.tar.bz2 \
-                               ghc-6.4.2-src.tar.bz2 \
-                               ghc-6.4.2-i386-unknown-netbsd-hc.tar.gz \
-                               ghc-6.4.2-powerpc-apple-darwin-hc.tar.gz
+                               ghc-6.6.1-src.tar.bz2 \
+                               ghc-6.6.1-i386-unknown-freebsd-hc.tar.gz \
+                               ghc-6.6.1-powerpc-apple-darwin-hc.tar.gz
 
-SITES.ghc-6.4.2-src.tar.bz2                                            = http://www.haskell.org/ghc/dist/6.4.2/
-SITES.ghc-6.4.2-i386-unknown-netbsd-hc.tar.gz  = ${MASTER_SITE_LOCAL}
-SITES.ghc-6.4.2-powerpc-apple-darwin-hc.tar.gz = http://static.cielonegro.org/archive/
+SITES.ghc-6.6.1-src.tar.bz2                                            = http://www.haskell.org/ghc/dist/6.6.1/
+SITES.ghc-6.6.1-powerpc-apple-darwin-hc.tar.gz = http://static.cielonegro.org/archive/
+SITES.ghc-6.6.1-i386-unknown-freebsd-hc.tar.gz = http://static.cielonegro.org/archive/
 
 .include "../../mk/bsd.prefs.mk"
 
@@ -29,12 +29,12 @@ USE_TOOLS+=                 gmake perl:run find:run cp:run
 
 # We don't want to extract all of the DISTFILEs.
 EXTRACT_ONLY=  ${DISTNAME}-src.tar.bz2 \
-                               ghc-6.4.2-src.tar.bz2
+                               ghc-6.6.1-src.tar.bz2
 
 .if ${MACHINE_ARCH} == "i386"
-EXTRACT_ONLY += ghc-6.4.2-i386-unknown-netbsd-hc.tar.gz
+EXTRACT_ONLY += ghc-6.6.1-i386-unknown-freebsd-hc.tar.gz
 .elif ${MACHINE_ARCH} == "powerpc"
-EXTRACT_ONLY += ghc-6.4.2-powerpc-apple-darwin-hc.tar.gz
+EXTRACT_ONLY += ghc-6.6.1-powerpc-apple-darwin-hc.tar.gz
 .endif
 
 # Build an unregisterised bootstrap compiler and install it directly
@@ -46,9 +46,10 @@ EXTRACT_ONLY += ghc-6.4.2-powerpc-apple-darwin-hc.tar.gz
 # files into ${BUILDLINK_DIR}/bin with dropping the "-inplace" at
 # their tails.
 pre-configure:
-       cd ${WRKDIR}/ghc-6.4.2 && \
-               ${ENV} ${CONFIGURE_ENV} ./distrib/hc-build -C --enable-hc-boot-unregisterised && \
-               ${FIND} . -type f -and -perm +o+x -and -name '*-inplace' | \
+       cd ${WRKDIR}/ghc-6.6.1 && \
+               ${CHMOD} +x ./distrib/hc-build && \
+               ${ENV} ${CONFIGURE_ENV} ./distrib/hc-build -C --disable-readline --enable-hc-boot-unregisterised && \
+               ${FIND} . -type f -and -perm -o+x -and -name '*-inplace' | \
                        while read i; do \
                                ${CP} $$i ${BUILDLINK_DIR}/bin/`basename $$i | sed -e 's/-inplace//'`; \
                        done