]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
Fix incorrect MASTER_SITES
[pkgsrc-ghc.git] / Makefile
index 81c93349992883e5c14e4fa349ee5e4a5d8e9284..f46f665c94c43baa2488e9263498616d4033726e 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -3,14 +3,14 @@
 DISTNAME=              ghc-${VERSION}
 VERSION=               7.0.1
 CATEGORIES=            lang
-MASTER_SITES=  http://new-www.haskell.org/ghc/dist/${VERSION}/
+MASTER_SITES=  http://www.haskell.org/ghc/dist/${VERSION}/
 MAINTAINER=            kristerw@NetBSD.org
 HOMEPAGE=              http://www.haskell.org/ghc/
 COMMENT=               Compiler for the functional language Haskell
 LICENSE=               modified-bsd
 
 DISTFILES=             ${DISTNAME}-src.tar.bz2
-#DISTFILES+=           ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
+DISTFILES+=            ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
 DISTFILES+=            ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
 DISTFILES+=            ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
 
@@ -31,8 +31,7 @@ PKG_DESTDIR_SUPPORT=  user-destdir
 #
 # If you want to build HC packages yourself, follow instructions in
 # the ./TODO file.
-#ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386 Darwin-*-powerpc
-ONLY_FOR_PLATFORM= NetBSD-*-i386 Darwin-*-powerpc
+ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386 Darwin-*-powerpc
 
 # We must provide the real pass to gcc to the ./configure script,
 # because GHC has a runtime dependency on it. Aren't there any ways
@@ -150,13 +149,9 @@ ${WRKDIR}/stamp-bootstrap-ghc: ${WRKDIR}/stamp-rewrite-hc-paths
 do-configure:
        ${RUN} cd ${WRKSRC} && \
                ${SETENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
-# We need to tell the libraries/integer-gmp/configure that libgmp is
+# We need to tell the libraries/terminfo/configure that our ncurses is
 # in a non-standard path. Without that, the resulting GHC tries to
 # link programs by executing ld(1) without passing it -L${PREFIX}/lib.
-       ${RUN} ${ECHO} "libraries/integer-gmp_CONFIGURE_OPTS += \
-               --configure-option=--with-gmp-includes=${PREFIX}/include \
-               --configure-option=--with-gmp-libraries=${PREFIX}/lib" > ${WRKSRC}/mk/build.mk
-# The ncurses is also in a non-standard path.
        ${RUN} ${ECHO} "libraries/terminfo_CONFIGURE_OPTS += \
                --configure-option=--with-curses-includes=${PREFIX}/include \
                --configure-option=--with-curses-libraries=${PREFIX}/lib" >> ${WRKSRC}/mk/build.mk
@@ -179,6 +174,9 @@ do-configure:
 #      ${RUN} ${ECHO} "GhcRtsCcOpts = -O0 -g" >> ${WRKSRC}/mk/build.mk
 #.endif
 
+# Substitutions for INSTALL and DEINSTALL.
+FILES_SUBST+=  DISTNAME=${DISTNAME}
+
 # Some unused scripts don't pass the portability test.
 CHECK_PORTABILITY_SKIP+=       distrib/prep-bin-dist-mingw