]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
GHC 7.0.3 for NetBSD-i386
[pkgsrc-ghc.git] / Makefile
index 794adbf6bde0f2f90d009d75302a21c7ff4cab44..f80ff2423ccd9faca50546570285a6fd97b05caf 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,9 @@
 # $NetBSD: Makefile,v 1.42 2008/07/07 14:58:00 kristerw Exp $
 
 DISTNAME=              ghc-${VERSION}
-VERSION=               6.12.3
+VERSION=               7.0.3
 CATEGORIES=            lang
-MASTER_SITES=  http://darcs.haskell.org/download/dist/${VERSION}/
+MASTER_SITES=  http://www.haskell.org/ghc/dist/${VERSION}/
 MAINTAINER=            kristerw@NetBSD.org
 HOMEPAGE=              http://www.haskell.org/ghc/
 COMMENT=               Compiler for the functional language Haskell
@@ -38,7 +38,7 @@ ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386 Darwin-*-powerpc
 # better than this?
 .include "../../mk/compiler.mk"
 .if empty(CCPATH)
-WARNINGS+= "This package depends on pkgsrc's undocumented variable\
+WARNINGS+= "This package depends on pkgsrc's undocumented variable \
 CCPATH but it disappeared somehow."
 WARNINGS+= "Using hard-coded /usr/bin/gcc as the C compiler..."
 CONFIGURE_ARGS+= --with-gcc=/usr/bin/gcc
@@ -83,11 +83,9 @@ PLATFORM           = i386-unknown-freebsd
 .elif ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap.mk
 PLATFORM           = powerpc-apple-darwin
-WARNINGS+= "You won't be able to use GHCi library for GHC itself\
-because of Mach-O limitation."
-
 # Existence of libelf makes LeadingUnderscore being "NO", which is
-# incorrect. See ghc-6.12.1/aclocal.m4 (FP_LEADING_UNDERSCORE)
+# incorrect for this platform. See ghc-6.12.1/aclocal.m4
+# (FP_LEADING_UNDERSCORE)
 CONFLICTS=     libelf-[0-9]*
 
 .else
@@ -96,50 +94,73 @@ PKG_FAIL_REASON+=   "internal error: unsupported platform"
 
 BOOTSTRAP_TARBALL = ${DISTNAME}-boot-${PLATFORM}.tar.bz2
 
-pre-configure:
+pre-configure: ${WRKDIR}/stamp-bootstrap-ghc
+
+${WRKDIR}/stamp-prepare-bootstrap:
        ${RUN} cd ${WRKDIR} && \
                ${ECHO} "====> Preparing bootstrap compiler" && \
-               ${MKDIR} bootstrap && \
+               ${RM} -rf bootstrap && \
+               ${MKDIR} -p bootstrap && \
                ${CP} -r ${DISTNAME} bootstrap && \
                cd bootstrap/${DISTNAME} && \
-               ${LN} -sf ${PWD_CMD} utils/ghc-pwd/ghc-pwd && \
+               ${MKDIR} -p utils/ghc-pwd/dist-boot && \
+               ${LN} -sf ${PWD_CMD} utils/ghc-pwd/dist-boot/ghc-pwd && \
+               ${TOUCH} $@
+
+${WRKDIR}/stamp-configure-hc-boot: ${WRKDIR}/stamp-prepare-bootstrap
+       ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
                ${ECHO} "====> Configuring for bootstrap compiler" && \
                ${SETENV} ${CONFIGURE_ENV} ./configure --enable-hc-boot --with-ghc="" ${CONFIGURE_ARGS} && \
+               ${TOUCH} $@
+
+${WRKDIR}/stamp-extract-hc: ${WRKDIR}/stamp-configure-hc-boot
+       ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
                ${ECHO} "====> Extracting bootstrap HC archive" && \
                (cd .. && bsdtar jxfm ${DISTDIR}/${BOOTSTRAP_TARBALL}) && \
                ${SH} mkfiles && \
-               ${ECHO} "====> Building bootstrap compiler" && \
+               ${TOUCH} $@
+
+${WRKDIR}/stamp-rewrite-hc-paths: ${WRKDIR}/stamp-extract-hc
+       ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
+               ${ECHO} "====> Rewriting GHC source paths" && \
                ${SED} -e "s#\\[\\[PREFIX\\]\\]#${PREFIX}#g" ${BOOTSTRAP_BUILD_MK} > mk/build.mk && \
                for c in libraries/*/configure; do \
                        (cd `${DIRNAME} $$c` && ${SETENV} ${CONFIGURE_ENV} ${SH} configure ${CONFIGURE_ARGS}); \
                done && \
                for i in inplace/lib/package.conf.d/*.conf */*/package-data.mk */*/*/package-data.mk; do \
-                       ${SED} -e "s#\\[\\[GHC_SOURCE_PATH\\]\\]#`${PWD_CMD}`#g" $$i > $$i.tmp; \
+                       ${SED} -e "s#\\[\\[PREFIX\\]\\]#${PREFIX}#g" \
+                                  -e "s#\\[\\[GHC_SOURCE_PATH\\]\\]#`${PWD_CMD}`#g" $$i > $$i.tmp; \
                        ${MV} -f $$i.tmp $$i; \
                done && \
                ${TOUCH} -r inplace/lib/package.conf.d */*/package-data.mk */*/*/package-data.mk && \
+               ${TOUCH} $@
+
+${WRKDIR}/stamp-bootstrap-ghc: ${WRKDIR}/stamp-rewrite-hc-paths
+       ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
+               ${ECHO} "====> Building bootstrap compiler" && \
                ${GMAKE} bootstrapping-files && \
                ${GMAKE} all_ghc_stage2 && \
                ${GMAKE} inplace/bin/ghc-pkg && \
                ${GMAKE} inplace/lib/unlit && \
                inplace/bin/ghc-pkg recache && \
-               ${CP} inplace/bin/ghc-stage2 ${BUILDLINK_DIR}/bin/ghc && \
-               ${CP} inplace/bin/ghc-pkg ${BUILDLINK_DIR}/bin/ghc-pkg
+               ${CP} -f inplace/bin/ghc-stage2 ${BUILDLINK_DIR}/bin/ghc && \
+               ${CP} -f inplace/bin/ghc-pkg ${BUILDLINK_DIR}/bin/ghc-pkg && \
+               ${TOUCH} $@
 
 do-configure:
+# Seemingly by mistake, ghc-7.0.3 has a prebuilt
+# utils/ghc-pwd/dist-boot/ghc-pwd for amd64 GNU/Linux.
+       ${RUN} cd ${WRKSRC} && \
+               rm -rf utils/ghc-pwd/dist-boot
        ${RUN} cd ${WRKSRC} && \
                ${SETENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
-# We need to tell the libraries/integer-gmp/configure that libgmp is
+# We need to tell the libraries/terminfo/configure that our ncurses is
 # in a non-standard path. Without that, the resulting GHC tries to
 # link programs by executing ld(1) without passing it -L${PREFIX}/lib.
-       ${RUN} ${ECHO} "libraries/integer-gmp_CONFIGURE_OPTS += \
-               --configure-option=--with-gmp-includes=${PREFIX}/include \
-               --configure-option=--with-gmp-libraries=${PREFIX}/lib" > ${WRKSRC}/mk/build.mk
-# The ncurses is also in a non-standard path.
        ${RUN} ${ECHO} "libraries/terminfo_CONFIGURE_OPTS += \
                --configure-option=--with-curses-includes=${PREFIX}/include \
                --configure-option=--with-curses-libraries=${PREFIX}/lib" >> ${WRKSRC}/mk/build.mk
-# The ghc compiler does normally split the generated C files into small
+# The ghc compiler does normally split the generated asm files into small
 # parts before sending them to gcc, to enable the linker to eliminate
 # unused parts.  This does however not play nice with the pkgsrc
 # framework, and the result is that the build takes more than 5 times
@@ -153,12 +174,15 @@ do-configure:
        ${RUN} ${ECHO} "HSCOLOUR_SRCS = NO" >> ${WRKSRC}/mk/build.mk
 # To avoid powerpc crash...
 # See http://hackage.haskell.org/trac/ghc/ticket/4034
-.if ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
-       ${RUN} ${ECHO} "GhcRtsHcOpts = -optc-O0 -optc-g" >> ${WRKSRC}/mk/build.mk
-       ${RUN} ${ECHO} "GhcRtsCcOpts = -O0 -g" >> ${WRKSRC}/mk/build.mk
-.endif
+#.if ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
+#      ${RUN} ${ECHO} "GhcRtsHcOpts = -optc-O0 -optc-g" >> ${WRKSRC}/mk/build.mk
+#      ${RUN} ${ECHO} "GhcRtsCcOpts = -O0 -g" >> ${WRKSRC}/mk/build.mk
+#.endif
+
+# Substitutions for INSTALL and DEINSTALL.
+FILES_SUBST+=  DISTNAME=${DISTNAME}
 
-# Some unused scripts don't pass the portability test.
+# There is an unused script which don't pass the portability test.
 CHECK_PORTABILITY_SKIP+=       distrib/prep-bin-dist-mingw
 
 # GHC currently *requires* ${PREFIX}/lib to be in